Bug 855477 - Many icons missing when running anaconda within a live Xfce image
Many icons missing when running anaconda within a live Xfce image
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
18
All All
unspecified Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F18Alpha-accepted/F18AlphaFreezeExcept
  Show dependency treegraph
 
Reported: 2012-09-07 19:21 EDT by Adam Williamson
Modified: 2012-09-12 02:43 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-12 02:43:44 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Adam Williamson 2012-09-07 19:21:32 EDT
I just span up an Xfce live image for some testing, with latest anaconda (18.6.6). I was actually able to complete an install, at last. However, I noticed all the icons on the hub screen show up as the 'icon missing' red X-on white background, as does the icon below the progress bar of the installation step. On the disks spoke, an icon is used to represent my disk, but it's some tiny icon that's been blown up way bigger than was intended.

I think anaconda needs another dep, on whatever provides the icons it expects to use...
Comment 1 Adam Williamson 2012-09-07 19:45:48 EDT
Proposing as NTH for Alpha - this is just cosmetic, but it looks pretty crappy.
Comment 2 Adam Williamson 2012-09-07 19:49:59 EDT
screenshot - http://www.happyassassin.net/extras/newui_xfce.png

also note the virtually unreadable text for the spoke 'subheads' - grey on a slightly different grey. even worse for the spoke that's highlighted.
Comment 3 Chris Lumens 2012-09-08 18:31:47 EDT
Looks like a theme-related problem might be missing.  There's lots of bad stuff going on there.
Comment 4 Chris Lumens 2012-09-09 15:38:45 EDT
*** Bug 855638 has been marked as a duplicate of this bug. ***
Comment 5 Chris Lumens 2012-09-11 14:13:46 EDT
I don't see this with http://alt.fedoraproject.org/pub/alt/stage/18-Alpha-RC2/Live/x86_64/Fedora-18-Alpha-x86_64-Live-XFCE.iso.  It looks like it does everywhere else.  Perhaps there was something wrong with the compose process?
Comment 6 Adam Williamson 2012-09-12 02:43:44 EDT
Yeah, I agree. I think it was just an issue with my compose; probably it suffered from the comps/spin-kickstarts mismatch. Closing. RC2 is fine.

Note You need to log in before you can comment on or make changes to this bug.