Bug 855541 - [abrt] libreoffice-core-3.5.6.2-2.fc17: multi-threaded XIOError segv
[abrt] libreoffice-core-3.5.6.2-2.fc17: multi-threaded XIOError segv
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: libreoffice (Show other bugs)
17
i686 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Caolan McNamara
Fedora Extras Quality Assurance
abrt_hash:fb7c7f4de5f534a1d96e9fb18ac...
:
: 820074 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-08 15:14 EDT by Sergey Kurtsev
Modified: 2012-12-20 11:11 EST (History)
8 users (show)

See Also:
Fixed In Version: libreoffice-3.5.6.2-5.fc17
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-20 11:11:28 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
File: core_backtrace (848 bytes, text/plain)
2012-09-08 15:15 EDT, Sergey Kurtsev
no flags Details
File: environ (1.73 KB, text/plain)
2012-09-08 15:15 EDT, Sergey Kurtsev
no flags Details
File: limits (1.29 KB, text/plain)
2012-09-08 15:15 EDT, Sergey Kurtsev
no flags Details
File: backtrace (37.39 KB, text/plain)
2012-09-08 15:15 EDT, Sergey Kurtsev
no flags Details
File: cgroup (126 bytes, text/plain)
2012-09-08 15:15 EDT, Sergey Kurtsev
no flags Details
File: maps (63.47 KB, text/plain)
2012-09-08 15:15 EDT, Sergey Kurtsev
no flags Details
File: dso_list (22.64 KB, text/plain)
2012-09-08 15:15 EDT, Sergey Kurtsev
no flags Details
File: var_log_messages (321 bytes, text/plain)
2012-09-08 15:15 EDT, Sergey Kurtsev
no flags Details
File: open_fds (344 bytes, text/plain)
2012-09-08 15:15 EDT, Sergey Kurtsev
no flags Details

  None (edit)
Description Sergey Kurtsev 2012-09-08 15:14:59 EDT
Version-Release number of selected component:
libreoffice-core-3.5.6.2-2.fc17

Additional info:
libreport version: 2.0.13
abrt_version:   2.0.12
backtrace_rating: 4
cmdline:        /usr/lib/libreoffice/program/soffice.bin --writer --splash-pipe=6
crash_function: exit
kernel:         3.5.3-1.fc17.i686.PAE

truncated backtrace:
:Thread no. 1 (6 frames)
: #1 exit at exit.c
: #2 gdk_x_io_error at gdkmain-x11.c
: #3 _XIOError at XlibInt.c
: #5 XGetSelectionOwner at GetSOwner.c
: #6 x11::SelectionManager::run at /usr/src/debug/libreoffice-3.5.6.2/vcl/unx/generic/dtrans/X11_selection.cxx
: #7 osl_thread_start_Impl at thread.c
Comment 1 Sergey Kurtsev 2012-09-08 15:15:02 EDT
Created attachment 611045 [details]
File: core_backtrace
Comment 2 Sergey Kurtsev 2012-09-08 15:15:04 EDT
Created attachment 611046 [details]
File: environ
Comment 3 Sergey Kurtsev 2012-09-08 15:15:07 EDT
Created attachment 611047 [details]
File: limits
Comment 4 Sergey Kurtsev 2012-09-08 15:15:09 EDT
Created attachment 611048 [details]
File: backtrace
Comment 5 Sergey Kurtsev 2012-09-08 15:15:11 EDT
Created attachment 611049 [details]
File: cgroup
Comment 6 Sergey Kurtsev 2012-09-08 15:15:14 EDT
Created attachment 611050 [details]
File: maps
Comment 7 Sergey Kurtsev 2012-09-08 15:15:16 EDT
Created attachment 611051 [details]
File: dso_list
Comment 8 Sergey Kurtsev 2012-09-08 15:15:19 EDT
Created attachment 611052 [details]
File: var_log_messages
Comment 9 Sergey Kurtsev 2012-09-08 15:15:21 EDT
Created attachment 611053 [details]
File: open_fds
Comment 10 Caolan McNamara 2012-09-10 05:56:21 EDT
There was an XIOError which typically is "the X server went away" while the app was running and we can do nothing about that. There appears then to be a segv during the unexpected shutdown
Comment 11 Caolan McNamara 2012-09-10 18:10:39 EDT
hmm, two threads, both get the XIOError, both call the default gdk xioerror handler which isn't prepared for that. Safest solution might be to install our own xioerror handler which discards xioerrors from the non-main thread.
Comment 12 Caolan McNamara 2012-09-11 06:38:38 EDT
*** Bug 820074 has been marked as a duplicate of this bug. ***
Comment 13 Caolan McNamara 2012-09-12 09:08:56 EDT
tweaked the XIOError handler to hopefully avoid this double exit problem. Will be in >= libreoffice-3.5.6.2-5.fc17
Comment 14 Fedora Update System 2012-09-26 04:21:38 EDT
libreoffice-3.5.6.2-5.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/libreoffice-3.5.6.2-5.fc17
Comment 15 Fedora Update System 2012-09-27 00:30:16 EDT
Package libreoffice-3.5.6.2-5.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing libreoffice-3.5.6.2-5.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-14896/libreoffice-3.5.6.2-5.fc17
then log in and leave karma (feedback).
Comment 16 Fedora Update System 2012-12-20 11:11:32 EST
libreoffice-3.5.6.2-5.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.