Bug 820074 - [abrt] libreoffice-core-3.5.2.1-6.fc17: XIOError killed by signal 11 (SIGSEGV)
[abrt] libreoffice-core-3.5.2.1-6.fc17: XIOError killed by signal 11 (SIGSEGV)
Status: CLOSED DUPLICATE of bug 855541
Product: Fedora
Classification: Fedora
Component: libreoffice (Show other bugs)
17
i686 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Caolan McNamara
Fedora Extras Quality Assurance
abrt_hash:c17c0ece727c76a1df7d7bce54e...
:
: 887985 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-09 01:08 EDT by Mikhail
Modified: 2012-12-18 03:09 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-11 06:38:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (31.62 KB, text/plain)
2012-05-09 01:08 EDT, Mikhail
no flags Details
File: maps (56.13 KB, text/plain)
2012-05-09 01:08 EDT, Mikhail
no flags Details
File: dso_list (19.31 KB, text/plain)
2012-05-09 01:09 EDT, Mikhail
no flags Details
File: build_ids (7.49 KB, text/plain)
2012-05-09 01:09 EDT, Mikhail
no flags Details

  None (edit)
Description Mikhail 2012-05-09 01:08:46 EDT
libreport version: 2.0.10
abrt_version:   2.0.10
backtrace_rating: 4
cmdline:        /usr/lib/libreoffice/program/soffice.bin --calc file:///home/mikhail/.cache/evolution/tmp/evolution-mikhail-9oUgWe/%D0%9F%D1%80%D0%BE%D1%81%D1%81%D1%80%D0%BE%D1%87%D0%BA%D0%B8%20%D0%BD%D0%B0%2002052012.xls --splash-pipe=6
crash_function: __GI_exit
executable:     /usr/lib/libreoffice/program/soffice.bin
kernel:         3.3.4-1.fc17.i686.PAE
pid:            21757
pwd:            /home/mikhail
remote_result:  681373
time:           Ср. 02 мая 2012 15:28:04
uid:            1000
username:       mikhail
xsession_errors: 

backtrace:      Text file, 32381 bytes
build_ids:      Text file, 7667 bytes
dso_list:       Text file, 19775 bytes
maps:           Text file, 57473 bytes

cgroup:
:9:perf_event:/
:8:blkio:/
:7:net_cls:/
:6:freezer:/
:5:devices:/
:4:memory:/
:3:cpuacct,cpu:/
:2:cpuset:/
:1:name=systemd:/user/mikhail/2

core_backtrace:
:- 0x0 - - -
:8977b8492e9b9e203c5e53dccd30adf441420b99 0x31cc1 __run_exit_handlers libc.so.6 -
:8977b8492e9b9e203c5e53dccd30adf441420b99 0x31d4d exit libc.so.6 -
:ff7cd1ed03a87c0eb8d530d46fac1fcec5caf45d 0x674e4 - libgdk-x11-2.0.so.0 -
:030b5d1726ecd29df95bdeeff0b2d62043833fee 0x3d4e5 _XIOError libX11.so.6 -
:030b5d1726ecd29df95bdeeff0b2d62043833fee 0x3accf _XEventsQueued libX11.so.6 -
:030b5d1726ecd29df95bdeeff0b2d62043833fee 0x2b578 XPending libX11.so.6 -
:ff7cd1ed03a87c0eb8d530d46fac1fcec5caf45d 0x5aa48 - libgdk-x11-2.0.so.0 -
:ff7cd1ed03a87c0eb8d530d46fac1fcec5caf45d 0x5aad3 - libgdk-x11-2.0.so.0 -
:e22e1e456283c0cdf171447a61c4f04e354f8b2a 0x46cb3 g_main_context_check libglib-2.0.so.0 -
:e22e1e456283c0cdf171447a61c4f04e354f8b2a 0x472a2 - libglib-2.0.so.0 -
:e22e1e456283c0cdf171447a61c4f04e354f8b2a 0x47472 g_main_context_iteration libglib-2.0.so.0 -
:b77ceec77747ce7d2a375fd84540094150d70025 0x2971b - libvclplug_gtklo.so -
:b77ceec77747ce7d2a375fd84540094150d70025 0x2a74f - libvclplug_gtklo.so -
:4021626053c8409788f135f16e4b748dd01f640a 0xbd49b Application::Yield(bool) libvcllo.so -
:4021626053c8409788f135f16e4b748dd01f640a 0xbd54c Application::Execute() libvcllo.so -
:47bc8d80b68563a1b2e4fdc0777e1d2bfa53e9b8 0x1a6ad - libsofficeapp.so -
:4021626053c8409788f135f16e4b748dd01f640a 0xc476a - libvcllo.so -
:4021626053c8409788f135f16e4b748dd01f640a 0xc4825 SVMain() libvcllo.so -
:47bc8d80b68563a1b2e4fdc0777e1d2bfa53e9b8 0x429c3 soffice_main libsofficeapp.so -
:f9baea2a8cca1560040b4a816fd0bf5c33769f7a 0x57e - [exe] -

environ:
:XDG_VTNR=1
:XDG_SESSION_ID=2
:HOSTNAME=telecon17l.afbank.ru
:LC_MONETARY=ru_RU.utf8
:IMSETTINGS_INTEGRATE_DESKTOP=yes
:GIO_LAUNCHED_DESKTOP_FILE_PID=21743
:GPG_AGENT_INFO=/run/user/mikhail/keyring-wwPRnX/gpg:0:1
:SHELL=/bin/bash
:TERM=dumb
:DESKTOP_STARTUP_ID=evolution-1521-telecon17l.afbank.ru-libreoffice-0_TIME17537741
:HISTSIZE=1000
:XDG_SESSION_COOKIE=928ad44a76a7008e0260558b00000016-1335931037.464729-423705319
:GJS_DEBUG_OUTPUT=stderr
:LC_NUMERIC=ru_RU.utf8
:OLDPWD=/usr/lib/libreoffice/program
:GNOME_KEYRING_CONTROL=/run/user/mikhail/keyring-wwPRnX
:'GJS_DEBUG_TOPICS=JS ERROR;JS LOG'
:IMSETTINGS_MODULE=none
:USER=mikhail
:SSH_AUTH_SOCK=/run/user/mikhail/keyring-wwPRnX/ssh
:USERNAME=mikhail
:SESSION_MANAGER=local/unix:@/tmp/.ICE-unix/1026,unix/unix:/tmp/.ICE-unix/1026
:GIO_LAUNCHED_DESKTOP_FILE=/usr/share/applications/libreoffice-calc.desktop
:MAIL=/var/spool/mail/mikhail
:PATH=/usr/local/bin:/usr/bin:/bin:/usr/local/sbin:/usr/sbin:/home/mikhail/.local/bin:/home/mikhail/bin
:DESKTOP_SESSION=gnome
:QT_IM_MODULE=xim
:PWD=/home/mikhail
:XMODIFIERS=@im=none
:GNOME_KEYRING_PID=1021
:LANG=en_US.UTF-8
:LC_MEASUREMENT=ru_RU.utf8
:GDMSESSION=gnome
:HISTCONTROL=ignoredups
:XDG_SEAT=seat0
:HOME=/home/mikhail
:SHLVL=1
:GNOME_DESKTOP_SESSION_ID=this-is-deprecated
:SAL_ENABLE_FILE_LOCKING=1
:LOGNAME=mikhail
:DBUS_SESSION_BUS_ADDRESS=unix:abstract=/tmp/dbus-zZ8Gr8CJhj,guid=90b5c499e3884f880164875f0000023b
:'LESSOPEN=||/usr/bin/lesspipe.sh %s'
:WINDOWPATH=1
:XDG_RUNTIME_DIR=/run/user/mikhail
:DISPLAY=:0
:LC_TIME=ru_RU.utf8
:XAUTHORITY=/var/run/gdm/auth-for-mikhail-LWFy1R/database
:LD_LIBRARY_PATH=/usr/lib/jvm/java-1.7.0-openjdk-1.7.0.3/jre/lib/i386/client:/usr/lib/jvm/java-1.7.0-openjdk-1.7.0.3/jre/lib/i386/server:/usr/lib/jvm/java-1.7.0-openjdk-1.7.0.3/jre/lib/i386/native_threads:/usr/lib/jvm/java-1.7.0-openjdk-1.7.0.3/jre/lib/i386

limits:
:Limit                     Soft Limit           Hard Limit           Units     
:Max cpu time              unlimited            unlimited            seconds   
:Max file size             unlimited            unlimited            bytes     
:Max data size             unlimited            unlimited            bytes     
:Max stack size            8388608              unlimited            bytes     
:Max core file size        0                    unlimited            bytes     
:Max resident set          unlimited            unlimited            bytes     
:Max processes             1024                 15713                processes 
:Max open files            4096                 4096                 files     
:Max locked memory         65536                65536                bytes     
:Max address space         unlimited            unlimited            bytes     
:Max file locks            unlimited            unlimited            locks     
:Max pending signals       15713                15713                signals   
:Max msgqueue size         819200               819200               bytes     
:Max nice priority         0                    0                    
:Max realtime priority     0                    0                    
:Max realtime timeout      unlimited            unlimited            us        

open_fds:
:0:/dev/null
:pos:	0
:flags:	0100000
:1:/home/mikhail/.xsession-errors
:pos:	4538515
:flags:	02002
:2:/home/mikhail/.xsession-errors
:pos:	4538515
:flags:	02002
:3:socket:[3084337]
:pos:	0
:flags:	02004002
:4:anon_inode:[eventfd]
:pos:	0
:flags:	02004002
:5:pipe:[3082634]
:pos:	0
:flags:	00
:6:pipe:[3082634]
:pos:	0
:flags:	01
:7:socket:[3084361]
:pos:	0
:flags:	02000002
:8:socket:[3084362]
:pos:	0
:flags:	02000002

smolt_data:
:
:
:General
:=================================
:UUID: 24b82623-fdb0-487f-b726-0d6b01472500
:OS: Fedora release 17 (Beefy Miracle)
:Default run level: Unknown
:Language: en_US.UTF-8
:Platform: i686
:BogoMIPS: 4787.56
:CPU Vendor: GenuineIntel
:CPU Model: Intel(R) Core(TM)2 Duo CPU     E4600  @ 2.40GHz
:CPU Stepping: 13
:CPU Family: 6
:CPU Model Num: 15
:Number of CPUs: 2
:CPU Speed: 2400
:System Memory: 1980
:System Swap: 3999
:Vendor: Unknown
:System:  
:Form factor: Unknown
:Kernel: 3.3.4-3.fc17.i686.PAE
:SELinux Enabled: 1
:SELinux Policy: targeted
:SELinux Enforce: Enforcing
:MythTV Remote: Unknown
:MythTV Role: Unknown
:MythTV Theme: Unknown
:MythTV Plugin: 
:MythTV Tuner: -1
:
:
:Devices
:=================================
:(32902:10672:32902:20298) pci, None, HOST/PCI, 82Q35 Express DRAM Controller
:(32902:10673:32902:20298) pci, pcieport, PCI/PCI, 82Q35 Express PCI Express Root Port
:(4523:24833:4523:24833) pci, pata_marvell, STORAGE, 88SE6101/6102 single-port PATA133 interface
:(32902:10544:32902:20298) pci, i801_smbus, SERIAL, 82801I (ICH9 Family) SMBus Controller
:(32902:10530:32902:20298) pci, ahci, STORAGE, 82801IR/IO/IH (ICH9R/DO/DH) 6 port SATA AHCI Controller
:(32902:10516:32902:20298) pci, None, PCI/ISA, 82801IO (ICH9DO) LPC Interface Controller
:(32902:4285:32902:1) pci, e1000e, ETHERNET, 82566DM-2 Gigabit Network Connection
:(32902:9294:32902:20298) pci, None, PCI/PCI, 82801 PCI Bridge
:(32902:10549:32902:20298) pci, uhci_hcd, USB, 82801I (ICH9 Family) USB UHCI Controller #2
:(32902:10548:32902:20298) pci, uhci_hcd, USB, 82801I (ICH9 Family) USB UHCI Controller #1
:(32902:10553:32902:20298) pci, uhci_hcd, USB, 82801I (ICH9 Family) USB UHCI Controller #6
:(32902:10550:32902:20298) pci, uhci_hcd, USB, 82801I (ICH9 Family) USB UHCI Controller #3
:(32902:10554:32902:20298) pci, ehci_hcd, USB, 82801I (ICH9 Family) USB2 EHCI Controller #1
:(32902:10556:32902:20298) pci, ehci_hcd, USB, 82801I (ICH9 Family) USB2 EHCI Controller #2
:(32902:10564:32902:10564) pci, pcieport, PCI/PCI, 82801I (ICH9 Family) PCI Express Port 3
:(32902:10566:32902:10566) pci, pcieport, PCI/PCI, 82801I (ICH9 Family) PCI Express Port 4
:(32902:10560:32902:10560) pci, pcieport, PCI/PCI, Optiplex 755
:(32902:10562:32902:10562) pci, pcieport, PCI/PCI, 82801I (ICH9 Family) PCI Express Port 2
:(32902:10676:32902:20298) pci, None, SIMPLE, 82Q35 Express MEI Controller
:(32902:10568:32902:10568) pci, pcieport, PCI/PCI, 82801I (ICH9 Family) PCI Express Port 5
:(32902:10558:32902:18) pci, snd_hda_intel, MULTIMEDIA, 82801I (ICH9 Family) HD Audio Controller
:(32902:10551:32902:20298) pci, uhci_hcd, USB, 82801I (ICH9 Family) USB UHCI Controller #4
:(32902:10552:32902:20298) pci, uhci_hcd, USB, 82801I (ICH9 Family) USB UHCI Controller #5
:(4098:43664:5963:43664) pci, snd_hda_intel, MULTIMEDIA, N/A
:(4098:26457:5963:57747) pci, radeon, VIDEO, NI Turks [AMD Radeon HD 6500]
:(4545:22545:4545:22545) pci, firewire_ohci, FIREWIRE, FW322/323
:
:
:Filesystem Information
:=================================
:device mtpt type bsize frsize blocks bfree bavail file ffree favail
:-------------------------------------------------------------------
:/dev/sda1 / ext4 4096 4096 5112811 2631031 2579838 1286144 1016648 1016648
:/dev/sda5 /home ext4 4096 4096 27766364 3524472 2134085 6955008 6873675 6873675
:

var_log_messages:
:May  2 15:28:01 telecon17l kernel: [20413.669503] soffice.bin[21757]: segfault at 176b80b4 ip 176b80b4 sp bf873edc error 14 in libibus-1.0.so.5.0.499[41000000+4f000]
:May  2 15:28:19 telecon17l abrt[24500]: Saved core dump of pid 21757 (/usr/lib/libreoffice/program/soffice.bin) to /var/spool/abrt/ccpp-2012-05-02-15:28:03-21757 (80531456 bytes)
Comment 1 Mikhail 2012-05-09 01:08:52 EDT
Created attachment 583134 [details]
File: backtrace
Comment 2 Mikhail 2012-05-09 01:08:57 EDT
Created attachment 583135 [details]
File: maps
Comment 3 Mikhail 2012-05-09 01:09:00 EDT
Created attachment 583137 [details]
File: dso_list
Comment 4 Mikhail 2012-05-09 01:09:03 EDT
Created attachment 583138 [details]
File: build_ids
Comment 5 Caolan McNamara 2012-05-09 06:46:01 EDT
XIOError suggests that the X Server "went away" while the application was still running. 

Does this happen on a regular basis or was it just a once off ? I imagine you saw the abrt message on logging in, but do you remember if the previous session crashed or was it a normal logout or shutdown ?
Comment 6 Caolan McNamara 2012-09-11 06:38:37 EDT
Might be a bit of a stretch to state that this is a dup of bug 855541, but its a little plausible

*** This bug has been marked as a duplicate of bug 855541 ***
Comment 7 Stephan Bergmann 2012-12-18 03:09:35 EST
*** Bug 887985 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.