Bug 855849 - could not UEFI boot F18 Alpha (TC6 through RC3) DVD or netinst written to optical disc or dd'ed to USB: /dev/root does not exist
could not UEFI boot F18 Alpha (TC6 through RC3) DVD or netinst written to opt...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: grub2 (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Peter Jones
Fedora Extras Quality Assurance
https://fedoraproject.org/wiki/Common...
: CommonBugs
: 856922 (view as bug list)
Depends On:
Blocks: F18Beta/F18BetaBlocker
  Show dependency treegraph
 
Reported: 2012-09-10 07:55 EDT by Jan Sedlák
Modified: 2012-10-22 19:48 EDT (History)
18 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-04 14:46:14 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
picture of warning (1.73 MB, image/jpeg)
2012-09-10 07:55 EDT, Jan Sedlák
no flags Details
output from journalctl --all (6.96 KB, text/plain)
2012-09-13 16:38 EDT, John Reiser
no flags Details
ls -R / (578.91 KB, text/plain)
2012-09-13 16:38 EDT, John Reiser
no flags Details

  None (edit)
Description Jan Sedlák 2012-09-10 07:55:18 EDT
Created attachment 611409 [details]
picture of warning

Description of problem:
When trying to boot Fedora 18 Alpha TC6 DVD install using UEFI on my ThinkPad T420s, boot fails with messages:
dracut-initqueue: Warning: Could not boot
dracut-initqueue: Warning: /dev/root does not exist 

Steps to Reproduce:
1. Boot Fedora F18 Alpha TC6
  
Actual results:
It fails to boot.

Expected results:
It should boot.

Additional info:
See attached image.
Comment 1 John Reiser 2012-09-10 23:00:43 EDT
I see the same symptom on ASUS mainboard, using physical DVD of Fedora 18-Alpha-RC1 netinst.iso
Comment 2 Jan Sedlák 2012-09-11 04:24:30 EDT
My smolt profile: http://www.smolts.org/client/show/pub_a0f8be89-b530-4af5-a50a-e1d06c11b3cb
Comment 3 Brian Lane 2012-09-11 16:18:37 EDT
Please retry with RC2.
Comment 4 John Reiser 2012-09-11 16:34:19 EDT
The same problem persists in RC2 using physical DVD from x86_64 netinst.iso.
Comment 5 Kamil Páral 2012-09-13 05:19:18 EDT
*** Bug 856922 has been marked as a duplicate of this bug. ***
Comment 6 Adam Williamson 2012-09-13 06:26:22 EDT
This also happens if you try and boot native UEFI from a dd'ed USB stick (dd if=Fedora-18-Alpha-x86_64-DVD.iso of=/dev/sdc ). So to tot up, this affects netinst and DVD whether written to a shiny disc or dd'ed, but *not* written with livecd-iso-to-disk (in that case anaconda starts and works, but you hit the later bug where the installed system doesn't boot). Adjusting summary.
Comment 7 Brian Lane 2012-09-13 11:52:07 EDT
This appears to be a grub2 bug. /proc/cmdline has the \ stripped out so the LABEL with the spaces has x20

Why the heck are we using spaces in the label in the first place? Spaces cause no end of trouble everywhere they are used. Just use underscores.
Comment 8 Mads Kiilerich 2012-09-13 16:17:41 EDT
Please describe the problem in more details.

What is in grub.cfg?

How is the grub.cfg created? grub2-mkconfig will not use labels.
Comment 9 John Reiser 2012-09-13 16:36:44 EDT
1. Burn Fedora-18-Alpha-x86_64-netinst.iso to DVD.
2. Boot the DVD in UEFI mode on a machine with ASUS mainboard with UEFI BIOS.
3. Wait.
4. Console displays:
   dracut-initqueue: Warning: Could not boot
   dracut-initqueue: Warning: /dev/root does not exist
and then dracut gives you an emergency shell.

There is no grub.cfg anywhere in the filesystem.
I will attach the output from "journalctl --all" and "ls -R /".
Comment 10 John Reiser 2012-09-13 16:38:22 EDT
Created attachment 612629 [details]
output from journalctl --all

Sep 13 20:26:02 localhost systemd-udevd[357]: failed to execute '/usr/lib/systemd/systemd-sysctl' '/usr/lib/systemd/systemd-sysctl --prefix=/proc/sys/net/ipv4/conf/em1 --prefix=/proc/sys/net/ipv4/neigh/em1 --prefix=/proc/sys/net/ipv6/conf/em1 --prefix=/proc/sys/net/ipv6/neigh/em1': No such file or directory
Comment 11 John Reiser 2012-09-13 16:38:50 EDT
Created attachment 612630 [details]
ls -R /
Comment 12 John Reiser 2012-09-13 16:42:29 EDT
(In reply to comment #9)
> 1. Burn Fedora-18-Alpha-x86_64-netinst.iso to DVD.

-RC3
Comment 13 Mads Kiilerich 2012-09-13 17:27:34 EDT
[I don't have a real efi system for testing, but I know grub and can triage.]

There _must_ be a .efi and grub.cfg somewhere on the boot media ... but probably in some hidden iso9660 boot section.

A first indication on this issue of what the problem is:
/dev/disk/by-label/Fedora\x2018\x20x86_64

What is in /proc/cmdline?
Comment 14 John Reiser 2012-09-13 18:31:03 EDT
In the dracut emergency shell:
# cat /proc/cmdline
BOOT_IMAGE=/images/pxeboot/vmlinuz inst.stage2=hd:LABEL=Fedorax2018x20x86_64
# ls /dev/disk/by-label
Fedora\x2018\x20x86_64    <<also labels from harddrive partition>>
# 

There are no backslashes '\\' in /proc/cmdline.  There are two backslashes in /dev/disk/by-label; both of them are in substrings "\x20" which means " ", namely a <Space> character.
Comment 15 John Reiser 2012-09-13 18:37:43 EDT
During booting, the VGA console displays "Welcome to GRUB", followed by a Grub menu and a one-minute countdown timer.  There are to items in the menu.  The first is "Fedora 18" and the second is "Test this media & start Fedora".

-----Fedora:
setparams 'Fedora 18'

        linuxefi /images/pxeboot/vmlinuz inst.stage2=hd:LABEL=Fedora\x2018\x20x86_64
        initrdefi /images/pxeboot/initrd.img
-----

-----Test this media & start Fedora:
setparams 'Test this media & Fedora'

        linuxefi /images/pxeboot/vmlinuz inst.stage2=hd:LABEL=Fedora\x2018\x20x86_64 quiet rd.live.check
        initrdefi /images/pxeboot/initrd.img
-----
Comment 16 John Reiser 2012-09-13 18:41:49 EDT
Corrections: the Grub timeout is only 5 (five) seconds. There are "two" items in the menu.  The expansion of the second menu item begins "setparams 'Test this media & start Fedora'".
Comment 17 Mads Kiilerich 2012-09-13 18:43:35 EDT
The grub.cfg language is very similar to sh. \ is probably processed like shells will process it. '\x' is an invalid escape sequence and it will be read as 'x'.

What happens if you edit the entry to something like
  Fedora\\x2018\\x20x86_64
and boot?
Comment 18 John Reiser 2012-09-13 18:55:46 EDT
Editing the grub entry so that the name reads
  Fedora\\x2018\\x20x86_64
followed by boot (<F10>) gets the same dracut error: /dev/root does not exist.
In the dracut emergency shell,
# cat /proc/cmdline
BOOT_IMAGE=/images/pxeboot/vmlinuz inst.stage2=hd:LABEL=Fedora\\x2018\\x20x86_64
# ls /dev/disk/by-label
Fedora\x2018\x20x86_64    <<also labels from harddrive partition>>
# 

So /proc/cmdline has "doubled backslashes" (two consecutive backslash characters, in two places.)
Comment 19 Mads Kiilerich 2012-09-13 19:58:08 EDT
Thanks, that demonstrates the problem.
Comment 20 Andre Robatino 2012-09-19 18:17:56 EDT
This also affects VirtualBox 4.2.0 with EFI enabled, booting from the ISO file. DVD and netinst both fail as described. The live image seems to be hung in the boot process, using 100% CPU. Not sure if it will continue since it's very slow.
Comment 21 Adam Williamson 2012-09-19 18:52:32 EDT
yeah, I would expect that. When you use a VM to boot an image you're effectively booting from a shiny spinny DVD: the virtual system has a virtual DVD drive.
Comment 22 Reartes Guillermo 2012-09-24 18:46:28 EDT
I get the same issue with F18a RC3, affected (ASUS) system:

$ cat /sys/devices/virtual/dmi/id/board_name 
SABERTOOTH 990FX

$ cat /sys/devices/virtual/dmi/id/bios_version 
1304

Also, on my Dell e4310 it just does not work. It used to work (now i get a black screen then and then it returns to the boot menu), but it is definitivelly 
a separate issue from the one discussed here.
Comment 23 Adam Williamson 2012-09-26 14:44:15 EDT
Discussed at 2012-09-26 blocker review meeting: http://meetbot.fedoraproject.org/fedora-qa/2012-09-26/f18-beta-blocker-review-1.2012-09-26-16.03.log.txt . Accepted as a blocker per Beta criterion "The installer must boot (if appropriate) and run on all primary architectures, with all system firmware types that are common on those architectures, from default live image, DVD, and boot.iso install media when written to a USB stick with any of the officially supported methods", we don't consider 'write it another way' an acceptable workaround for Beta. The bug here seems to be well known already, it's to do with the spaces in the volume label.
Comment 24 Mads Kiilerich 2012-09-26 14:57:02 EDT
This is a grub2 bug, but in a pretty obscure corner case.

I would recommend solving the current blocker status by working around the issue by using labels without spaces.
Comment 25 Adam Williamson 2012-09-28 19:59:40 EDT
just to poke this one, still valid with the latest pre-beta smoketest build (smoke3). no-one's done anything about this yet, it seems.
Comment 26 Fedora Update System 2012-10-01 14:04:46 EDT
grub2-2.00-9.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/grub2-2.00-9.fc18
Comment 27 John Reiser 2012-10-01 15:47:41 EDT
grub2-2.00-9.fc18 fixed this problem for me.
Comment 28 Fedora Update System 2012-10-01 16:03:08 EDT
Package grub2-2.00-9.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing grub2-2.00-9.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-15149/grub2-2.00-9.fc18
then log in and leave karma (feedback).
Comment 29 Adam Williamson 2012-10-02 02:41:13 EDT
Yup, test image tflink built boots fine when dd'ed to USB for me. I confirmed the test image does have spaces in the partition label.
Comment 30 Adam Williamson 2012-10-04 14:46:14 EDT
Update was pushed stable on 10-03, closing.
Comment 31 Pavel Rosenboim 2012-10-21 10:19:12 EDT
Beta TC6 still doesn't boot with same error for me.
Comment 32 Adam Williamson 2012-10-22 19:48:55 EDT
The error message is a very generic one. The fact that you see it doesn't necessarily mean you hit this bug. Please file a new bug with more details on exactly what process you followed and if possible a picture of the screen you see at failure time.

Note You need to log in before you can comment on or make changes to this bug.