Bug 855950 - [abrt] yum-3.4.3-29.fc17: os.py:157:makedirs:OSError: [Errno 13] Permission denied: '/var/cache/yum/x86_64/17/fedora/gen' [NEEDINFO]
[abrt] yum-3.4.3-29.fc17: os.py:157:makedirs:OSError: [Errno 13] Permission d...
Status: CLOSED DUPLICATE of bug 854974
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
17
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Fedora Packaging Toolset Team
Fedora Extras Quality Assurance
abrt_hash:6f29e69bf3765d03b27e205375f...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-10 13:36 EDT by Jose Francisco Beltran Neira
Modified: 2014-01-21 18:23 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-11 03:20:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
zpavlas: needinfo?


Attachments (Terms of Use)
File: core_backtrace (1.38 KB, text/plain)
2012-09-10 13:36 EDT, Jose Francisco Beltran Neira
no flags Details

  None (edit)
Description Jose Francisco Beltran Neira 2012-09-10 13:36:56 EDT
Version-Release number of selected component:
yum-3.4.3-29.fc17

Additional info:
libreport version: 2.0.13
abrt_version:   2.0.12
cmdline:        /usr/bin/python -t /usr/share/yum-cli/completion-helper.py -d 0 -C list available openvswitch
kernel:         3.3.4-5.fc17.x86_64

backtrace:
:os.py:157:makedirs:OSError: [Errno 13] Permission denied: '/var/cache/yum/x86_64/17/fedora/gen'
:
:Traceback (most recent call last):
:  File "/usr/share/yum-cli/completion-helper.py", line 89, in <module>
:    main(sys.argv[1:])
:  File "/usr/share/yum-cli/completion-helper.py", line 83, in main
:    base.doCommands()
:  File "/usr/share/yum-cli/cli.py", line 485, in doCommands
:    return self.yum_cli_commands[self.basecmd].doCommand(self, self.basecmd, self.extcmds)
:  File "/usr/share/yum-cli/completion-helper.py", line 45, in doCommand
:    patterns=[get_pattern(extcmds)])
:  File "/usr/lib/python2.7/site-packages/yum/__init__.py", line 2709, in doPackageLists
:    avail = self.pkgSack.returnNewestByNameArch(patterns=patterns,
:  File "/usr/lib/python2.7/site-packages/yum/__init__.py", line 1015, in <lambda>
:    pkgSack = property(fget=lambda self: self._getSacks(),
:  File "/usr/lib/python2.7/site-packages/yum/__init__.py", line 779, in _getSacks
:    self.repos.populateSack(which=repos)
:  File "/usr/lib/python2.7/site-packages/yum/repos.py", line 309, in populateSack
:    self.doSetup()
:  File "/usr/lib/python2.7/site-packages/yum/repos.py", line 135, in doSetup
:    self.ayum.plugins.run('postreposetup')
:  File "/usr/lib/python2.7/site-packages/yum/plugins.py", line 187, in run
:    func(conduitcls(self, self.base, conf, **kwargs))
:  File "/usr/lib/yum-plugins/langpacks.py", line 73, in postreposetup_hook
:    infile = repo.getGroups()
:  File "/usr/lib/python2.7/site-packages/yum/yumRepo.py", line 1735, in getGroups
:    fn = misc.repo_gen_decompress(fn, 'comps.xml')
:  File "/usr/lib/python2.7/site-packages/yum/misc.py", line 1167, in repo_gen_decompress
:    os.makedirs(dest, mode=0755)
:  File "/usr/lib64/python2.7/os.py", line 157, in makedirs
:    mkdir(name, mode)
:OSError: [Errno 13] Permission denied: '/var/cache/yum/x86_64/17/fedora/gen'
:
:Local variables in innermost frame:
:tail: 'gen'
:head: '/var/cache/yum/x86_64/17/fedora'
:name: '/var/cache/yum/x86_64/17/fedora/gen'
:mode: 493
Comment 1 Jose Francisco Beltran Neira 2012-09-10 13:36:59 EDT
Created attachment 611513 [details]
File: core_backtrace
Comment 2 Zdeněk Pavlas 2012-09-11 03:20:28 EDT
Fixed in commit 7bd23b46e6809fa9d35f51a3bf6ed9a7f02bb8bf.

*** This bug has been marked as a duplicate of bug 854974 ***

Note You need to log in before you can comment on or make changes to this bug.