Bug 854974 - [abrt] yum-3.4.3-42.fc18: os.py:157:makedirs:OSError: [Errno 13] Permission denied: '/var/cache/yum/x86_64/18/rpmfusion-free-updates-testing/gen'
[abrt] yum-3.4.3-42.fc18: os.py:157:makedirs:OSError: [Errno 13] Permission d...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
18
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Fedora Packaging Toolset Team
Fedora Extras Quality Assurance
abrt_hash:594e43858688ee58ef7e8b0d992...
:
: 855950 863704 875864 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-06 08:30 EDT by Kjartan Maraas
Modified: 2014-01-21 18:23 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-18 21:23:12 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
File: core_backtrace (1.21 KB, text/plain)
2012-09-06 08:30 EDT, Kjartan Maraas
no flags Details

  None (edit)
Description Kjartan Maraas 2012-09-06 08:30:30 EDT
Description of problem:
Was installing the livna-release rpm and package install complained that the package wasn't signed or trusted.

Version-Release number of selected component:
yum-3.4.3-42.fc18

Additional info:
libreport version: 2.0.13
abrt_version:   2.0.12
cmdline:        /usr/bin/python -t /usr/share/yum-cli/completion-helper.py -d 0 -C list available livna-release
kernel:         3.6.0-0.rc2.git2.1.fc18.x86_64

backtrace:
:os.py:157:makedirs:OSError: [Errno 13] Permission denied: '/var/cache/yum/x86_64/18/rpmfusion-free-updates-testing/gen'
:
:Traceback (most recent call last):
:  File "/usr/share/yum-cli/completion-helper.py", line 89, in <module>
:    main(sys.argv[1:])
:  File "/usr/share/yum-cli/completion-helper.py", line 83, in main
:    base.doCommands()
:  File "/usr/share/yum-cli/cli.py", line 485, in doCommands
:    return self.yum_cli_commands[self.basecmd].doCommand(self, self.basecmd, self.extcmds)
:  File "/usr/share/yum-cli/completion-helper.py", line 45, in doCommand
:    patterns=[get_pattern(extcmds)])
:  File "/usr/lib/python2.7/site-packages/yum/__init__.py", line 2709, in doPackageLists
:    avail = self.pkgSack.returnNewestByNameArch(patterns=patterns,
:  File "/usr/lib/python2.7/site-packages/yum/__init__.py", line 1015, in <lambda>
:    pkgSack = property(fget=lambda self: self._getSacks(),
:  File "/usr/lib/python2.7/site-packages/yum/__init__.py", line 779, in _getSacks
:    self.repos.populateSack(which=repos)
:  File "/usr/lib/python2.7/site-packages/yum/repos.py", line 348, in populateSack
:    sack.populate(repo, mdtype, callback, cacheonly)
:  File "/usr/lib/python2.7/site-packages/yum/yumRepo.py", line 191, in populate
:    db_un_fn = self._check_uncompressed_db_gen(repo, mydbtype)
:  File "/usr/lib/python2.7/site-packages/yum/yumRepo.py", line 242, in _check_uncompressed_db_gen
:    cached=repo.cache)
:  File "/usr/lib/python2.7/site-packages/yum/misc.py", line 1166, in repo_gen_decompress
:    os.makedirs(dest, mode=0755)
:  File "/usr/lib64/python2.7/os.py", line 157, in makedirs
:    mkdir(name, mode)
:OSError: [Errno 13] Permission denied: '/var/cache/yum/x86_64/18/rpmfusion-free-updates-testing/gen'
:
:Local variables in innermost frame:
:tail: 'gen'
:head: '/var/cache/yum/x86_64/18/rpmfusion-free-updates-testing'
:name: '/var/cache/yum/x86_64/18/rpmfusion-free-updates-testing/gen'
:mode: 493
Comment 1 Kjartan Maraas 2012-09-06 08:30:38 EDT
Created attachment 610293 [details]
File: core_backtrace
Comment 2 Zdeněk Pavlas 2012-09-06 10:34:11 EDT
primary.sqlite.bz2 has the correct checksum, but there's no /gen directory (yet)?
Bash completion while Yum was downloading metadata, maybe..  Seems easy to fix.
Comment 3 Zdeněk Pavlas 2012-09-11 03:20:28 EDT
*** Bug 855950 has been marked as a duplicate of this bug. ***
Comment 4 Zdeněk Pavlas 2012-10-09 10:18:01 EDT
*** Bug 863704 has been marked as a duplicate of this bug. ***
Comment 5 Fedora Update System 2012-11-12 09:49:03 EST
yum-3.4.3-30.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/yum-3.4.3-30.fc17
Comment 6 Fedora Update System 2012-11-12 19:55:44 EST
Package yum-3.4.3-30.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing yum-3.4.3-30.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-18062/yum-3.4.3-30.fc17
then log in and leave karma (feedback).
Comment 7 Zdeněk Pavlas 2012-11-13 03:48:11 EST
*** Bug 875864 has been marked as a duplicate of this bug. ***
Comment 8 Fedora Update System 2012-11-18 21:23:14 EST
yum-3.4.3-30.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.