Bug 856131 - dbus-protocol.h prevents building Qt5 in Fedora 17
dbus-protocol.h prevents building Qt5 in Fedora 17
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: dbus (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: David Zeuthen
Fedora Extras Quality Assurance
:
: 863596 870786 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-11 05:17 EDT by Florian Weimer
Modified: 2013-03-05 23:08 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-23 22:29:10 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
FreeDesktop.org 46147 None None None 2012-10-14 16:32:58 EDT

  None (edit)
Description Florian Weimer 2012-09-11 05:17:35 EDT
Please apply this patch:

https://bugs.freedesktop.org/attachment.cgi?id=57131

to make the dbus-protocol.h header file compatible with GCC in C++11 mode.
Comment 1 Colin Walters 2012-09-13 09:33:59 EDT
This has been in rawhide since http://koji.fedoraproject.org/koji/buildinfo?buildID=322180

Is three some other release you meant this bug to apply to?
Comment 2 Florian Weimer 2012-09-13 09:35:52 EDT
(In reply to comment #1)
> This has been in rawhide since
> http://koji.fedoraproject.org/koji/buildinfo?buildID=322180
> 
> Is three some other release you meant this bug to apply to?

It would be nice to have it in F17, so that it's possible to compile Qt 5.
Comment 3 Colin Walters 2012-09-13 09:49:34 EDT
(In reply to comment #2)
> (In reply to comment #1)
> > This has been in rawhide since
> > http://koji.fedoraproject.org/koji/buildinfo?buildID=322180
> > 
> > Is three some other release you meant this bug to apply to?
> 
> It would be nice to have it in F17, so that it's possible to compile Qt 5.

Not super excited to be updating core components to help not-in-distribution software compile with bleeding edge C++, but I'll queue this up to go out with a combined dbus update relatively soon.
Comment 4 Colin Walters 2012-09-18 13:18:47 EDT
Ok, I forgot to do this - do you really want it?
Comment 5 Florian Weimer 2012-09-18 14:17:08 EDT
(In reply to comment #4)
> Ok, I forgot to do this - do you really want it?

No, it's not really critical.  It's fixed upstream, so it'll eventually trickle down to Fedora.  That's good enough.
Comment 6 J-P Nurmi 2012-09-27 11:41:07 EDT
I'd vote for the _trivial_ patch. It's not only about Qt5 after all.
Comment 7 Rex Dieter 2012-10-14 16:26:54 EDT
*** Bug 863596 has been marked as a duplicate of this bug. ***
Comment 8 Rex Dieter 2012-10-14 16:30:34 EDT
We've contributors beginning work on qt5 packaging, so getting this fixed sooner rather than later would greatly help those efforts.

I worked on updated dbus-1.4.24 packaging, but if you'd rather pull in the minimal fix, that's fine too.
Comment 9 Rex Dieter 2012-11-14 16:09:04 EST
*** Bug 870786 has been marked as a duplicate of this bug. ***
Comment 10 Fedora Update System 2012-11-14 16:35:55 EST
dbus-1.4.10-7.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/dbus-1.4.10-7.fc17
Comment 11 Fedora Update System 2012-11-16 02:32:56 EST
Package dbus-1.4.10-7.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing dbus-1.4.10-7.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-18313/dbus-1.4.10-7.fc17
then log in and leave karma (feedback).
Comment 12 Fedora Update System 2012-11-23 22:29:12 EST
dbus-1.4.10-7.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.