Bug 856399 - RC2 DVD is missing grub2-efi and shim packages
RC2 DVD is missing grub2-efi and shim packages
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: comps (Show other bugs)
18
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Bill Nottingham
AcceptedBlocker
:
: 856400 (view as bug list)
Depends On:
Blocks: F18Alpha/F18AlphaBlocker
  Show dependency treegraph
 
Reported: 2012-09-11 20:10 EDT by Brian Lane
Modified: 2014-03-16 23:32 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-13 16:13:53 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Brian Lane 2012-09-11 20:10:54 EDT
UEFI install from RC2 DVD doesn't work due to missing packages. grub2-efi and shim need to be included.
Comment 1 Adam Williamson 2012-09-11 20:20:06 EDT
This is in comps, these days. We have grub-efi in the anaconda-tools group, we need to switch that out.
Comment 2 Adam Williamson 2012-09-11 20:26:02 EDT
*** Bug 856400 has been marked as a duplicate of this bug. ***
Comment 3 Adam Williamson 2012-09-11 20:27:51 EDT
+1 blocker, we consider EFI installs blocker for Alpha (since 17). Criterion is "The installer must boot (if appropriate) and run on all primary architectures, with all system firmware types that are common on those architectures, from default live image, DVD, and boot.iso install media when written to an optical disc and when written to a USB stick with at least one of the officially supported methods" (the 'all system firmware types that are common' language is considered to cover EFI).

I have pushed a fix to comps for this - http://git.fedorahosted.org/cgit/comps.git/commit/?id=e863360d2e620d8f505b3c09d78568cc8ec02510 . Once mash is done, it should be fixed in RC3.
Comment 4 Adam Williamson 2012-09-12 14:31:20 EDT
Discussed at 2012-09-12 blocker review meeting. Accepting as a blocker per criterion "In most cases, a system installed according to any of the above criteria must boot to the 'firstboot' utility on the first boot after installation, without unintended user intervention, unless the user explicitly chooses to boot in non-graphical mode. The firstboot utility must be able to create a working user account" combined with the above criterion.
Comment 5 Adam Williamson 2012-09-13 16:13:53 EDT
This is fixed in RC3, both packages are present. I just loop-mounted the DVD and checked.

Note You need to log in before you can comment on or make changes to this bug.