Bug 856492 - [abrt] xorg-x11-server-Xorg-1.12.3-1.fc17: Xorg server crashed
[abrt] xorg-x11-server-Xorg-1.12.3-1.fc17: Xorg server crashed
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-synaptics (Show other bugs)
17
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Peter Hutterer
Fedora Extras Quality Assurance
abrt_hash:0e261d8371cb6cc691b0fc4fbcf...
:
: 856493 856494 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-12 03:09 EDT by Bojan Smojver
Modified: 2013-01-14 18:36 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-14 18:36:00 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: Xorg.0.log (70.60 KB, text/plain)
2012-09-12 03:09 EDT, Bojan Smojver
no flags Details
File: usr_share_xorg_conf_d.tar.gz (1.57 KB, text/plain)
2012-09-12 03:09 EDT, Bojan Smojver
no flags Details
File: etc_X11_xorg_conf_d.tar.gz (383 bytes, text/plain)
2012-09-12 03:09 EDT, Bojan Smojver
no flags Details

  None (edit)
Description Bojan Smojver 2012-09-12 03:09:39 EDT
Version-Release number of selected component:
xorg-x11-server-Xorg-1.12.3-1.fc17

Additional info:
libreport version: 2.0.13
abrt_version:   2.0.12
kernel:         3.5.3-1.fc17.x86_64

backtrace:
:0: /usr/bin/Xorg (xorg_backtrace+0x36) [0x4652a6]
:1: /usr/lib64/xorg/modules/input/synaptics_drv.so (0x7f8c67f24000+0x2e77) [0x7f8c67f26e77]
:2: /usr/lib64/xorg/modules/input/synaptics_drv.so (0x7f8c67f24000+0x4563) [0x7f8c67f28563]
:3: /usr/lib64/xorg/modules/input/synaptics_drv.so (0x7f8c67f24000+0x6fa4) [0x7f8c67f2afa4]
:4: /usr/bin/Xorg (0x400000+0x80787) [0x480787]
:5: /usr/bin/Xorg (0x400000+0xa4a80) [0x4a4a80]
:6: /lib64/libpthread.so.0 (0x3f32200000+0xefe0) [0x3f3220efe0]
:7: /lib64/libpthread.so.0 (__close+0x10) [0x3f3220e0f0]
:8: /usr/lib64/xorg/modules/input/evdev_drv.so (0x7f8c68357000+0x734c) [0x7f8c6835e34c]
:9: /usr/bin/Xorg (DisableDevice+0x16e) [0x42d6ee]
:10: /usr/bin/Xorg (xf86Wakeup+0x494) [0x481244]
:11: /usr/bin/Xorg (WakeupHandler+0x6b) [0x43838b]
:12: /usr/bin/Xorg (WaitForSomething+0x1a4) [0x462834]
:13: /usr/bin/Xorg (0x400000+0x34111) [0x434111]
:14: /usr/bin/Xorg (0x400000+0x23485) [0x423485]
:15: /lib64/libc.so.6 (__libc_start_main+0xf5) [0x3f31e21735]
:16: /usr/bin/Xorg (0x400000+0x2375d) [0x42375d]
Comment 1 Bojan Smojver 2012-09-12 03:09:42 EDT
Created attachment 612005 [details]
File: Xorg.0.log
Comment 2 Bojan Smojver 2012-09-12 03:09:44 EDT
Created attachment 612006 [details]
File: usr_share_xorg_conf_d.tar.gz
Comment 3 Bojan Smojver 2012-09-12 03:09:46 EDT
Created attachment 612007 [details]
File: etc_X11_xorg_conf_d.tar.gz
Comment 4 Peter Hutterer 2012-09-21 08:37:12 EDT
When did this happen? during suspend/resume?
Comment 5 Peter Hutterer 2012-09-21 08:37:47 EDT
*** Bug 856493 has been marked as a duplicate of this bug. ***
Comment 6 Peter Hutterer 2012-09-21 08:43:13 EDT
*** Bug 856494 has been marked as a duplicate of this bug. ***
Comment 7 Bojan Smojver 2012-09-21 18:15:51 EDT
(In reply to comment #4)
> When did this happen? during suspend/resume?

Most of them appear in abrt-gui after resume, I think. The X server does not really crash any more, but this backtrace is present many times. Doesn't happen all the time for sure. Only sometimes.
Comment 8 Peter Hutterer 2012-10-17 01:57:46 EDT
fwiw, I haven't been able to reproduce this yet, despite enabling/disabling the device _a lot_. Any hints on how to trigger this would be appreciated.

The key is most likely in how many fingers are down on suspend and how many fingers are there on resume, but all combinations I've tried so far have failed to trigger this bug.
Comment 9 Bojan Smojver 2012-10-17 02:10:24 EDT
Haven't seen this in a while, to be honest.
Comment 10 Peter Hutterer 2013-01-14 18:36:00 EST
Closing for now, please re-open if the bug triggers again.

Note You need to log in before you can comment on or make changes to this bug.