Bug 856503 - The non-interactive cmdline output mode can not work well
The non-interactive cmdline output mode can not work well
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: David Cantrell
Fedora Extras Quality Assurance
:
: 856728 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-12 03:28 EDT by Tao Wu
Modified: 2014-10-28 19:45 EDT (History)
5 users (show)

See Also:
Fixed In Version: anaconda-18.11
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-16 15:14:05 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
cmdline stops (15.14 KB, image/png)
2012-09-12 03:28 EDT, Tao Wu
no flags Details
anaconda log (744 bytes, text/x-log)
2012-09-12 03:29 EDT, Tao Wu
no flags Details

  None (edit)
Description Tao Wu 2012-09-12 03:28:38 EDT
Created attachment 612017 [details]
cmdline stops

Description of problem:
The non-interactive cmdline output mode can not work well

Version-Release number of selected component (if applicable):
18.6.7

How reproducible:
always

Steps to Reproduce:
1.Prepare a valid kickstart file. For help creating a kickstart file, examine the file /root/anaconda-ks.cfg on a previously installed system.
2.Boot the installer with the command-line option cmdline as well as ks argument to load the kickstart file
3.
  
Actual results:
Anaconda stops as the attachment displays.

Expected results:
Anaconda completes successfully 

Additional info:
Comment 1 Tao Wu 2012-09-12 03:29:54 EDT
Created attachment 612018 [details]
anaconda log
Comment 2 Jesse Keating 2012-09-12 15:44:09 EDT
There is no current code to drive kickstarts from text mode.  That's planned post-alpha, perhaps even post F18.
Comment 3 Jesse Keating 2012-09-12 17:48:03 EDT
*** Bug 856728 has been marked as a duplicate of this bug. ***
Comment 4 Jesse Keating 2012-09-27 23:51:48 EDT
There is now code pushed upstream that handles cmdline mode and text mode kickstarts.  Please re-test when the next build becomes available.
Comment 5 Jesse Keating 2012-10-03 19:42:22 EDT
The F18 Beta TC1 image should suffice.  http://dl.fedoraproject.org/pub/alt/stage/18-Beta-TC1/
Comment 6 Jan ONDREJ 2012-10-04 04:15:42 EDT
Better, but:

1. I use "text" option on boot command line and installed still asks me this:

VNC                                                                             
                                                                                
Text mode provides a limited set of installation options. It does not allow you 
to specify your own partitioning layout or package selections. Would you like to
 use VNC mode instead?                                                          
                                                                                
 1) Start VNC                                                                   
                                                                                
 2) Use text mode                                                               

By pressing "2" installation continues and installs everything well.
Comment 7 Jesse Keating 2012-10-04 12:47:45 EDT
(In reply to comment #6)
> Better, but:
> 
> 1. I use "text" option on boot command line and installed still asks me this:
> 
> VNC                                                                         
> 
>                                                                             
> 
> Text mode provides a limited set of installation options. It does not allow
> you 
> to specify your own partitioning layout or package selections. Would you
> like to
>  use VNC mode instead?                                                      
> 
>                                                                             
> 
>  1) Start VNC                                                               
> 
>                                                                             
> 
>  2) Use text mode                                                           
> 
> 
> By pressing "2" installation continues and installs everything well.

Yes, that's how it worked before too.  Text is limited, we de-emphasise it.  We would rather people use the full featured graphical interface, which is available over VNC.  What you're seeing here is not a bug.
Comment 8 Jan ONDREJ 2012-10-04 12:57:30 EDT
(In reply to comment #7)
> (In reply to comment #6)
> > By pressing "2" installation continues and installs everything well.
> 
> Yes, that's how it worked before too.  Text is limited, we de-emphasise it. 
> We would rather people use the full featured graphical interface, which is
> available over VNC.  What you're seeing here is not a bug.

I only want an fully automated install. Now I am simulating an headless PC, where I can't confirm VNC/text mode install.
How I can run automated install, if I have to press 1 or 2 to continue?
Comment 9 Jesse Keating 2012-10-04 13:22:19 EDT
You put "text" into the kickstart file you're using to automate the install.

Note You need to log in before you can comment on or make changes to this bug.