This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 856728 - Fallback to text mode fails too.
Fallback to text mode fails too.
Status: CLOSED DUPLICATE of bug 856503
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
18
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On: 855083
Blocks: F18Beta/F18BetaBlocker
  Show dependency treegraph
 
Reported: 2012-09-12 12:29 EDT by Jan ONDREJ
Modified: 2012-09-12 17:48 EDT (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 855083
Environment:
Last Closed: 2012-09-12 17:48:03 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jan ONDREJ 2012-09-12 12:29:02 EDT
As reported in previous bug, X startup fails on cirrus card. Installer displays, that it's falling back to text mode, but after aprox. 10 minutes nothing happens. I can see in "top", that my cpu is used by anaconda, but nothing displayed.

+++ This bug was initially created as a clone of Bug #855083 +++

Description of problem:
Xorg fails to start in qemu's default cirrus vga output.

Version-Release number of selected component (if applicable):
todays F18 installer, happened before too

How reproducible:
always

Steps to Reproduce:
1. Boot F18 installer using: qemu-kvm -vga cirrus ...
  
Actual results:
Starting installer, one moment...
anaconda 18.6.5 for Fedora 18 (pre-release) started.
15:57:08 X startup failed, falling back to text mode

Xorg.log output:
(EE) cirrus: The PCI device 0xb8 at 00@00:02:0 has a kernel module claiming it.
(EE) cirrus: This driver cannot operate until it has been unloaded.

Expected results:
graphical boot

Additional info:
I can use "nomodeset" boot option to workaround this, but this is not for normal users.

--- Additional comment from BobLfoot@gmail.com on 2012-09-10 13:56:51 CEST ---

Using virt-manager on a Centos 6.3 host I ran into same issue that F18-alpha-TC6-i386 would not boot using cirrus video.  MY work around was to switch to vga driver.

--- Additional comment from kparal@redhat.com on 2012-09-10 14:01:14 CEST ---

Proposing as F18 Blocker:
" The release must install and boot successfully as a virtual guest in a situation where the virtual host is running the previous stable Fedora release, using Fedora's current preferred virtualization technology "
https://fedoraproject.org/wiki/Fedora_18_Beta_Release_Criteria

qxl is current default, but cirrus is still used in old VMs. I'm not really sure we want to block on both qxl and cirrus, so this should just start a discussion.
Comment 1 Jan ONDREJ 2012-09-12 12:32:21 EDT
This has something with my kickstart script. How can I debug anaconda in this stage to find more information, what's wrong? Same kickstart script works well in graphical install.
Comment 2 Jesse Keating 2012-09-12 17:48:03 EDT
kickstarts from text mode do not work currently, there is no code to drive them.

See bug 856503

*** This bug has been marked as a duplicate of bug 856503 ***

Note You need to log in before you can comment on or make changes to this bug.