Bug 856559 - Flash video/audio playback breaks up when user starts to move with mouse cursor
Flash video/audio playback breaks up when user starts to move with mouse cursor
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: spice-client (Show other bugs)
6.3
Unspecified Unspecified
high Severity high
: rc
: ---
Assigned To: Uri Lublin
Desktop QE
:
Depends On:
Blocks: 835616 960054
  Show dependency treegraph
 
Reported: 2012-09-12 06:20 EDT by Tomas Dosek
Modified: 2013-05-30 16:44 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-20 17:01:11 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Logs, dump (1.96 MB, application/zip)
2012-09-12 06:20 EDT, Tomas Dosek
no flags Details

  None (edit)
Description Tomas Dosek 2012-09-12 06:20:25 EDT
Created attachment 612044 [details]
Logs, dump

Description of problem:
This bug was filled based on a case we experienced with one customer.

When user played a youtube flash video in a guest VM (latest RHN RHEL 6.3)
in their environment it was ok unless customer started to move mouse cursor.
After starting to move the cursor video playback started being lacky, glitchy and audio muted from time to time.

Using RHEV 3.0 (RHEV-H 6.3, RHEV-M ic157)

Version-Release number of selected component (if applicable):
Windows spice client version 5.0.0.10029
RHEV-H 6.3 host
RHEV-M ic157


How reproducible:
In customer's env. 100 %, in our environment could not reproduce

Steps to Reproduce:
1. Have A RHEV-M 3.0 setup and a RHEL 6.3 VM in it
2. Connect to the VM using spice
3. Play a youtube flash video
4. Start moving cursor
  
Actual results:
Video and audio playback breaks as mentioned above

Expected results:
Video and audio playback shouldn't be influenced.

Additional info:
Attaching sosreport from guest VM, spice tcpdump.
I'll attach also spice client logs once customer sends us these.
Comment 3 Uri Lublin 2012-09-12 08:53:02 EDT
Is this a duplicate of bug 814211 ?
Comment 4 Tomas Dosek 2012-09-12 09:02:31 EDT
Uri to make this more clear. I filed this bug because while working on the case, which is attached to both this and 814211 bugs we experienced different behaviours of windows/linux spice client.

Using spice client on linux the video was lacky no matter what user did (even when user didn't touch mouse at all).

Using windows spice client the video was lacky just and only in case that user moved mouse. That's why I filed this bug. It might be related, but I'm not sure if we should mark this as duplicate (because of different behaviour of linux/windows spice clients).
Comment 6 RHEL Product and Program Management 2012-12-14 02:27:03 EST
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 8 David Blechter 2013-05-20 17:01:11 EDT
1. It is the old spice client that is obsolete for rhevm users
2. In general, moving cursor can make video jumpy, especially in you tube, it makes pop-up to jump, etc, and it affects our video detection. 
3.The Red Hat Customer Portal 00696033 was already closed, so it is safe to remove the link from this bug

Based on the above closing the bug with WONTFIX

Note You need to log in before you can comment on or make changes to this bug.