Bug 856745 - No option to configure system time as UTC or LOCAL
No option to configure system time as UTC or LOCAL
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-12 13:44 EDT by Daniel Belton
Modified: 2012-10-05 10:33 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-12 13:50:36 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Daniel Belton 2012-09-12 13:44:52 EDT
Description of problem: 

There is no option during the install of Fedora 18 to configure how the system clock is set. 


Version-Release number of selected component (if applicable): 

Fedora 18 Alpha TC2


How reproducible: 

Install Fedora 18 Alpha TC2. No option in neither anaconda or firstboot to configure how the system clock is set. 


Steps to Reproduce:
1.
2.
3.
  
Actual results:

Previous install had the option to set if your system clock used UTC. This is missing in F18


Expected results:

The ability to set how the system clock is set. It's preferable to set the system clock as UTC, especially in linux, and pretty much mandatory if you have different users that reside in different time zones. 

Additional info:

I am not certain if this should be in anaconda or firstboot, but one of the two should allow configuring how the system clock is set.
Comment 1 Daniel Belton 2012-09-12 13:46:43 EDT
I made a typo above. I was using Fedora 18 Alpha RC2, not TC2.
Comment 2 Martin Sivák 2012-09-12 13:50:36 EDT
This should still be possible using kickstart. The removal was intentional.

If I remember correctly we default to UTC unless Windows was detected.
Comment 3 Daniel Belton 2012-09-12 14:12:00 EDT
No Windows installed on my machine here, but it defaulted to LOCAL. 

Even on my machines where Windows is installed, the system time is still set to UTC, so defaulting to LOCAL in those instances would be wrong as well.
Comment 4 Steve Tyler 2012-09-14 16:08:51 EDT
(In reply to comment #3)
> No Windows installed on my machine here, but it defaulted to LOCAL. 
> 
> Even on my machines where Windows is installed, the system time is still set
> to UTC, so defaulting to LOCAL in those instances would be wrong as well.

After a clean F18-Alpha-RC3 install in a VM, the system clock time zone is likewise LOCAL. Network time setting was not enabled. ISTM, that the bug here is that the automatic setting of the system clock time zone does not work. I believe this bug could be reopened.

[joeblow@localhost ~]$ cat /etc/adjtime 
0.000000 1347676433 0.000000
1347676433
LOCAL
[joeblow@localhost ~]$ date
Fri Sep 14 19:52:27 PDT 2012
[joeblow@localhost ~]$ ps -ef | grep chrony
joeblow   1518  1423  0 19:52 pts/0    00:00:00 grep --color=auto chrony
[joeblow@localhost ~]$ uname -r
3.6.0-0.rc4.git2.1.fc18.x86_64
[joeblow@localhost ~]$ 

QEMU command line:
$ qemu-kvm -m 1024 -hda f18-test-2.img -cdrom ~/xfr/fedora/F18/F18-Alpha/RC3/Fedora-18-Alpha-x86_64-DVD.iso -boot menu=on -vga qxl
Comment 5 Steve Tyler 2012-09-14 16:24:32 EDT
For the record, testing was done with:
qemu-kvm-1.0.1-1.fc17.x86_64
Comment 6 Steve Tyler 2012-09-14 17:05:29 EDT
(In reply to comment #4)
...
> After a clean F18-Alpha-RC3 install in a VM, the system clock time zone is
> likewise LOCAL.
...

That was a gnome desktop install. A minimal install seems to be sufficient:
# cat /etc/adjtime 
0.0 0 0.0
0
LOCAL

Daniel: Could you confirm that you are looking at /etc/adjtime?
Comment 7 Daniel Belton 2012-09-14 23:41:33 EDT
Yes, I can confirm that I was looking at /etc/adjtime and after the install it was indeed set to LOCAL. I have since changed it to UTC on my system here.

I did a bare metal install form the x86_64 DVD image.
Comment 8 Steve Tyler 2012-09-15 15:32:19 EDT
(In reply to comment #7)
> Yes, I can confirm that I was looking at /etc/adjtime and after the install
> it was indeed set to LOCAL. I have since changed it to UTC on my system here.
> 
> I did a bare metal install form the x86_64 DVD image.

Thanks for the additional details.

I changed LOCAL to UTC in /etc/adjtime in my VM installation, and,
after rebooting the VM, the date is displayed as expected.

Enabling "Network Time" in "System Tools:System Settings:Date & Time"
also works around the problem. Doing that starts "chronyd".

Do you have "Network Time" disabled?
$ ps -ef | grep chrony

Another thing I noticed is that "--utc" is not set
in the anaconda kickstart file:

# grep timezone /root/anaconda-ks.cfg 
# System timezone
timezone America/Los_Angeles --nontp

http://fedoraproject.org/wiki/Anaconda/Kickstart#timezone
Comment 9 Chris Lumens 2012-10-05 10:33:41 EDT
*** Bug 863199 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.