Bug 863199 - Can't select UTC timezone during installation
Can't select UTC timezone during installation
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Vratislav Podzimek
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks: F18-accepted/F18FinalFreezeExcept
  Show dependency treegraph
 
Reported: 2012-10-04 12:33 EDT by Peter McNabb
Modified: 2012-11-22 21:50 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-22 21:50:20 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot showing F17 "Non-geographic timezones" installer menu (141.38 KB, image/png)
2012-10-18 08:19 EDT, Steve Tyler
no flags Details
screenshot showing F17 timezone configuration with Gnome control center (363.38 KB, image/png)
2012-10-18 09:29 EDT, Steve Tyler
no flags Details
screenshot showing tzclock app set to display GMT (632.46 KB, image/png)
2012-10-23 10:00 EDT, Steve Tyler
no flags Details

  None (edit)
Description Peter McNabb 2012-10-04 12:33:26 EDT
Description of problem:
In previous versions of Fedora, there was an "other" region that include UTC and offsets, but this does not appear to be in option with the new anaconda.

Version-Release number of selected component (if applicable):
Using F18 boot.iso from 10/03/2012

Steps to Reproduce:
1. Start F18 installation
2. Select "Date & Time" under Localization
3. Try to find UTC
  
Actual results:
Not found

Expected results:
Found
Comment 1 Chris Lumens 2012-10-05 10:33:41 EDT

*** This bug has been marked as a duplicate of bug 856745 ***
Comment 2 Peter McNabb 2012-10-05 15:30:12 EDT
This is actually a different issue than bug 856745.

In previous versions of anaconda, the time zone selection had you select two things:

1) Time zone / Nearest city (what this bug is for)
2) Whether or not "System clock uses UTC" (what bug 856745 is for)

In the Fedora 17 installer, at the bottom of the list is "Non-geographic timezones" which includes:

UTC
GMT-14
GMT-13
GMT-12
GMT-11
GMT-10
...
GMT+11
GMT+12

In the Fedora 18 installer, there is no option to select a "Non-geographic timezone."
Comment 3 Vratislav Podzimek 2012-10-18 03:29:06 EDT
(In reply to comment #2)
> This is actually a different issue than bug 856745.
> 
> In previous versions of anaconda, the time zone selection had you select two
> things:
> 
> 1) Time zone / Nearest city (what this bug is for)
> 2) Whether or not "System clock uses UTC" (what bug 856745 is for)
> 
> In the Fedora 17 installer, at the bottom of the list is "Non-geographic
> timezones" which includes:
> 
> UTC
> GMT-14
> GMT-13
> GMT-12
> GMT-11
> GMT-10
> ...
> GMT+11
> GMT+12
> 
> In the Fedora 18 installer, there is no option to select a "Non-geographic
> timezone."
Why do you think these timezones should be included?
Comment 4 Steve Tyler 2012-10-18 08:19:18 EDT
Created attachment 629336 [details]
screenshot showing F17 "Non-geographic timezones" installer menu

Those appear to be some of the time zones from:

$ ls /usr/share/zoneinfo/Etc/
GMT    GMT-1   GMT-11  GMT-13  GMT-3  GMT-5  GMT-7  GMT-9      Universal
GMT0   GMT+1   GMT+11  GMT-14  GMT+3  GMT+5  GMT+7  GMT+9      UTC
GMT-0  GMT-10  GMT-12  GMT-2   GMT-4  GMT-6  GMT-8  Greenwich  Zulu
GMT+0  GMT+10  GMT+12  GMT+2   GMT+4  GMT+6  GMT+8  UCT

There is no daylight saving time change with them:

$ zdump /usr/share/zoneinfo/Etc/UTC /usr/share/zoneinfo/Europe/London 
/usr/share/zoneinfo/Etc/UTC        Thu Oct 18 12:13:07 2012 UTC
/usr/share/zoneinfo/Europe/London  Thu Oct 18 13:13:07 2012 BST

See also:
World Time Zone Map
http://astro.ukho.gov.uk/nao/miscellanea/WMTZ/
Comment 5 Steve Tyler 2012-10-18 09:29:54 EDT
Created attachment 629378 [details]
screenshot showing F17 timezone configuration with Gnome control center

For comparison, the F17 Gnome control center does not show any GMT-XX timezones.
Comment 6 Peter McNabb 2012-10-18 13:15:36 EDT
vpodzime: see Steve's comments for info..
Comment 7 Vratislav Podzimek 2012-10-22 05:43:22 EDT
I can add the GMT-XX timezones to the GUI (no position indication on the map for them, of course), but still -- are there really use cases that require them? I don't see any reason for setting timezone without daylight saving time change. Of course, I'd be glad to learn something new.
Comment 8 Steve Tyler 2012-10-22 10:36:30 EDT
I believe a case could be made for UTC, anyway, because UTC is used in aviation and meteorology, and for cross-timezone meeting scheduling. The latter is exemplified here:

# Fedora Quality Assurance Meeting
# Date: 2012-10-22
# Time: 15:00 UTC
(https://fedoraproject.org/wiki/Infrastructure/UTCHowto)
# Location: #fedora-meeting on irc.freenode.net
http://article.gmane.org/gmane.linux.redhat.fedora.test.announce/544

There are numerous localities that do not observe daylight saving time, although the corresponding zoneinfo file should account for that.

Daylight Saving Time Around the World 2012
http://www.timeanddate.com/time/dst/2012.html

Annex to the ITU Operational Bulletin
No. 999 – 1.III.2012
LEGAL TIME 2012
http://www.itu.int/pub/T-SP-LT.1-2012
Comment 9 Vratislav Podzimek 2012-10-23 04:32:22 EDT
(In reply to comment #8)
> I believe a case could be made for UTC, anyway, because UTC is used in
> aviation and meteorology, and for cross-timezone meeting scheduling. The
> latter is exemplified here:
> 
> # Fedora Quality Assurance Meeting
> # Date: 2012-10-22
> # Time: 15:00 UTC
> (https://fedoraproject.org/wiki/Infrastructure/UTCHowto)
> # Location: #fedora-meeting on irc.freenode.net
> http://article.gmane.org/gmane.linux.redhat.fedora.test.announce/544
Of course, knowing how to convert time from UTC to your local time and vice versa is definitely a good thing, but setting UTC as system time is something completely different.

> 
> There are numerous localities that do not observe daylight saving time,
> although the corresponding zoneinfo file should account for that.
Exactly.

> 
> Daylight Saving Time Around the World 2012
> http://www.timeanddate.com/time/dst/2012.html
> 
> Annex to the ITU Operational Bulletin
> No. 999 – 1.III.2012
> LEGAL TIME 2012
> http://www.itu.int/pub/T-SP-LT.1-2012
Thanks for additional info.

I could add UTC and GMT-XX timezones, but the problem is that many people don't know what these letters mean and may get confused.
Comment 10 Steve Tyler 2012-10-23 10:00:34 EDT
Created attachment 632137 [details]
screenshot showing tzclock app set to display GMT

The tzclock app can display the various GMT-XX timezones. Also, the date command can show the current time in UTC:

$ date --utc
Tue Oct 23 13:48:16 UTC 2012

The gnome-clocks app, which is installed with the Gnome desktop, does not appear to support the GMT-XX timezones.

WRT system time on UTC: A sysadmin with multiple servers in various time zones might want to set the system time zone to UTC on all of the servers, so that timestamps in the log files could be correlated. Setting the system time zone can, of course, always be done by manually linking /etc/localtime to a time zone file.
Comment 11 Steve Tyler 2012-10-23 10:14:45 EDT
(In reply to comment #10)
...
> WRT system time on UTC: A sysadmin with multiple servers in various time
> zones might want to set the system time zone to UTC on all of the servers,
> so that timestamps in the log files could be correlated. Setting the system
> time zone can, of course, always be done by manually linking /etc/localtime
> to a time zone file.

kickstart appears to support setting the system time zone to any zoneinfo file:

timezone --utc America/Los_Angeles

NB: The "--utc" option specifies that the hardware clock is set to UTC.

http://fedoraproject.org/wiki/Anaconda/Kickstart#timezone
Comment 12 Peter McNabb 2012-10-24 15:10:08 EDT
(In reply to comment #9)
> I could add UTC and GMT-XX timezones, but the problem is that many people
> don't know what these letters mean and may get confused.

vpodzime: Again, see Steve's comments for needinfo. One big benefit is being able to correlate logs of servers in multiple timezones.

By using a category of "Non-geographic timezones," previous versions avoided confusion to users who may have not run across UTC and GMT-XX timezones.
Comment 13 Steve Tyler 2012-10-24 17:24:37 EDT
Googling found some use-cases that aren't our say-so: :-)

Setting a UTC Timezone
http://rimuhosting.com/howto/timezone.jsp

"Scenario: The hosting company is in country W; the data center is in timezone X; the customer is in country Y; and their users are in country Z.

What timezone should you use for your server?  Perhaps you should try Universal Co-ordinated Time (UTC)."

Should servers have their timezone set to GMT/UTC?
http://serverfault.com/questions/191331/should-servers-have-their-timezone-set-to-gmt-utc

How does one deal with multiple TimeZones in applications that store dates and times?
http://stackoverflow.com/questions/3207976/how-does-one-deal-with-multiple-timezones-in-applications-that-store-dates-and-t

How to set the timezone on Ubuntu Server
http://www.christopherirish.com/2012/03/21/how-to-set-the-timezone-on-ubuntu-server/

"I find it’s pretty annoying when you have to go log file spelunking only to find all the timestamps are in UTC."
Comment 14 Vratislav Podzimek 2012-10-25 04:32:09 EDT
Fair enough, guys, thanks a lot for this elaboration. I will add UTC and GMT-XX timezones to the GUI.
Comment 15 Steve Tyler 2012-10-25 08:08:12 EDT
Thanks, Vratislav.

WRT GMT-XX being confusing:

The GMT-XX timezone names have the signs reversed:

GMT-1 = UTC + 1
GMT+1 = UTC - 1

$ date --utc; zdump /usr/share/zoneinfo/Etc/GMT-1 /usr/share/zoneinfo/Etc/GMT+1
Thu Oct 25 12:05:08 UTC 2012
/usr/share/zoneinfo/Etc/GMT-1  Thu Oct 25 13:05:08 2012 GMT-1
/usr/share/zoneinfo/Etc/GMT+1  Thu Oct 25 11:05:08 2012 GMT+1
Comment 16 Vratislav Podzimek 2012-11-06 04:22:46 EST
Patch adding UTC and GTM-XX timezones pushed to anaconda git repository [1]. If you think this should appear in Fedora 18 please propose this as Nice To Have.

[1] http://git.fedorahosted.org/cgit/anaconda.git/commit/?id=88d9dd82a638dcb267936f0482de79d47dc8b7a9
Comment 17 Steve Tyler 2012-11-06 14:19:14 EST
(In reply to comment #16)
> Patch adding UTC and GTM-XX timezones pushed to anaconda git repository [1].
> If you think this should appear in Fedora 18 please propose this as Nice To
> Have.
> 
> [1]
> http://git.fedorahosted.org/cgit/anaconda.git/commit/
> ?id=88d9dd82a638dcb267936f0482de79d47dc8b7a9

Thanks. I can't add blocks to this bug. Peter, you can propose this bug as an F18 Blocker NTH bug by adding the bug alias 'F18-accepted'[1] to the Blocks box at the top of this report. That will add it to a list[2] that is reviewed by QA[3].

[1] http://fedoraproject.org/wiki/BugZappers/HouseKeeping/Trackers
[2] http://qa.fedoraproject.org/blockerbugs/milestone/18/final/buglist
[3] https://fedoraproject.org/wiki/QA:SOP_blocker_bug_process
Comment 18 Fedora Update System 2012-11-07 22:34:36 EST
anaconda-18.27-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/anaconda-18.27-1.fc18
Comment 19 Fedora Update System 2012-11-08 22:22:00 EST
Package anaconda-18.27-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing anaconda-18.27-1.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-17823/anaconda-18.27-1.fc18
then log in and leave karma (feedback).
Comment 20 Fedora Update System 2012-11-10 14:36:59 EST
Package anaconda-18.28-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing anaconda-18.28-1.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-17823/anaconda-18.28-1.fc18
then log in and leave karma (feedback).
Comment 21 Adam Williamson 2012-11-22 21:50:20 EST
This bug looks to have been fixed in 18.27 (which is now stable) but missed being closed. If you find you are still experiencing it with Fedora 18 Beta (RC1) or later, please re-open the bug.

(tested with Beta RC1, the non-geographic timezones are present in the drop-downs under 'Etc').

Note You need to log in before you can comment on or make changes to this bug.