Bug 856838 - ALSA HDA driver and HP onboard sound is causing crackling/popping during volume change in RHEL5
ALSA HDA driver and HP onboard sound is causing crackling/popping during volu...
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
5.8
All Linux
high Severity high
: rc
: ---
Assigned To: Jaroslav Kysela
Red Hat Kernel QE team
:
Depends On: 856837
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-12 17:54 EDT by Daniel Kinon
Modified: 2014-01-29 04:06 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 856837
Environment:
Last Closed: 2014-01-29 04:06:11 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Daniel Kinon 2012-09-12 17:54:19 EDT
+++ This bug was initially created as a clone of Bug #856837 +++

Description of problem:
I did also some measurement and the ALSA HDA driver tests to eliminate the pops caused by the volume changes (volume slider changes) using a mixer application.

I believe that this issue is related directly to hardware and hardware vendor should be asked, why changing of the volume in the HDA audio codec causes pops in the analog output. I can reproduce the clicks with some hardware, but other hardware does not suffer from this issue. I verified the driver and I do not see any problems there. Also, I wrote a script changing the volume periodically using direct HDA codec writes and the pops are there (for some HDA codec types), too.

Perhaps, there might be a vendor specific workaround to set the volume without clicks outside the HDA specification from Intel, but also in this case, the hardware vendor (HDA codec vendor, PC vendor) might be asked to provide this information.


Version-Release number of selected component (if applicable):
2.6.18-308.13.1.el5

How reproducible:
Easily on HP onboard sound.

Steps to Reproduce:
1. Move volume slider up and donw to change audio volume.
  
Actual results:
Volume change with crackling/popping.

Expected results:
Volume change with no crackling/popping.

Additional info:
Still narrowing down other affected hardware
Comment 1 RHEL Product and Program Management 2012-10-30 02:07:58 EDT
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 4 Jaroslav Kysela 2014-01-29 04:06:11 EST
I'm sorry, but I don't see any way to fix the hardware issue.

Note You need to log in before you can comment on or make changes to this bug.