Bug 857119 - USB clerk service won't share any device on Windows Server 2008 R2 and Windows XP
USB clerk service won't share any device on Windows Server 2008 R2 and Window...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: usb-clerk-win (Show other bugs)
3.1.0
Unspecified Unspecified
urgent Severity urgent
: ---
: ---
Assigned To: Arnon Gilboa
Desktop QE
:
: 870009 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-13 11:31 EDT by David Jaša
Modified: 2013-04-10 11:48 EDT (History)
7 users (show)

See Also:
Fixed In Version: usbclerk-win-0.1-10
Doc Type: Bug Fix
Doc Text:
No documentation needed
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-04 12:58:16 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Logs (25.65 KB, text/plain)
2012-10-25 07:26 EDT, Tomas Jamrisko
no flags Details
Logs from XP (16.81 KB, text/plain)
2012-10-29 06:17 EDT, Tomas Jamrisko
no flags Details
use specific static libs (4.28 KB, patch)
2012-11-01 06:18 EDT, Arnon Gilboa
no flags Details | Diff

  None (edit)
Description David Jaša 2012-09-13 11:31:25 EDT
Description of problem:
USB clerk service won't share any device on Windows Server 2008 R2

Version-Release number of selected component (if applicable):
rhevm-spice-client-x32-cab-3.1-4.el6.noarch
rhevm-spice-client-x64-cab-3.1-4.el6.noarch

How reproducible:
always

Steps to Reproduce:
1. install usbclerk on Windows 2008 R2
2. connect to a console with (native) USB Auto Share enabled
3.
  
Actual results:
* USB selection menu is disabled
* this error is popped up upon device plug in:
Could not open usb device: Operation not supported or unimplemented on this platform [-12]

Expected results:
either:
* USB can be redirected
OR
* usbclerk service should refuse to launch (similarly to vdservice when virtio-serial port is missing)

Additional info:
Comment 1 Arnon Gilboa 2012-10-21 10:36:04 EDT
client is 2008 R2 32/64 bit?
please repro & attach %windir%\temp\usbclerk.log
Comment 2 David Blechter 2012-10-22 11:14:02 EDT
 2008 R2 32/64 is not in the rhevm 3.1 supported clients. Moving to the rhevm-future
Comment 3 Tomas Jamrisko 2012-10-25 07:24:00 EDT
*** Bug 870009 has been marked as a duplicate of this bug. ***
Comment 4 Tomas Jamrisko 2012-10-25 07:26:28 EDT
Created attachment 633274 [details]
Logs

Copying back log from the duplicate bug as requested by Arnon
Comment 6 Arnon Gilboa 2012-10-25 09:43:03 EDT
(In reply to comment #4)
> Created attachment 633274 [details]
> Logs
> 
> Copying back log from the duplicate bug as requested by Arnon

"driver install failed -- Unable to run process with required administrative privileges (-15)"
Is it running as SYSTEM? Can you try to manually change the usbclerk service privilages?
Comment 7 Tomas Jamrisko 2012-10-26 05:12:00 EDT
Running as SYSTEM, permissions in "Advanced Security Settings for usbclerk" are listed as Full Control. Not sure how I can elevate them even further.
Comment 8 Marian Krcmarik 2012-10-26 08:50:42 EDT
I've reproduced on Windows XP client so I am raising the severity.
USBClerk service is running under SYSTEM, not sure what to do with privileges in Windows XP.
Comment 9 Arnon Gilboa 2012-10-28 08:18:45 EDT
(In reply to comment #8)
> I've reproduced on Windows XP client so I am raising the severity.
> USBClerk service is running under SYSTEM, not sure what to do with
> privileges in Windows XP.

Is it the same error (-15) ? is it a new bug? how to repro? happens with all devices or only specific ones? please repro on XP client and attach usbclerk.log.
Comment 10 Tomas Jamrisko 2012-10-29 06:17:33 EDT
Created attachment 634962 [details]
Logs from XP
Comment 11 Tomas Jamrisko 2012-10-29 06:20:01 EDT
> Is it the same error (-15) ? is it a new bug? how to repro? happens with all
> devices or only specific ones? please repro on XP client and attach
> usbclerk.log.

Adding requested log. Exactly the same error. 

Happens with at the very least USB mass storage devices.
Comment 12 Arnon Gilboa 2012-10-31 11:53:45 EDT
The reason for this error is missing MS VC++ 2008 SP1 redist.

Two optional solutions:

1. Release note requiring to install it on client Windows for usbclerk to work.
x86: http://www.microsoft.com/download/en/details.aspx?id=5582
x64: http://www.microsoft.com/download/en/details.aspx?id=15336

2. Re-brew libwdi-win and its deps (installer, embedder) after patching it to use specific static libs instead of "standard windows libs", and then re-brew usbclerk-win.
Comment 13 Arnon Gilboa 2012-11-01 06:18:05 EDT
Created attachment 636542 [details]
use specific static libs

patch for option 2, which sounds better.
Comment 14 Uri Lublin 2012-11-01 07:10:27 EDT
I think options 1 of comment 12 is a good solution too, maybe better than 2.
Generally, and specifically for runtime libraries, using dynamic libraries is a good thing.

It's true that for some users, that do not have those libraries already installed on the client machine, may get a bit frustrated with usbredir not working immediately. They would have to spend some time to figure out why, download and install from the links above. As Arnon proposed we can add a release note about that.
Comment 15 Tomas Jamrisko 2012-11-01 09:47:40 EDT
Installing the above mentioned libraries also fixes this issue on server 2008
Comment 18 Arnon Gilboa 2012-11-15 10:54:53 EST
Finally choose option 2 of comment 12. Removed doc text.
Comment 22 errata-xmlrpc 2012-12-04 12:58:16 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2012-1527.html

Note You need to log in before you can comment on or make changes to this bug.