Bug 857147 - Auto-subscribe window has a confusing name
Auto-subscribe window has a confusing name
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: subscription-manager (Show other bugs)
7.0
Unspecified Unspecified
unspecified Severity medium
: beta
: 7.0
Assigned To: William Poteat
Entitlement Bugs
:
: 847229 (view as bug list)
Depends On:
Blocks: rhsm-rhel70
  Show dependency treegraph
 
Reported: 2012-09-13 12:43 EDT by J.C. Molet
Modified: 2014-06-17 20:22 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-13 06:01:18 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
auto-subscribe iwindow (74.70 KB, image/png)
2012-09-13 12:44 EDT, J.C. Molet
no flags Details
Subscription attachment screen (152.74 KB, image/png)
2014-02-07 08:45 EST, Sharath Dwaral
no flags Details

  None (edit)
Description J.C. Molet 2012-09-13 12:43:50 EDT
Description of problem:
The auto-subscribe window used to be part of the register dialog and process.  When it was moved to a new window so it could be done as a separate action, all the strings remained the same and it looks as if the dialog is still part of the registration window.

Version-Release number of selected component (if applicable):
subscription-manager-gui-1.0.17-1.git.12.23074e9.el5

How reproducible:
always

Steps to Reproduce:
1. Start up subscription manager
2. Register
3a. Open the auto-subscribe dialog by clicking the auto subscribe button
3b. When you register in step 2, don't check "manually subscribe"
  
Actual results:
3b) If autosubscribing while registering, when the user gets to the subscription part of the process, the user still thinks they are in the registration process. This presents a problem because if the user presses cancel at this point, they are still registered when the dialog closes and it does not actually cancel the register.

3a) If opening the auto-subscribe dialog through its stand alone button, The progress bar reads "Registering" and the window title reads "System Registration".  This is misleading and confusing because the system has already been long registered at this point. Additionally the dialog has nothing to do with registering.

Expected results:
The auto-subscribe window should take some measures to let the user know they are not registering at this point.

I would start by changing both the window title and the tile of the progress bar to something that has to do with finding subscriptions.

Additional info:
Attached screen shot to follow.
Comment 1 J.C. Molet 2012-09-13 12:44:34 EDT
Created attachment 612504 [details]
auto-subscribe iwindow
Comment 2 RHEL Product and Program Management 2012-09-13 12:48:16 EDT
This request was evaluated by Red Hat Product Management for inclusion
in a Red Hat Enterprise Linux release.  Product Management has
requested further review of this request by Red Hat Engineering, for
potential inclusion in a Red Hat Enterprise Linux release for currently
deployed products.  This request is not yet committed for inclusion in
a release.
Comment 6 Adrian Likins 2012-11-19 10:37:25 EST
I think I'm going to push this out again. If we have to change it for 6.4, we can probably do it with existing strings, or get an exception. Not confident in trying to fix this for string freeze.
Comment 7 Carter Kozak 2014-01-17 12:48:40 EST
*** Bug 847229 has been marked as a duplicate of this bug. ***
Comment 8 William Poteat 2014-01-30 11:26:01 EST
master commit 98d3f86157b266330de0ed0ee0e74d6650f45c46
Comment 10 Sharath Dwaral 2014-02-07 08:45:00 EST
Created attachment 860521 [details]
Subscription attachment screen

Version

# subscription-manager version 
server type: Red Hat Subscription Management
subscription management server: 0.9.3-1
subscription-manager: 1.10.13-1.el7
python-rhsm: 1.10.12-1.el7


Verification:

Scenario 1: Register with auto-attach

     Register system to candlepin uncheck manually attach subscriptions option

Scenario 2: Register without auto-attach

     Register systerm to candlepin check manually attach subscriptions option
     Click on auto-attach mutton after registering

The registration process has window header as "System Registration"
And dutring subscription attachment it has widow header "Subscription Attachment"

Please see attachment.


Additional Information:

To see the sequence of screens refer comment 5

VERIFIED
Comment 11 Ludek Smid 2014-06-13 06:01:18 EDT
This request was resolved in Red Hat Enterprise Linux 7.0.

Contact your manager or support representative in case you have further questions about the request.

Note You need to log in before you can comment on or make changes to this bug.