Bug 857192 - Missing index in EVENTTYPES table
Missing index in EVENTTYPES table
Status: CLOSED DUPLICATE of bug 883412
Product: JBoss Enterprise BRMS Platform 5
Classification: JBoss
Component: doc-BRMS_Rule_Flow_Component_Guide (Show other bugs)
BRMS 5.3.0.GA
Unspecified Unspecified
high Severity high
: ---
: future
Assigned To: lcarlon
Lukáš Petrovický
: Documentation
Depends On: 854612 864558
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-13 14:45 EDT by Marco Rietveld
Modified: 2016-09-20 01:04 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 854612
Environment:
Last Closed: 2013-01-20 22:32:13 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker JBPM-3589 Major Resolved drools-flow: deadlock for concurrent process completions in oracle 2013-01-20 22:35:04 EST

  None (edit)
Description Marco Rietveld 2012-09-13 14:45:35 EDT
After talking with mweiler about this, we decided that we'd do 2 things: 

1. provide a technical solution 
2. Document the solution (for cases in which the technical solution doesn't work). 

This bug is for 2, the documentation. When I've written the documentation, I'll mention the commit and change the status to modified. 

+++ This bug was initially created as a clone of Bug #854612 +++

Description of problem:
Platform issue for JBPM-3589:

In the EVENTTABLES table, the INSTANCEID column isn't indexed. As the column is a foreign key to the ProcessInstanceInfo table, and as unindexed foreign key columns are a common cause of deadlock issues in Oracle, an index should be added:

CREATE INDEX IDX_EVENTTYPES ON EVENTTYPES (INSTANCEID);
Comment 1 Marco Rietveld 2012-09-13 14:52:43 EDT
Just realized that changing the status isn't appropriate -- I'll add a link to the git diff when I've written the documentation.
Comment 3 JBoss JIRA Server 2012-12-18 17:35:29 EST
Marco Rietveld <marco.rietveld@redhat.com> updated the status of jira JBPM-3589 to Resolved
Comment 4 JBoss JIRA Server 2012-12-18 17:35:29 EST
Marco Rietveld <marco.rietveld@redhat.com> made a comment on jira JBPM-3589

This has been fixed in the latest version of 5.2.x.
Comment 5 JBoss JIRA Server 2012-12-18 17:36:11 EST
Marco Rietveld <marco.rietveld@redhat.com> made a comment on jira JBPM-3589

This has been fixed in the latest version of 5.2.x (which has not been released yet, I believe).
Comment 6 lcarlon 2013-01-20 22:32:13 EST
Marked as a duplicate, though the solution was eventually changed so the info in this bug is no longer required.

*** This bug has been marked as a duplicate of bug 883412 ***

Note You need to log in before you can comment on or make changes to this bug.