Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 883412 - Document what needs to be updated in database schema created by BRMS for production use
Summary: Document what needs to be updated in database schema created by BRMS for prod...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: JBoss Enterprise BRMS Platform 5
Classification: JBoss
Component: doc-BRMS_Administrator_Guide
Version: BRMS 5.3.1
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: ---
Assignee: lcarlon
QA Contact: Jiri Svitak
URL:
Whiteboard:
: 857192 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-12-04 14:35 UTC by Jiri Svitak
Modified: 2018-11-28 19:26 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-01-21 03:33:16 UTC
Type: Bug


Attachments (Terms of Use)

Description Jiri Svitak 2012-12-04 14:35:10 UTC
Deadlock issues happened on Oracle (https://bugzilla.redhat.com/show_bug.cgi?id=854612) due to missing index on column InstanceId in EventTypes table. Initial solution to add a missing index by using hibernate xml script proved to be a bad idea. It's hard to manage database specific problems by this file.

Documentation should be updated with information about all unindexed columns in database schema and should contain recommendation to add indexes to destined columns before using the database for production use.

Comment 1 lcarlon 2012-12-05 00:57:38 UTC
Hi Jiri,

Thanks for reporting. Who's the best person to provide the steps that need to be taken to resolve this issue?

We're well past the point at which the docs team can create new content for this release; however, if this is a fairly critical issue and somebody can provide the information in a step by step form that users can follow we'll add to the admin guide.

(I've also asked for info in the related email thread).

Thanks
Lee

Comment 2 lcarlon 2012-12-05 01:01:12 UTC
Hi Jiri,

Thanks for reporting. Who's the best person to provide the steps that need to be taken to resolve this issue?

We're well past the point at which the docs team can create new content for this release; however, if this is a fairly critical issue and somebody can provide the information in a step by step form that users can follow we'll add to the admin guide.

(I've also asked for info in the related email thread).

Thanks
Lee

Comment 3 lcarlon 2012-12-06 03:18:21 UTC
Alessandro and Marco have provided the content by email. I have updated the doc and will post a link as soon as it is available on the internal doc stage.

Thanks
Lee

Comment 9 Jiri Svitak 2012-12-07 14:04:10 UTC
Hi Lee,

thank you for fixing the typos and creating a separate section for database indexes, I think it's better this way.

Regarding to hbm2ddl property - don't delete that from other parts of the documentation as it well serves for demonstration purposes. Text from section 2.6 was deleted because of incorrect description for creating indexes.

I think that current fixes are sufficient and no other changes are necessary. Verified.

Comment 10 lcarlon 2012-12-10 01:22:51 UTC
Thanks, Jiri!

Comment 12 lcarlon 2012-12-20 00:17:31 UTC
Thanks you, Toshiya.

I've corrected the typo and will publish the updated guide.

Comment 13 lcarlon 2013-01-21 03:32:13 UTC
*** Bug 857192 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.