Bug 857373 - MozNSS certificate database in SQL format cannot be used
MozNSS certificate database in SQL format cannot be used
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: openldap (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jan Vcelak
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 857390
  Show dependency treegraph
 
Reported: 2012-09-14 04:56 EDT by Jan Vcelak
Modified: 2013-03-03 20:30 EST (History)
4 users (show)

See Also:
Fixed In Version: openldap-2.4.32-3.fc17
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 857390 860317 (view as bug list)
Environment:
Last Closed: 2012-12-20 11:03:59 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch (1.10 KB, patch)
2012-09-14 05:00 EDT, Jan Vcelak
no flags Details | Diff

  None (edit)
Description Jan Vcelak 2012-09-14 04:56:24 EDT
Description of problem:

MozNSS certificate database in newer SQL format cannot be used. Database prefix is recognized incorrectly.


Version-Release number of selected component (if applicable):
openldap-2.4.32-2.fc17


How reproducible:
always


Steps to Reproduce:
1. certutil -d sql:/tmp/certdb -N
2. certutil -d sql:/tmp/certdb -A -n ca -t TC,, -a -i /tmp/ca.pem
3. LDAPTLS_CACERTDIR=sql:/tmp/certdb ldapsearch -x -ZZ -d1
  
Actual results:

...
TLS: certdb config: configDir='sql:/tmp' tokenDescription='ldap(0)' certPrefix='certdb' keyPrefix='certdb' flags=readOnly
TLS: cannot open certdb 'sql:/tmp', error -8018:Unknown PKCS #11 error.
TLS: could not get info about the CA certificate directory sql:/tmp/certdb - error -5950:File not found.
...
ldap_start_tls: Connect error (-11)
        additional info: TLS error -8172:Peer's certificate issuer has been marked as not trusted by the user.


Expected results:

...
TLS: certdb config: configDir='sql:/tmp/certdb' tokenDescription='ldap(0)' certPrefix='' keyPrefix='' flags=readOnly
TLS: using moznss security dir sql:/tmp/certdb prefix .
...


Additional info:

Not a regression, this seems to be a problem since switching to MozNSS.
Comment 1 Jan Vcelak 2012-09-14 05:00:18 EDT
Created attachment 612778 [details]
patch

Upstream submission will follow.
Comment 2 Jan Vcelak 2012-09-14 05:57:19 EDT
Upstream report:
http://www.openldap.org/its/index.cgi?findid=7388
Comment 3 Fedora Update System 2012-09-19 05:11:51 EDT
openldap-2.4.32-3.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/openldap-2.4.32-3.fc17
Comment 4 Fedora Update System 2012-09-19 05:13:22 EDT
openldap-2.4.32-3.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/openldap-2.4.32-3.fc18
Comment 5 Fedora Update System 2012-09-20 01:58:21 EDT
Package openldap-2.4.32-3.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing openldap-2.4.32-3.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-14390/openldap-2.4.32-3.fc18
then log in and leave karma (feedback).
Comment 6 Fedora Update System 2012-10-07 22:24:36 EDT
openldap-2.4.32-3.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 7 Fedora Update System 2012-12-20 11:04:02 EST
openldap-2.4.32-3.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.