Bug 857390 - MozNSS certificate database in SQL format cannot be used
Summary: MozNSS certificate database in SQL format cannot be used
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: openldap (Show other bugs)
(Show other bugs)
Version: 6.3
Hardware: Unspecified Unspecified
high
medium
Target Milestone: rc
: ---
Assignee: Jan Vcelak
QA Contact: David Spurek
URL:
Whiteboard:
Keywords:
Depends On: 857373
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-09-14 10:02 UTC by Jan Vcelak
Modified: 2015-03-02 05:27 UTC (History)
6 users (show)

Fixed In Version: openldap-2.4.23-29.el6
Doc Type: Bug Fix
Doc Text:
Cause: TLS_CACERTDIR has a prefix which specifies used Mozilla NSS database type (like 'sql:') and TLS operation is requested. Consequence: The certificate database fails to open. Fix: Patch applied, which removes the database type prefix, when checking the existence of the directory with certificate database. Result: The certificate database is successfully opened even if the database type prefix is used.
Story Points: ---
Clone Of: 857373
Environment:
Last Closed: 2013-02-21 09:46:25 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2013:0364 normal SHIPPED_LIVE openldap bug fix and enhancement update 2013-02-20 20:52:54 UTC

Description Jan Vcelak 2012-09-14 10:02:38 UTC
This problem is present in RHEL-6 as well.

Version-Release number of selected component (if applicable):
openldap-2.4.23-26.el6_3.2.x86_64

+++ This bug was initially created as a clone of Bug #857373 +++

Description of problem:

MozNSS certificate database in newer SQL format cannot be used. Database prefix is recognized incorrectly.


Version-Release number of selected component (if applicable):
openldap-2.4.32-2.fc17


How reproducible:
always


Steps to Reproduce:
1. certutil -d sql:/tmp/certdb -N
2. certutil -d sql:/tmp/certdb -A -n ca -t TC,, -a -i /tmp/ca.pem
3. LDAPTLS_CACERTDIR=sql:/tmp/certdb ldapsearch -x -ZZ -d1
  
Actual results:

...
TLS: certdb config: configDir='sql:/tmp' tokenDescription='ldap(0)' certPrefix='certdb' keyPrefix='certdb' flags=readOnly
TLS: cannot open certdb 'sql:/tmp', error -8018:Unknown PKCS #11 error.
TLS: could not get info about the CA certificate directory sql:/tmp/certdb - error -5950:File not found.
...
ldap_start_tls: Connect error (-11)
        additional info: TLS error -8172:Peer's certificate issuer has been marked as not trusted by the user.


Expected results:

...
TLS: certdb config: configDir='sql:/tmp/certdb' tokenDescription='ldap(0)' certPrefix='' keyPrefix='' flags=readOnly
TLS: using moznss security dir sql:/tmp/certdb prefix .
...


Additional info:

Not a regression, this seems to be a problem since switching to MozNSS.

--- Additional comment from jvcelak@redhat.com on 2012-09-14 11:00:18 CEST ---

Created attachment 612778 [details]
patch

Upstream submission will follow.

--- Additional comment from jvcelak@redhat.com on 2012-09-14 11:57:19 CEST ---

Upstream report:
http://www.openldap.org/its/index.cgi?findid=7388

Comment 2 Jan Vcelak 2012-09-25 16:10:30 UTC
Resolved in: openldap-2.4.23-29.el6

Comment 6 errata-xmlrpc 2013-02-21 09:46:25 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0364.html


Note You need to log in before you can comment on or make changes to this bug.