Bug 857430 - cursor somewhat broken in server mode on windows 7/8 clients and guests
cursor somewhat broken in server mode on windows 7/8 clients and guests
Status: CLOSED ERRATA
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: mingw-virt-viewer (Show other bugs)
3.1.0
Unspecified Windows
high Severity unspecified
: ---
: ---
Assigned To: Marc-Andre Lureau
Desktop QE
:
: 843110 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-14 07:46 EDT by Tomas Jamrisko
Modified: 2015-09-22 09 EDT (History)
11 users (show)

See Also:
Fixed In Version: mingw-virt-viewer-0.5.3-15.el6
Doc Type: Bug Fix
Doc Text:
Some multiple-screen users experienced inconsistent cursor behavior (erratic cursor movement or an inability to return cursor to the client window) due to a problem with the cursor clip. This error has now been corrected so that users can experience expected cursor behavior.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-04 12:59:00 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Video of what's wrong (34.82 MB, video/mp4)
2012-10-25 08:41 EDT, Tomas Jamrisko
no flags Details

  None (edit)
Description Tomas Jamrisko 2012-09-14 07:46:42 EDT
Description of problem:
Connecting to a freshly installed windows 7 (without any additional tools/agents) guest from windows 7/8 client results in a completely weird cursor behaviour -- cursor can't even get over virt-viewer window and instead "bounces back". 

Version-Release number of selected component (if applicable):
mingw-virt-viewer 0.5.3

How reproducible:
Always

Steps to Reproduce:
1. Install somewhere a clean win 7 guest
2. Set it up, so that you have to press ctrl+alt+del before logging in
3. Close the connection
4. Shut it down
5. Start it up again
6. Connect to the login screen
  
Actual results:
Cursor is completely unusable -- makes small bounces on guest in one corner, bounces from edges of window on client. (Send key Ctr+alt+del didn't work once either) 

Expected results:
the cursor should be captured and locked in guest.
Comment 3 Marc-Andre Lureau 2012-10-11 17:38:41 EDT
are you testing mingw-virt-viewer inside a VM (through spice or vnc)?
Comment 4 David Jaša 2012-10-12 05:35:16 EDT
(In reply to comment #3)
> are you testing mingw-virt-viewer inside a VM (through spice or vnc)?

I encountered this on physical Windows XP client, too. The issue seems to be sort of random, I reproduced it with single client/host/guest twice, then something non-obvious happened and the cursor started working normally.
Comment 5 David Jaša 2012-10-12 05:39:19 EDT
My random reproducer was somewhat simpler:
1) connect to a VM
2) make sure that agent is not running
3) disconnect from a VM, reconnect
4) grab cursor
Comment 6 Tomas Jamrisko 2012-10-25 08:41:56 EDT
Created attachment 633298 [details]
Video of what's wrong

Tried powering up an older installation of a clean XP VM, and couldn't do much because of this cursor issue. 

Also David encountered the same problem with Fedora 18 guest, with vm mouse driver on a RHEL 6.4 client with virt-viewer-0.5.2-15. 

So this problem most likely **isn't limited to** windows clients. 

The problem is, randomness of the issue. 

Mine client had 2 monitors, when I disconnected one, the mouse worked fairly fine. David's problems persisted.
Comment 7 Vaclav Ehrlich 2012-10-26 07:08:19 EDT
Same here. Client/guest Win7 64b, RHEVM 3.1 si19.1
Comment 8 Tomas Jamrisko 2012-10-26 07:12:41 EDT
Raising priority as this bug bugged us consistently during our RHEVM 3.1 Beta 3 integration testing. 

100% reproducer seemed to be: 

1. Install windows 7 guest from a template - make sure you don't have any agents running. 
2. Connect to it from a Windows client
Comment 9 David Jaša 2012-10-29 16:08:32 EDT
Several more observations:

1) it happened to me last time right after first connection to freshly sysprep'd VM from template (win7x64), last client win xp

2) the cursor should be grabbed (title bar says "(Press <combo> to release pointer)") but it isn't, or more precisely, it's inversely grabbed

3) cursor jupms to the center of the whole screen: if you have two identical monitors side-by-side, it jumps to the center of common edge. The same goes for two monitor vertically and similarly for two identical monitors vertically - then the pointer jumps to the common

4) sometimes, when you right-click taskbar entry of r-v window, the mouse jumps as if it touched the actual window - even when there is fairly large gap between the taskbar menu and the window

5) once when I right-clicked the taskbar entry, guest also received right-click near the right edge of its desktop
Comment 10 Marc-Andre Lureau 2012-10-30 07:52:58 EDT
I have a simpler reproducer:

Mouse in server mode, move client window so that it isn't in the center of the screen, enter the window, the mouse is grabbed and move. The cursor will be visible again, and any attempt to reach the client window will bring the cursor back to the center of the screen. This is related to moving the cursor out of the cursor clip...
Comment 11 Marc-Andre Lureau 2012-10-31 11:08:42 EDT
sending patches to ML
Comment 15 Marian Krcmarik 2012-11-16 10:38:59 EST
*** Bug 843110 has been marked as a duplicate of this bug. ***
Comment 17 errata-xmlrpc 2012-12-04 12:59:00 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2012-1525.html

Note You need to log in before you can comment on or make changes to this bug.