Bug 843110 - Grabbing mouse focus inside guest does not work on non-primary monitor screens in server mouse mode.
Grabbing mouse focus inside guest does not work on non-primary monitor screen...
Status: CLOSED DUPLICATE of bug 857430
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: mingw-virt-viewer (Show other bugs)
3.1.0
Unspecified Unspecified
unspecified Severity low
: ---
: ---
Assigned To: Marc-Andre Lureau
Desktop QE
spice
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-25 11:43 EDT by Marian Krcmarik
Modified: 2016-02-10 15:21 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-16 10:38:59 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Spice
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Marian Krcmarik 2012-07-25 11:43:28 EDT
Description of problem:
When a user ungrabs mouse focus from guest with multiple monitors (keyboard shortcut Ctrl+Alt, SHift+F12 (in RHEVM)) It's not possible to enter the guest and grab mouse focs again on non-primary screen, after clicking into non-primary screen mouse cursor is stuck where It was left, Not possible to move with mouse cursor, It is possible to grab mouse focus and move mouse on primary screen. THis does not happen with linux remote-viewer.

Version-Release number of selected component (if applicable):
mingw-virt-viewer-0.5.3-8.el6

How reproducible:
Always

Steps to Reproduce:
1. Connect with mingw-virt-viewer to a Windows guest with multiple monitors, Be sure to have server mouse mode.
2. Ungrab mouse focus from guest.
3. Try to click inside non-primary monitor of guest to grab your mouse inside guest.
  
Actual results:
Mouse is stuck on the place It was left, cannot move with cursor.

Expected results:
A user should be able to grab mouse inside guest on any screen of guest.

Additional info:
Comment 1 Marc-Andre Lureau 2012-11-16 07:53:58 EST
hey, can you try againt with latest build? mingw-virt-viewer-0.5.3-17

It could eventually be fixed with bug 872640. thanks for checking
Comment 2 Marian Krcmarik 2012-11-16 09:06:21 EST
(In reply to comment #1)
> hey, can you try againt with latest build? mingw-virt-viewer-0.5.3-17
> 
> It could eventually be fixed with bug 872640. thanks for checking

Yes It seems to be fixed, Now It's possible to enter guest with mouse in any screen while having server mode mouse.
Comment 3 Marc-Andre Lureau 2012-11-16 10:18:42 EST
(In reply to comment #2)
> Yes It seems to be fixed, Now It's possible to enter guest with mouse in any
> screen while having server mode mouse.

should we mark as dup?
Comment 4 Marian Krcmarik 2012-11-16 10:38:59 EST
(In reply to comment #3)
> (In reply to comment #2)
> > Yes It seems to be fixed, Now It's possible to enter guest with mouse in any
> > screen while having server mode mouse.
> 
> should we mark as dup?

Whatever, does not matter (except for statistics).

*** This bug has been marked as a duplicate of bug 857430 ***

Note You need to log in before you can comment on or make changes to this bug.