Bug 857517 - Anaconda in RHEL 6 does not honor the --fsoptions= with swap partitions
Anaconda in RHEL 6 does not honor the --fsoptions= with swap partitions
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: anaconda (Show other bugs)
6.3
x86_64 Linux
medium Severity medium
: rc
: 6.4
Assigned To: Brian Lane
Release Test Team
: Reopened
Depends On:
Blocks: 960065
  Show dependency treegraph
 
Reported: 2012-09-14 13:18 EDT by BJ Walker
Modified: 2015-09-27 22:28 EDT (History)
8 users (show)

See Also:
Fixed In Version: anaconda-13.21.199-1
Doc Type: Bug Fix
Doc Text:
No documentation needed.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-21 04:54:28 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description BJ Walker 2012-09-14 13:18:09 EDT
Description of problem:
When trying to install RHEL 6 using a kickstart and specifying any fsoptions="option" into the partitioning section (as seen below), Anaconda is not honoring.  Have tried syntax as specified in documentation however at no point is it copied into /etc/fstab.  We have previously opened a bug for the documentation to add this option: https://bugzilla.redhat.com/show_bug.cgi?id=601977 however I have been able to reproduce (as well as the customer) that at no time is this line honored.

Version-Release number of selected component (if applicable):
anaconda-13.21.176-1.el6_3

How reproducible:
Every time.  I have no been able to have Anaconda copy ANY options from the --fsoptions= line.

Steps to Reproduce:
1. Add a line into any of the partitions to append options into the /etc/fstab
2. Kickstart install any RHEL 6.x system
3. Upon reboot the options for that partition in /etc/fstab are set to defaults
  
Actual results:
Options in /etc/fstab are set to defaults

Expected results:
Options in /etc/fstab are set to the same options as defined by --fsoptions= in the kickstart

Additional info:
Documentation is seen here: https://access.redhat.com/knowledge/docs/en-US/Red_Hat_Enterprise_Linux/6/html/Installation_Guide/s1-kickstart2-options.html  however I am unable to get this option to ever work, no matter the syntax I use.  Not sure if it ever worked in RHEL 6, though it does work in RHEL 5.
Comment 2 Brian Lane 2012-09-18 12:42:46 EDT
Please switch to tty2 (ctrl-alt-f2) and attach the logs from /tmp/*log to this bug as individual text/plain files.
Comment 3 David Cantrell 2012-10-16 13:27:47 EDT
Closing as insufficient data as we do not have any log files from the reporter.  If you are able to provide the log files, please attach them as individual plain text files to this bug and reopen it.
Comment 5 BJ Walker 2012-12-10 09:19:19 EST
Uploaded the requested log files and reopened the bugzilla.  Thanks!
Comment 7 Martin Banas 2013-05-23 03:48:39 EDT
Hi,

I'm not able to reproduce your bug. Could you please attach the kickstart you used? If I use following, it's copied to /etc/fstab then.

ks.cfg:
part / --size=1000 --asprimary
part /usr --size=3200 --asprimary
part /var --size=200 --asprimary --fsoptions='noatime'
part /home --size=200 --asprimary --fsoptions='noatime'

/etc/fstab:
UUID=28989961-48ed-4587-94ac-4f2055e1a7e5 /                       ext4    defaults        1 1
UUID=cbdf9559-3f55-41b6-a123-fbfa75a2f819 /home                   ext4    noatime         1 2
UUID=98851567-9b6d-4e85-8ba1-09a23b0c9bda /usr                    ext4    defaults        1 2
UUID=3724842b-e7ce-4aa5-8d13-b38e9fd1e21d /var                    ext4    noatime         1 2
Comment 8 Jan Stodola 2013-05-23 07:16:54 EDT
Reproduced with following partitioning:

bootloader --location=mbr
zerombr
clearpart --all --initlabel
part /boot --asprimary --size=500 --label=boot
part pv.01 --grow --maxsize=8192 --size=2048
part pv.02 --grow --maxsize=8192 --size=2048
volgroup SNAKEVG --pesize=32768 pv.01 pv.02
logvol swap --fstype=swap --recommended --name=SNAKE_SWAP --vgname=SNAKEVG --fsoptions="pri=10"
logvol / --grow --maxsize=10240 --size=2048 --name=SNAKEROOT --vgname=SNAKEVG
Comment 14 Brian Lane 2013-06-28 17:21:23 EDT
This was limited to swap partitions, normal partitions pick up --fsoptions just fine.
Comment 16 Ľuboš Kardoš 2013-08-28 09:30:51 EDT
Verified on RHEL6.5-20130820.2 anaconda 13.21.203
Comment 18 errata-xmlrpc 2013-11-21 04:54:28 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1588.html

Note You need to log in before you can comment on or make changes to this bug.