Bug 601977 - Please document the usage of '--fsoptions' for the 'part|partition' kickstart option in the install guide.
Please document the usage of '--fsoptions' for the 'part|partition' kickstart...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: doc-Installation_Guide (Show other bugs)
6.0
All Linux
low Severity medium
: rc
: ---
Assigned To: Ruediger Landmann
: Documentation
Depends On: 600298
Blocks: 601980
  Show dependency treegraph
 
Reported: 2010-06-08 19:46 EDT by Michael Hideo
Modified: 2010-11-11 10:34 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 600298
: 601980 (view as bug list)
Environment:
Last Closed: 2010-11-11 10:34:00 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Hideo 2010-06-08 19:46:26 EDT
+++ This bug was initially created as a clone of Bug #600298 +++

Description of problem:
Kickstart documentation in the "RHEL Installation Guide" does not document the
'part|partition' option's "--fsoptions" option.

Version-Release number of selected component (if applicable):
RHEL 5.5 and earlier.

How reproducible:
100%

Steps to Reproduce:
1. Read the installation guide's section on kickstart from start to finish.
2. Read through it again looking for a way to specify mount options.
3. Observe that there isn't any such option documented for the 'part' option.

Actual results:
Write your own ugly script in %post to munge fstab because you can't find a
built in method to specify mount options.  Hit corner cases that don't quite work right and have to special case them while your nose hairs fall out.  ;o)

Accidentally stumble upon the --fsoptions option documented in the 'raid' and 'logvol' options, and then notice it also on the Fedoraproject website anaconda documentation.

Test the option out in a dummy kickstart install and discover that it actually works with 'part' and not just with 'raid' and 'logvol'.  Rejoice and remove a screenful of unnecessary bash scripting from %post.  ;o)


Expected results:
For --fsoptions to be documented under the 'part' option, and any other missing options that there might be left to discover. ;o)


Additional info:
I'd paste my fstab_munge() function here for completeness but it'd make you barf.

--- Additional comment from clumens@redhat.com on 2010-06-04 13:09:15 EDT ---

Here's what docs/kickstart-docs.txt on rhel5-branch has to say:

       --fsoptions=

           Specifies a free form string of options to be used when
           mounting the filesystem. This string will be copied into the
           /etc/fstab file of the installed system and should be enclosed
           in quotes.

--- Additional comment from mharris@mharris.ca on 2010-06-05 06:51:29 EDT ---

I probably didn't file this bug report against the right component as it is technically not an anaconda bug.  The problem is specifically the RHEL 5 Installation Guide does not mention the option, so anyone using that as their basis for writing a kickstart file, will not see the --fsoptions documented for the 'part' command, and may resort to writing their own /etc/fstab mangling routines in %post.  When I discovered this and mentioned it in IRC, 3 or 4 other competent admins mentioned that they did the same type of mangling and were happy to find out about --fsoptions.

It is good that it is documented elsewhere, but all documentation should be consistent.  I suspect most admins, in particular newer admins will look either directly in the RHEL Installation Guide, or to Google, and "docs/kickstart.txt" doesn't come up high in the search list.  ;o)

I'll try to reassign this to the proper component if I can figure that out.

--- Additional comment from mharris@mharris.ca on 2010-06-05 06:53:11 EDT ---

Doh, my bad...  I didn't notice it was already reassigned.  Good stuff.  Now that I'm aware of the option, this isn't for me, but rather for other admins out there who might not ever go looking beyond the installation guide for kickstart documentation.  It's a minor issue, but would still be nice to see it fixed in the next documentation update.
Comment 1 Ruediger Landmann 2010-06-21 02:43:58 EDT
Fixed in build 0-64 onwards
Comment 3 releng-rhel@redhat.com 2010-11-11 10:34:00 EST
Red Hat Enterprise Linux 6.0 is now available and should resolve
the problem described in this bug report. This report is therefore being closed
with a resolution of CURRENTRELEASE. You may reopen this bug report if the
solution does not work for you.

Note You need to log in before you can comment on or make changes to this bug.