Bug 857751 - add conditionals to be able to build with systemd or sysvinit support whereever applicable
add conditionals to be able to build with systemd or sysvinit support whereev...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: mediatomb (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Gwyn Ciesla
Fedora Extras Quality Assurance
:
: 857746 857749 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-16 14:57 EDT by David Jaša
Modified: 2012-12-20 11:25 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-20 11:25:02 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
example spec patch (5.30 KB, patch)
2012-09-16 14:57 EDT, David Jaša
no flags Details | Diff

  None (edit)
Description David Jaša 2012-09-16 14:57:50 EDT
Created attachment 613493 [details]
example spec patch

Description of problem:
add conditionals to be able to build with systemd or sysvinit support whereever applicable.

The example patch also clears obsolete conditionals (<= fc13) and bug 857746 and bug 857749.

Please try the patch if it indeed doesn't touch build systemd system, I couldn't do it myself because mediatomb (even stock one) fails to build in my fc17 machine.

Version-Release number of selected component (if applicable):
0.12.1-17

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Gwyn Ciesla 2012-09-17 13:57:22 EDT
Fix coming.
Comment 2 Gwyn Ciesla 2012-09-17 14:18:32 EDT
*** Bug 857746 has been marked as a duplicate of this bug. ***
Comment 3 Gwyn Ciesla 2012-09-17 14:18:39 EDT
*** Bug 857749 has been marked as a duplicate of this bug. ***
Comment 4 Gwyn Ciesla 2012-09-17 14:19:08 EDT
Rawhide build broke, I'll wait for another compose and try again.
Comment 5 Gwyn Ciesla 2012-09-18 09:20:46 EDT
Still won't build on rawhide, f18 is fine.
Comment 6 Gwyn Ciesla 2012-09-18 11:55:12 EDT
Old version is FTBFS too.
Comment 7 Gwyn Ciesla 2012-10-15 09:37:10 EDT
Built in rawhide.
Comment 8 Fedora Update System 2012-10-15 12:01:06 EDT
mediatomb-0.12.1-19.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/mediatomb-0.12.1-19.fc18
Comment 9 Fedora Update System 2012-10-15 12:01:33 EDT
mediatomb-0.12.1-19.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/mediatomb-0.12.1-19.fc17
Comment 10 Fedora Update System 2012-10-15 13:39:09 EDT
Package mediatomb-0.12.1-19.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing mediatomb-0.12.1-19.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-16142/mediatomb-0.12.1-19.fc18
then log in and leave karma (feedback).
Comment 11 Fedora Update System 2012-12-20 11:25:03 EST
mediatomb-0.12.1-19.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.