Bug 857846 - Configured a static ip for RHEV-H and registered RHEV-M successful, status page should display "static" not "none".
Configured a static ip for RHEV-H and registered RHEV-M successful, status pa...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ovirt-node (Show other bugs)
6.3
Unspecified Unspecified
urgent Severity urgent
: rc
: ---
Assigned To: Fabian Deutsch
Virtualization Bugs
: Regression, ZStream
Depends On:
Blocks: 863161
  Show dependency treegraph
 
Reported: 2012-09-17 04:26 EDT by chencong
Modified: 2016-04-26 10:05 EDT (History)
16 users (show)

See Also:
Fixed In Version: ovirt-node-2.5.0-5.el6
Doc Type: Bug Fix
Doc Text:
When interfaces on the hypervisor were configured to use a static IP address the status page listed the relevant connection as "none". The hypervisor has been updated. Connections configured to use a static IP address are now correctly listed on the status page as "static".
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-28 11:38:54 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
vdsm.log,libvirt.log,vdsm-reg.log (16.97 KB, application/x-gzip)
2012-09-17 04:26 EDT, chencong
no flags Details
ovirt.log (126.25 KB, text/x-log)
2012-09-17 06:12 EDT, chencong
no flags Details

  None (edit)
Description chencong 2012-09-17 04:26:56 EDT
Created attachment 613590 [details]
vdsm.log,libvirt.log,vdsm-reg.log

Description of problem:
If configured a static ip for rhev-h to registered rhev-m, at the status page of rhev-h should display:"static" not "none".

Version-Release number of selected component (if applicable):
rhev-hypervisor 6-6.3-20120910.0.rhev31.el6_3
vdsm-4.9-113.3.el6_3.x86_64
rhev-m 3.0.7_0001-2.el6_3
rhev-m 3.1.0-14.el6ev

How reproducible:
100%

Steps to Reproduce:
1. Install RHEV-H.
2. Configure static ip for the nic ,registered to RHEV-M successful.
3. Check the status page "Networking" display.

Actual results:
Configured a static ip and registered to RHEV-M successful, the status page of RHEV-H display "Networking :    rhevm:    none 10.66.11.20".

Expected results:
Configured a static ip and regiested to RHEV-M successful, the status page of RHEV-H should display "Networking :    rhevm: static    10.66.11.20".


Additional info:
It's right when configured a dhcp ip.No such issue in RHEV-H 6.3-20120815.0.el6_3 , so it is a regression bug.
Comment 3 chencong 2012-09-17 06:12:51 EDT
Created attachment 613621 [details]
ovirt.log
Comment 4 Fabian Deutsch 2012-09-17 09:56:16 EDT
Cong,

could you also provide the vdsm log and the output if ifcfg and brctl show.

thanks
Comment 5 Fabian Deutsch 2012-09-17 10:38:34 EDT
vdms is setting BOOTPROTO=static [1], the UI is just displaying that variable.
According to vdsm static is the correct value for static IP configurations.

In this case we should just replace none with "static".

[1] http://gerrit.ovirt.org/gitweb?p=vdsm.git;a=blob;f=vdsm/configNetwork.py;hb=HEAD#l402
Comment 6 Fabian Deutsch 2012-09-17 10:50:28 EDT
http://gerrit.ovirt.org/#/c/8023/

Tested as follows:

1. Install Node
2. Apply patch
3. Configure static net
4. Change ifcfg-breth0 bootproto to none
5. Re-login into the tui
6. static is displayed on status page
Comment 8 Fabian Deutsch 2012-09-20 04:51:53 EDT
(In reply to comment #5)
> vdms is setting BOOTPROTO=static [1], the UI is just displaying that
> variable.

Correction:
vdsm is setting BOOTPROTO=none
Comment 9 Fabian Deutsch 2012-09-20 04:59:39 EDT
Just to point it out, Node is setting BOOTPROTO=static in ifcfg-breth*, but looking at the docs [1] 'static' is no intended value for BOOTPROTO. 
It's noteworthy that looking at the search results of a famous search engine it seems to be common to use BOOTPROTO=static.
So, vdsm is doing the right thing and the TUI just needs to interprete BOOTPROTO=none as a static IP configuration.

[1] https://access.redhat.com/knowledge/docs/en-US/Red_Hat_Enterprise_Linux/6/html/Deployment_Guide/s1-networkscripts-interfaces.html
Comment 12 shaochen 2012-10-31 06:18:33 EDT
There is a existing bug: Bug 867784 - [RHEV-H 6.4] The "DHCP" was marked "*" in network detail page if configured nic by using "static" .
So I will verify this bug after 867784 fixed.
Comment 17 errata-xmlrpc 2013-02-28 11:38:54 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0556.html

Note You need to log in before you can comment on or make changes to this bug.