Bug 858005 - Mouse jumps to edges / corners when using an absolute input device (ie virtual machine usb tablet)
Mouse jumps to edges / corners when using an absolute input device (ie virtua...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: xorg-x11-server (Show other bugs)
6.4
All Linux
unspecified Severity urgent
: rc
: ---
Assigned To: Adam Jackson
Desktop QE
AcceptedNTH
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-17 14:16 EDT by Marian Krcmarik
Modified: 2013-02-21 03:04 EST (History)
18 users (show)

See Also:
Fixed In Version: xorg-x11-server-1.13.3-3.el6
Doc Type: Bug Fix
Doc Text:
Cause: An uninitialised device transformation matrix caused a calculation to generate zero on certain movements on devices with absolute axes. The transformation matrix is used to bind a device to a specific area on the screen (or a specific screen). This bug only triggered if the device did not change the device transformation matrix and left it at its default value. Consequence: The generated zero value causes a reset of the pointer coordinates to 0/0, i.e. a jump to the top-left corner. Fix: The matrix is initialised to the identity matrix. Result: Pointer movement now works as expected.
Story Points: ---
Clone Of: 852841
Environment:
Last Closed: 2013-02-21 03:04:01 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Peter Hutterer 2012-09-20 09:22:41 EDT
MODIFIED

xorg-x11-server-1.13.3-3.el6
Comment 4 RHEL Product and Program Management 2012-09-20 09:50:54 EDT
This request was evaluated by Red Hat Product Management for
inclusion in a Red Hat Enterprise Linux release.  Product
Management has requested further review of this request by
Red Hat Engineering, for potential inclusion in a Red Hat
Enterprise Linux release for currently deployed products.
This request is not yet committed for inclusion in a release.
Comment 10 errata-xmlrpc 2013-02-21 03:04:01 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0299.html

Note You need to log in before you can comment on or make changes to this bug.