This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 852841 - Mouse jumps to edges / corners when using an absolute input device (ie virtual machine usb tablet)
Mouse jumps to edges / corners when using an absolute input device (ie virtua...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xorg-x11-server (Show other bugs)
rawhide
All Linux
unspecified Severity high
: ---
: ---
Assigned To: X/OpenGL Maintenance List
Fedora Extras Quality Assurance
AcceptedNTH https://fedoraproject.org...
: CommonBugs, Reopened
: 856242 856250 856252 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-29 14:05 EDT by bdetter3
Modified: 2012-10-16 10:35 EDT (History)
25 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 858005 (view as bug list)
Environment:
Last Closed: 2012-10-01 18:07:37 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg.0.log (58.69 KB, text/plain)
2012-09-12 07:05 EDT, Kamil Páral
no flags Details
Xorg.0.log from F17 in Virtualbox 4.1.22 (42.74 KB, text/x-log)
2012-09-14 10:52 EDT, Cybertimber2011
no flags Details
lsusb output from F17 on virtualbox 4.1.22 (181 bytes, text/plain)
2012-09-14 10:53 EDT, Cybertimber2011
no flags Details

  None (edit)
Description bdetter3 2012-08-29 14:05:45 EDT
Description of problem:
Mouse movements cause random 'snapto' to the upper left corner hot spot in Gnome3. This causes the Activities screen to display, interrupting any work in the focused window.

Version-Release number of selected component (if applicable):
xorg-x11-server-common-1.12.3-1.fc17 (64-bit)
xorg-x11-server-Xorg-1.12.3-1.fc17 (64-bit)
xorg-x11-server-Xephyr-1.12.3-1.fc17 (64-bit)

How reproducible:
Always

Steps to Reproduce:
1. Activate any window on the Gnome3 desktop
2. move mouse around
3. With in a minute the screen will display the Activities screen.
  
Actual results:
screen switches to the Activities screen

Expected results:
Current screen remains active

Additional info:
downgraded the xorg-x11-server files to the 1.12.0-2 version and problem was resolved.
Comment 1 Jeremy Petersen 2012-09-06 14:00:25 EDT
I experienced this same behavior, but within the KDE desktop environment. This was on 2 different 64bit virtualbox machines running on 2 different systems. This is on a fully patched Fedora 17 x64.

Downgrading the three xorg-x11-server packages listed above to the 1.12.0-2 versions corrected this behavior completely for me on both systems.
Comment 2 Adam Williamson 2012-09-11 15:56:10 EDT
*** Bug 856242 has been marked as a duplicate of this bug. ***
Comment 3 Adam Williamson 2012-09-11 15:58:01 EDT
Transferring Alpha blocker nomination from #856242. Several people confirmed seeing the bug there, and there are reports on test@ that it's affecting VirtualBox too.
Comment 4 Adam Williamson 2012-09-11 16:05:50 EDT
updating to xorg server 1.13.0 doesn't fix this in f18, fwiw.
Comment 5 bdetter3 2012-09-11 16:11:02 EDT
I submitted the original bug report and I neglected to identify my environment as VirtualBox. The problem first occured in VB 4.1.18, got significantly worse with VB 4.1.20 and remains the same in VB 4.1.22.
Comment 6 Hans de Goede 2012-09-12 06:02:16 EDT
I have a feeling the may be related to the special vmware mouse mode of ps/2 mouse emulation, can people who are seeing this in in virtual box please attach their /var/log/Xorg.0.log  ?
Comment 7 Hans de Goede 2012-09-12 06:40:47 EDT
Hi,

Me again, 2 more things:
1) Can you try doing: sudo rpm -e --nodeps xorg-x11-drv-vmmouse, and then restarting Xorg ?
2) Another possible culprit could be a usb-tablet, does the vm have a usb-tablet (see lsusb in the guest) ? 

Regards,

Hans
Comment 8 Kamil Páral 2012-09-12 07:05:18 EDT
Created attachment 612060 [details]
Xorg.0.log

ad 1) Didn't help even after reboot.

ad 2) Default VMs in virt-manager have EvTouch tablet assigned. If I remove it and reboot, the issue is still present.
Comment 9 Hans de Goede 2012-09-12 07:23:28 EDT
(In reply to comment #8)
> Created attachment 612060 [details]
> Xorg.0.log
> 
> ad 1) Didn't help even after reboot.
> 
> ad 2) Default VMs in virt-manager have EvTouch tablet assigned. If I remove
> it and reboot, the issue is still present.

Hi, copy pasting this to "bug 852842", which is the more generic tracking bug for this issue, this one is specifically for people seeing this under virtualbox (at least for now).

Also I've more questions, but I'll ask those in bug 852842 too.
Comment 10 Hans de Goede 2012-09-12 07:25:25 EDT
Correction the bug number in my last comment should be bug 856242
Comment 11 Alon Levy 2012-09-12 07:40:59 EDT
Hans,

 I saw this happen either with a uinput device (spice-vdagent) or with usb tablet emulation, but not with imps/2 emulation. I test by running

[spice@f18qxlkms ~]$ xinput test 9 | grep =0
motion a[0]=0 a[1]=0 
motion a[0]=0 a[1]=0 

Alon
Comment 12 Hans de Goede 2012-09-12 09:19:41 EDT
*** Bug 856242 has been marked as a duplicate of this bug. ***
Comment 13 Hans de Goede 2012-09-12 09:23:32 EDT
As discussed in bug 856242, this seems to happen with both virtualbox & qemu-vnc & qemu-spice, and with
both spice-vdagent and usb-tablets within qemu, so I'm pretty sure this really is an xorg bug, also as indicated by comment #0, donwgrading F-17 xorg to the non updates version fixes this, giving more clues that this seems to be an xorg issue.
Comment 14 Hans de Goede 2012-09-12 09:23:41 EDT
*** Bug 856250 has been marked as a duplicate of this bug. ***
Comment 15 Hans de Goede 2012-09-12 09:23:48 EDT
*** Bug 856252 has been marked as a duplicate of this bug. ***
Comment 16 David Jaša 2012-09-12 09:39:13 EDT
replying to the other bug here:

(In reply to comment #22)
> (In reply to comment #21)
> > Yes, it occurs with usb-tablet & disabled vdagent, too (in RHEL 6 VM).
> 
> How up2date is this RHEL-6 vm / which xorg-server version does it use ?

# rpm -q xorg-x11-server-Xorg
xorg-x11-server-Xorg-1.13.0-1.el6.x86_64
Comment 18 Hans de Goede 2012-09-12 09:43:06 EDT
(In reply to comment #16)
> replying to the other bug here:
> 
> (In reply to comment #22)
> > (In reply to comment #21)
> > > Yes, it occurs with usb-tablet & disabled vdagent, too (in RHEL 6 VM).
> > 
> > How up2date is this RHEL-6 vm / which xorg-server version does it use ?
> 
> # rpm -q xorg-x11-server-Xorg
> xorg-x11-server-Xorg-1.13.0-1.el6.x86_64

Ah yes, so that is newer then the F-17 xorg-x11-server-Xorg-1.12.0 -> 1.12.3 transition when this was first seen, given that it was first seen in an xorg bugfix release it should be easy to find the actual commit, as the bugfix releases have relatively few commits. But thanks for the info, that you're seeing it with that version is just 1 bit more proof that this is caused by xorg.
Comment 19 Adam Williamson 2012-09-12 14:20:42 EDT
Discussed at 2012-09-12 blocker review meeting. The clause under which this stands the most chance of being accepted is "Bug hinders execution of required Alpha test plans or dramatically reduces test coverage", but we agreed that Alpha involves so little desktop testing that it doesn't really count, so it's rejected as an Alpha blocker, accepted as NTH (since it's really freaking annoying). There was considerable support for Beta blocker status under the above clause, so re-proposing as Beta blocker too.
Comment 20 Cybertimber2011 2012-09-14 10:52:15 EDT
Created attachment 612911 [details]
Xorg.0.log from F17 in Virtualbox 4.1.22
Comment 21 Cybertimber2011 2012-09-14 10:53:18 EDT
Created attachment 612912 [details]
lsusb output from F17 on virtualbox 4.1.22
Comment 22 Cybertimber2011 2012-09-14 11:26:54 EDT
Hans, for me this started with a recent F17 system update on 2012-09-11. Looking at my yum log (grepped for xorg), here were my recent xorg updates if that helps:

Jul 03 13:59:52 Updated: xorg-x11-server-common-1.12.2-4.fc17.x86_64
Jul 03 13:59:58 Updated: xorg-x11-server-Xorg-1.12.2-4.fc17.x86_64
Jul 03 13:59:59 Updated: xorg-x11-server-Xephyr-1.12.2-4.fc17.x86_64
Aug 02 08:48:06 Updated: xorg-x11-drv-intel-2.20.1-1.fc17.x86_64
Sep 11 11:53:30 Updated: xorg-x11-server-common-1.12.3-1.fc17.x86_64
Sep 11 11:55:49 Updated: xorg-x11-server-Xorg-1.12.3-1.fc17.x86_64
Sep 11 11:56:44 Installed: abrt-addon-xorg-2.0.12-1.fc17.x86_64
Sep 11 11:57:08 Updated: xorg-x11-drv-intel-2.20.6-1.fc17.x86_64
Sep 11 11:57:47 Updated: xorg-x11-server-Xephyr-1.12.3-1.fc17.x86_64
Comment 23 Volker Sobek 2012-09-14 15:21:58 EDT
(In reply to comment #8)

> Default VMs in virt-manager have EvTouch tablet assigned. If I remove
> it and reboot, the issue is still present.

This workaround works for me, though. I shut down the VM (an up to date f18) and removed the tablet on the details page of the virtual machine in virt-manager. After booting the VM again the issue was gone.
Comment 24 Kamil Páral 2012-09-17 03:25:00 EDT
Please see bug 856242 comment 16:

> So the only way how to fix this issue is to remove spice-vdagent AND 
> remove the tablet. Any other combination breaks it.

At least that was my observation.
Comment 25 Jan Sedlák 2012-09-17 07:04:51 EDT
(In reply to comment #7)
> 2) Another possible culprit could be a usb-tablet, does the vm have a
> usb-tablet (see lsusb in the guest) ? 

I have tried it on my machine with up to date F18 and it solves the problem, at least for me.
Comment 26 Jeremy Petersen 2012-09-17 15:21:05 EDT
Sorry - I'm a bit confused. I am on a Win7 host, F17 guest. The F17 guest shows the "VirtualBox USB Tablet" in 'lsusb' output and I have spice-vdagent installed. Uninstalling the package is easy enough of course, but how do I remove the "USB Tablet" that is being seen?

I still have the downgraded xorg packages installed to keep everything working but would like to test this other solution as well.
Comment 27 Fabian Deutsch 2012-09-18 11:23:17 EDT
(In reply to comment #23)
> (In reply to comment #8)
> 
> > Default VMs in virt-manager have EvTouch tablet assigned. If I remove
> > it and reboot, the issue is still present.
> 
> This workaround works for me, though. I shut down the VM (an up to date f18)
> and removed the tablet on the details page of the virtual machine in
> virt-manager. After booting the VM again the issue was gone.

Removing the wacom tablet also didn't solve the issue for me.
Comment 28 Peter Hutterer 2012-09-18 11:25:52 EDT
I've been failing to reproduce this on the VM's I have here. Can you please record the QEMU's tablet event sequence with evemu-record and attach the output here? I need to figure out how this is triggered, maybe replaying the event sequence triggers the bug here too.

More info about how to use evemu is here:
http://people.freedesktop.org/~whot/evemu/
Comment 29 Peter Hutterer 2012-09-18 14:58:09 EDT
update: I've been able to reproduce this, but it's completely random and when it happens, the event sequence gives no hint on anything going wrong.
Any hints on how to reproduce this reliably appreciated.
Comment 30 Adam Williamson 2012-09-18 15:17:15 EDT
whot: for me it happens reliably simply booting an F18 Alpha live image on an F18 host, in a VM created with default configuration by virt-manager. It happens frequently and unavoidably. It plays hell with some Alpha testing, actually. I can attach my VM definition if it's any help.
Comment 31 Fabian Deutsch 2012-09-19 03:21:03 EDT
Yes, the same for me. But on an F16 host, VM is using qxl/spice w/ mouse+wacom and only mouse (wacom removed).

Too me it seems as if there are two mouse pointers in the game (in the VM). A hidden one with a changing offset and the visible one.
Comment 32 Peter Hutterer 2012-09-19 11:40:32 EDT
Found a possible culprit, scratch build is attached here, please let me know if that fixes it.

F17: http://koji.fedoraproject.org/koji/taskinfo?taskID=4503192
F18: http://koji.fedoraproject.org/koji/taskinfo?taskID=4503213
Comment 33 Federico Pedemonte 2012-09-19 12:21:00 EDT
Peter, that fixed the issue for me (running F18 Alpha into a VM hosted in a F17 gust)

thanks!
Comment 34 Kamil Páral 2012-09-19 12:26:54 EDT
Peter, looks good! I can no longer reproduce the bug after I updated to that xorg build.
Comment 35 Jeremy Petersen 2012-09-19 12:56:11 EDT
Peter - that did the trick for me too. I can no longer reproduce the issue on either of my (separate) F17 vbox guests running on Win7 hosts. Thank you!
Comment 36 Mamoru TASAKA 2012-09-19 21:37:14 EDT
(In reply to comment #32)
> Found a possible culprit, scratch build is attached here, please let me know
> if that fixes it.
> 
> F17: http://koji.fedoraproject.org/koji/taskinfo?taskID=4503192

Tested with F17 vbox guest and seems good, thank you.
Comment 37 Fedora Update System 2012-09-20 02:35:40 EDT
xorg-x11-server-1.13.0-5.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/xorg-x11-server-1.13.0-5.fc18
Comment 38 Fedora Update System 2012-09-20 04:05:40 EDT
xorg-x11-server-1.12.3-2.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/xorg-x11-server-1.12.3-2.fc17
Comment 39 Fedora Update System 2012-09-21 19:57:40 EDT
Package xorg-x11-server-1.12.3-2.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing xorg-x11-server-1.12.3-2.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-14449/xorg-x11-server-1.12.3-2.fc17
then log in and leave karma (feedback).
Comment 40 Fedora Update System 2012-09-22 23:25:14 EDT
xorg-x11-server-1.12.3-2.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 41 Fedora Update System 2012-09-23 00:56:45 EDT
xorg-x11-server-1.13.0-5.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 42 Andre Robatino 2012-09-30 14:42:34 EDT
Still broken in Rawhide, though (which has 1.12.99.904-2.20120808.fc19). Could someone do a Rawhide build? Thanks.
Comment 43 Peter Hutterer 2012-10-01 18:07:21 EDT
Rawhide build: http://koji.fedoraproject.org/koji/taskinfo?taskID=4549045

Note You need to log in before you can comment on or make changes to this bug.