Bug 858031 - Digest Mismatch in ImageMagick-6.7.5.6-4.fc17.armv5tel
Digest Mismatch in ImageMagick-6.7.5.6-4.fc17.armv5tel
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: rpm (Show other bugs)
17
arm Linux
unspecified Severity high
: ---
: ---
Assigned To: Fedora Packaging Toolset Team
Fedora Extras Quality Assurance
:
: 858812 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-17 16:08 EDT by Andrew Jones
Modified: 2012-09-25 11:31 EDT (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-24 17:49:44 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andrew Jones 2012-09-17 16:08:39 EDT
Description of problem: Cannot Install ImageMagick-6.7.5.6-4.fc17.armv5tel due to digest mismatch in rpm


Version-Release number of selected component (if applicable): 6.7.5.6-4.fc17.armv5tel


How reproducible: 100% on my hardware. (RaspberryPi) 



Steps to Reproduce:
1. su -c 'yum install ImageMagick'
2.
3.
  
Actual results:
Loaded plugins: langpacks, presto, refresh-packagekit
Resolving Dependencies
--> Running transaction check
---> Package ImageMagick.armv5tel 0:6.7.5.6-4.fc17 will be installed
--> Finished Dependency Resolution

Dependencies Resolved

========================================================================================================================
 Package                      Arch                      Version                          Repository                Size
========================================================================================================================
Installing:
 ImageMagick                  armv5tel                  6.7.5.6-4.fc17                   updates                  2.0 M

Transaction Summary
========================================================================================================================
Install  1 Package

Total download size: 2.0 M
Installed size: 7.2 M
Is this ok [y/N]: y
Downloading Packages:
ImageMagick-6.7.5.6-4.fc17.armv5tel.rpm                                                          | 2.0 MB     00:13     
Running Transaction Check
Running Transaction Test
Transaction Test Succeeded
Running Transaction
  Installing : ImageMagick-6.7.5.6-4.fc17.armv5tel                                                                  1/1 
Error unpacking rpm package ImageMagick-6.7.5.6-4.fc17.armv5tel
error: unpacking of archive failed on file /usr/lib/libMagickCore.so.5.0.0;50577ef5: cpio: Digest mismatch
  Verifying  : ImageMagick-6.7.5.6-4.fc17.armv5tel                                                                  1/1 

Failed:
  ImageMagick.armv5tel 0:6.7.5.6-4.fc17                                                                                 

Complete!


Expected results:
Successful installation

Additional info:
I wouldn't have thought this was very important but it is stopping me installing emacs and I am too old to learn vi...
Comment 1 Robert 'Bob' Jensen 2012-09-22 00:33:00 EDT
*** Bug 858812 has been marked as a duplicate of this bug. ***
Comment 2 Pavel Alexeev 2012-09-22 08:36:12 EDT
Hm, I don't known what to doing with that. Possible some rpm bug. Reassigning.
Comment 3 Peter Robinson 2012-09-24 17:49:44 EDT
I suspect we just have a corrupt build. I've reset the build in koji and I'm rebuilding it now
Comment 4 Andrew Jones 2012-09-25 11:31:22 EDT
Downloaded the new build from Koji and it appears to work.

Thanks!

-bash-4.2$ wget http://armpkgs.fedoraproject.org/packages/ImageMagick/6.7.5.6/4.fc17/armv5tel/ImageMagick-6.7.5.6-4.fc17.armv5tel.rpm
--2012-08-28 13:21:18--  http://armpkgs.fedoraproject.org/packages/ImageMagick/6.7.5.6/4.fc17/armv5tel/ImageMagick-6.7.5.6-4.fc17.armv5tel.rpm
Resolving armpkgs.fedoraproject.org... 142.204.133.156
Connecting to armpkgs.fedoraproject.org|142.204.133.156|:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 2118741 (2.0M) [application/x-rpm]
Saving to: `ImageMagick-6.7.5.6-4.fc17.armv5tel.rpm'

100%[=========================================================================>] 2,118,741   65.0K/s   in 62s     

2012-08-28 13:22:21 (33.4 KB/s) - `ImageMagick-6.7.5.6-4.fc17.armv5tel.rpm' saved [2118741/2118741]




-bash-4.2$ su -c 'yum localinstall ImageMagick-6.7.5.6-4.fc17.armv5tel.rpm'
Password: 
Loaded plugins: langpacks, presto, refresh-packagekit
Examining ImageMagick-6.7.5.6-4.fc17.armv5tel.rpm: ImageMagick-6.7.5.6-4.fc17.armv5tel
Marking ImageMagick-6.7.5.6-4.fc17.armv5tel.rpm to be installed
Resolving Dependencies
--> Running transaction check
---> Package ImageMagick.armv5tel 0:6.7.5.6-4.fc17 will be installed
--> Finished Dependency Resolution

Dependencies Resolved

========================================================================================================================================
 Package                   Arch                   Version                      Repository                                          Size
========================================================================================================================================
Installing:
 ImageMagick               armv5tel               6.7.5.6-4.fc17               /ImageMagick-6.7.5.6-4.fc17.armv5tel               7.2 M

Transaction Summary
========================================================================================================================================
Install  1 Package

Total size: 7.2 M
Installed size: 7.2 M
Is this ok [y/N]: y
Downloading Packages:
Running Transaction Check
Running Transaction Test
Transaction Test Succeeded
Running Transaction
  Installing : ImageMagick-6.7.5.6-4.fc17.armv5tel                                                                                  1/1 
  Verifying  : ImageMagick-6.7.5.6-4.fc17.armv5tel                                                                                  1/1 

Installed:
  ImageMagick.armv5tel 0:6.7.5.6-4.fc17                                                                                                 

Complete!

Note You need to log in before you can comment on or make changes to this bug.