Bug 858072 - Can't view root problems due to policykit issue in live-cd.
Can't view root problems due to policykit issue in live-cd.
Status: CLOSED DUPLICATE of bug 834494
Product: Fedora
Classification: Fedora
Component: abrt (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: abrt
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-17 18:42 EDT by Sergio
Modified: 2012-09-19 02:24 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-19 02:24:10 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Sergio 2012-09-17 18:42:31 EDT
Description of problem: on live-cd (rc3-alpha xfce spin) the polkit authentication box doesn't open when checking 'view all problems' and abrt-gui gets stuck there.

~/.xsession-errors gives:

** (polkit-gnome-authentication-agent-1:2334): CRITICAL **: polkit_agent_listener_initiate_authentication: assertion `identities != NULL' failed

Then after a while it timeouts:

Can't get problem list from abrt-dbus: Foi atingido o tempo limite de espera

Version-Release number of selected component (if applicable): 2.0.11-2.fc18


How reproducible: always


Steps to Reproduce:
1. open abrt-gui after a problem owned by root
2. check 'view all problems'
3.
  
Actual results: authentication box doesn't show up


Expected results: maybe no authentication box as it's a live-cd and then show the problem owned by root.

Additional info:
# yum list abrt*
Loaded plugins: langpacks, presto, refresh-packagekit
Installed Packages
abrt.i686                                 2.0.11-2.fc18                 @koji-override-0/$releasever
abrt-addon-ccpp.i686                      2.0.11-2.fc18                 @koji-override-0/$releasever
abrt-addon-kerneloops.i686                2.0.11-2.fc18                 @koji-override-0/$releasever
abrt-addon-python.i686                    2.0.11-2.fc18                 @koji-override-0/$releasever
abrt-addon-vmcore.i686                    2.0.11-2.fc18                 @koji-override-0/$releasever
abrt-addon-xorg.i686                      2.0.11-2.fc18                 @koji-override-0/$releasever
abrt-dbus.i686                            2.0.11-2.fc18                 @koji-override-0/$releasever
abrt-desktop.i686                         2.0.11-2.fc18                 @koji-override-0/$releasever
abrt-gui.i686                             2.0.11-2.fc18                 @koji-override-0/$releasever
abrt-libs.i686                            2.0.11-2.fc18                 @koji-override-0/$releasever
abrt-plugin-bodhi.i686                    2.0.11-2.fc18                 @koji-override-0/$releasever
abrt-retrace-client.i686                  2.0.11-2.fc18                 @koji-override-0/$releasever
abrt-tui.i686                             2.0.12-1.fc18                 @updates-testing            
Available Packages
abrt.i686                                 2.0.12-1.fc18                 updates-testing             
abrt-addon-ccpp.i686                      2.0.12-1.fc18                 updates-testing             
abrt-addon-kerneloops.i686                2.0.12-1.fc18                 updates-testing             
abrt-addon-python.i686                    2.0.12-1.fc18                 updates-testing             
abrt-addon-vmcore.i686                    2.0.12-1.fc18                 updates-testing             
abrt-addon-xorg.i686                      2.0.12-1.fc18                 updates-testing             
abrt-cli.i686                             2.0.12-1.fc18                 updates-testing             
abrt-dbus.i686                            2.0.12-1.fc18                 updates-testing             
abrt-desktop.i686                         2.0.12-1.fc18                 updates-testing             
abrt-devel.i686                           2.0.12-1.fc18                 updates-testing             
abrt-gui.i686                             2.0.12-1.fc18                 updates-testing             
abrt-libs.i686                            2.0.12-1.fc18                 updates-testing             
abrt-plugin-bodhi.i686                    2.0.12-1.fc18                 updates-testing             
abrt-retrace-client.i686                  2.0.12-1.fc18                 updates-testing
Comment 1 Jiri Moskovcak 2012-09-18 03:00:37 EDT
Does the policykit work for other actions like installing a package? If yes, then it's probably ABRT bug if it doesn't then I would say the bug is in the policyKit.
Comment 2 Sergio 2012-09-18 06:40:02 EDT
(In reply to comment #1)
> Does the policykit work for other actions like installing a package?

Actually it doesn't also work for yumex ( https://bugzilla.redhat.com/show_bug.cgi?id=857229 ).
I tried the workaround on that bug report (i.e., adding liveuser to the wheel group) but it still didn't work.
Comment 3 Sergio 2012-09-18 16:49:13 EDT
Sorry, I tested it more properly now by first setting

# usermod -G liveuser,wheel liveuser

and then forcing a bug (for root) and trying to view with abrt and it worked properly.
Comment 4 Jiri Moskovcak 2012-09-19 02:24:10 EDT
Thx for the info, marking this as a dupe of: rhbz#834494

*** This bug has been marked as a duplicate of bug 834494 ***

Note You need to log in before you can comment on or make changes to this bug.