Bug 858135 - vim-command-t should require ruby
vim-command-t should require ruby
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: vim-command-t (Show other bugs)
17
Unspecified Unspecified
unspecified Severity low
: ---
: ---
Assigned To: Vít Ondruch
Fedora Extras Quality Assurance
:
: 860034 950447 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-18 01:53 EDT by Jorge A Gallegos
Modified: 2013-04-20 16:12 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-04-19 00:47:52 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jorge A Gallegos 2012-09-18 01:53:49 EDT
Description of problem: Looking at https://bugzilla.redhat.com/show_bug.cgi?id=752785 it seems that vim-enhanced now ships without a ruby dependency, and vim-command-t doesn't have it either, which means that if you have vim and install vim-command-t *without* having ruby installed, opening VI will result in a nasty SEGFAULT, hardly ideal.


Version-Release number of selected component (if applicable):
vim-command-t-1.4-1.fc17

How reproducible:
Always

Steps to Reproduce:
1. on a fresh system (or otherwise remove ruby)
2. yum install vim-command-t
3. open vim
  
Actual results:
SEGFAULT

Expected results:
VIM editor window

Additional info:
Comment 1 Vít Ondruch 2012-09-18 03:39:15 EDT
Hi Jorge,

Well, you are right, but just partially. The truth is that vim segfaults when ruby package is not installed, but the problem is elsewhere IMO. If you have installed vim, you could see by issuing "vim --version" from command line or ":ruby 1" in vim, that Ruby support is still enabled, i.e. the [1] was not applied yet. However, if you run just the ":ruby 1" command earlier, vim segfaults, due to missing RubyGems package and it was reported here [2]. As you can see from [2], I was trying to fix it by requiring ruby package by ruby-libs, but that was wrong approach.

I may consider to apply workaround, i.e. to require ruby or rubygems package by vim-command-t, but I don't like the idea. If that is not blocker for you, I would like to wait a bit if it is a real pain for other users as well.


[1] https://bugzilla.redhat.com/show_bug.cgi?id=752785
[2) https://bugzilla.redhat.com/show_bug.cgi?id=848058
[3] https://bugzilla.redhat.com/show_bug.cgi?id=845011
Comment 2 Jorge A Gallegos 2012-09-18 23:17:29 EDT
Take your time to do it the right way. Not a show-stopper for me at all, but found it appropriate to file a bug to have it documented somewhere :)
Comment 3 Vít Ondruch 2012-09-19 03:22:55 EDT
Thank you. I already trying to push bug 752785 forward.
Comment 4 Vít Ondruch 2012-09-25 01:22:03 EDT
*** Bug 860034 has been marked as a duplicate of this bug. ***
Comment 5 Greg Ennis 2013-03-18 16:37:39 EDT
This was a problem for me.  I made a post on the Fedora list, and Ed Greshko figured out the solution and pointed me to this bug.   I would say this may be a problem that others will have if they try to install vim on the basis of "yum install vim*" like I did.   The new software installer of F18 is not as friendly as the older versions when you try to add a few of the special things that one desires.  I was not sure how to install vim, and could not figure out a way to install it from the gui software installer.
Comment 6 Vít Ondruch 2013-04-10 06:20:29 EDT
*** Bug 950447 has been marked as a duplicate of this bug. ***
Comment 7 Fedora Update System 2013-04-10 07:43:23 EDT
vim-command-t-1.4-4.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/vim-command-t-1.4-4.fc19
Comment 8 Fedora Update System 2013-04-10 07:44:16 EDT
vim-command-t-1.4-4.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/vim-command-t-1.4-4.fc18
Comment 9 Fedora Update System 2013-04-10 07:46:07 EDT
vim-command-t-1.4-4.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/vim-command-t-1.4-4.fc17
Comment 10 Vít Ondruch 2013-04-10 07:48:24 EDT
For now, there is no better way, then to add dependency on RubyGems into vim-command-t. So I did that. Hopefully, one day, RPM/YUM will be capable enough to fix this and it could be moved into better place, i.e. into VIM (bug #848058).
Comment 11 Fedora Update System 2013-04-10 11:15:33 EDT
Package vim-command-t-1.4-4.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing vim-command-t-1.4-4.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-5314/vim-command-t-1.4-4.fc19
then log in and leave karma (feedback).
Comment 12 Fedora Update System 2013-04-19 00:47:54 EDT
vim-command-t-1.4-4.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 13 Fedora Update System 2013-04-19 00:52:15 EDT
vim-command-t-1.4-4.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 14 Fedora Update System 2013-04-20 16:12:15 EDT
vim-command-t-1.4-4.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.