Bug 860034 - vim-command-t installs with error: scriptlet failure in rpm package
vim-command-t installs with error: scriptlet failure in rpm package
Status: CLOSED DUPLICATE of bug 858135
Product: Fedora
Classification: Fedora
Component: vim-command-t (Show other bugs)
17
x86_64 Linux
unspecified Severity low
: ---
: ---
Assigned To: Vít Ondruch
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-24 12:57 EDT by Todd Thomas
Modified: 2012-09-25 01:22 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-25 01:22:03 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Todd Thomas 2012-09-24 12:57:28 EDT
Description of problem:
When installing 'vim-command-t' via yum, the installation errors:
Non-fatal POSTIN scriptlet failure in rpm package vim-command-t-1.4-1.fc17.x86_64                                             


Version-Release number of selected component (if applicable):
0:1.4-1.fc17

How reproducible:
I've done this on 2 workstations so far; same error both times.


Steps to Reproduce:
1. Install from f17 Live CD on a VM; update && reboot
2. Upgrade VIM: $ sudo yum -y install vim-common vim-enhanced
3. Install Command-T: $ sudo yum -y install vim-command-t
  
Actual results:
Running Transaction Check
Running Transaction Test
Transaction Test Succeeded
Running Transaction
  Installing : vim-command-t-1.4-1.fc17.x86_64
Non-fatal POSTIN scriptlet failure in rpm package vim-command-t-1.4-1.fc17.x86_64
/var/tmp/rpm-tmp.Xitz0a: line 1: 17601 Segmentation fault      (core dumped) vim -c ":helptags /usr/share/vim/vimfiles/doc" -c :q &>/dev/null
warning: %post(vim-command-t-1.4-1.fc17.x86_64) scriptlet failed, exit status 139
  Verifying  : vim-command-t-1.4-1.fc17.x86_64

Installed:
  vim-command-t.x86_64 0:1.4-1.fc17                                                                                               

Complete!
---

Leaving the package installed causes vim to fail:
$ vim
Vim: Caught deadly signal SEGV
Vim: Finished.
Segmentation fault (core dumped)


Expected results:
vim-command-t installs correctly and without error.


Additional info:
I suspect this would happen on non x86_64 arch's as well but I have not tested that.

Also, asked someone in the fedora IRC channel to duplicate this for me. They received the erorr "after I get a segfault".


Work-around: 
Clone command-t from GitHub (vimball did not work for me on a new install)
https://github.com/wincent/Command-T
Follow directions to install.
Comment 1 Vít Ondruch 2012-09-25 01:22:03 EDT
The correct workaround should be to install ruby prior installation of vim-command-t. I am working toward solving this issue, but I am not there yet :/

*** This bug has been marked as a duplicate of bug 858135 ***

Note You need to log in before you can comment on or make changes to this bug.