Bug 858200 - [RHEV-H 6.3] The Content of grub.conf didn't keep the same after upgraded from 6.3 old to 6.3 latest via TUI and RHEVM .
[RHEV-H 6.3] The Content of grub.conf didn't keep the same after upgraded fro...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ovirt-node (Show other bugs)
6.3
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: Fabian Deutsch
Virtualization Bugs
: TestOnly
: 863982 (view as bug list)
Depends On: 863982
Blocks: 875929
  Show dependency treegraph
 
Reported: 2012-09-18 06:09 EDT by haiyang,dong
Modified: 2016-04-26 09:57 EDT (History)
12 users (show)

See Also:
Fixed In Version: ovirt-node-2.5.0-10.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-28 15:23:00 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description haiyang,dong 2012-09-18 06:09:58 EDT
Description of problem:
The Content of grub.conf didn't keep the same when upgraded from 6.3 old to 6.3 latest via TUI and RHEVM .

[root@localhost redhat]# diff grub.conf.viaTUI grub.conf.viaRHEVM
11a12
>     savedefault


Upgraded from rhev-hypervisor6-6.3-20120815.0.el6_3 to rhev-hypervisor6-6.3-20120913.0.el6_3 via TUI:
[root@localhost admin]# cat /dev/.initramfs/live/grub/grub.conf
default saved
timeout 5
hiddenmenu
title Red Hat Enterprise Virtualization Hypervisor (6.3-20120913.0.el6_3)
    root (hd0,1)
    kernel /vmlinuz0 root=live:LABEL=Root ro rootfstype=ext2 rootflags=ro ksdevice=bootif crashkernel=512M-2G:64M,2G-:128M lang= rd_NO_LUKS rd_NO_LVM kssendmac rd_NO_MD quiet elevator=deadline rhgb rd_NO_DM
    initrd /initrd0.img
title BACKUP RHEV Hypervisor 6.3-20120815.0.el6_3
    root (hd0,2)
    kernel /vmlinuz0 root=live:LABEL=RootBackup ro rootfstype=ext2 rootflags=ro ksdevice=bootif crashkernel=512M-2G:64M,2G-:128M lang= rd_NO_LUKS rd_NO_LVM kssendmac rd_NO_MD quiet elevator=deadline rhgb rd_NO_DM
    initrd /initrd0.img

Upgraded from rhev-hypervisor6-6.3-20120815.0.el6_3 to rhev-hypervisor6-6.3-20120913.0.el6_3 via RHEVM:
[root@localhost admin]# cat /dev/.initramfs/live/grub/grub.conf
default saved
timeout 5
hiddenmenu
title Red Hat Enterprise Virtualization Hypervisor (6.3-20120913.0.el6_3)
    root (hd0,1)
    kernel /vmlinuz0 root=live:LABEL=Root ro rootfstype=ext2 rootflags=ro ksdevice=bootif crashkernel=512M-2G:64M,2G-:128M lang= rd_NO_LUKS rd_NO_LVM kssendmac rd_NO_MD quiet elevator=deadline rhgb rd_NO_DM
    initrd /initrd0.img
title BACKUP RHEV Hypervisor 6.3-20120815.0.el6_3
    root (hd0,2)
    kernel /vmlinuz0 root=live:LABEL=RootBackup ro rootfstype=ext2 rootflags=ro ksdevice=bootif crashkernel=512M-2G:64M,2G-:128M lang= rd_NO_LUKS rd_NO_LVM kssendmac rd_NO_MD quiet elevator=deadline rhgb rd_NO_DM
    initrd /initrd0.img
    savedefault


Version-Release number of selected component (if applicable):
rhev-hypervisor6-6.3-20120913.0.el6_3

How reproducible:
100%

Steps to Reproduce:
1.Upgraded from rhev-hypervisor6-6.3-20120815.0.el6_3 to rhev-hypervisor6-6.3-20120913.0.el6_3 via TUI
2.Check the content of /dev/.initramfs/live/grub/grub.conf
3.Upgraded from rhev-hypervisor6-6.3-20120815.0.el6_3 to rhev-hypervisor6-6.3-20120913.0.el6_3 via RHEVM
4.Check the content of /dev/.initramfs/live/grub/grub.conf

Actual results:
The Content of grub.conf didn't keep the same after upgraded from 6.3 old to 6.3 latest via TUI and RHEVM

Expected results:
The Content of grub.conf should keep the same after upgraded from 6.3 old to 6.3 latest via TUI and RHEVM

Additional info:
The Content of grub.conf keep the same when upgraded from 6.3 old to 6.3 latest via cmdline and RHEVM .
Comment 10 Mike Burns 2012-11-15 09:05:06 EST
*** Bug 863982 has been marked as a duplicate of this bug. ***
Comment 12 haiyang,dong 2012-12-19 06:07:12 EST
Need to register rhev-h to RHEV-M to reproduce the bug, but there was a bug 
about "Bug 879148 - vdsm 6.4: Register rhev-h to RHEV-M failed" , so need to
wait for that bug was fixed to retest this one.
Comment 14 haiyang,dong 2013-01-29 07:41:45 EST
Test version:
rhev-hypervisor6-6.4-20130116.3.0.el6
ovirt-node-2.5.0-15.el6.noarch

upgraded rhev-h from rhev-hypervisor6-6.4-20130116.3.0.el6 to itself via TUI,cmdline and RHEVM .

check that the Content of all grub.conf keep the same, so this bug has been fixed,
change the status into "VERIFIED".
Comment 15 Mike Burns 2013-02-28 15:23:00 EST
This bug was shipped as part of the RHBA-2013:0556 Errata, but was accidentally omitted from the errata text.  

closing this as CurrentRelease

Note You need to log in before you can comment on or make changes to this bug.