Bug 863982 - The grub title does not update to latest and no backup version after upgrade via RHEVM
The grub title does not update to latest and no backup version after upgrade ...
Status: CLOSED DUPLICATE of bug 858200
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ovirt-node (Show other bugs)
6.3
Unspecified Unspecified
high Severity high
: rc
: ---
Assigned To: Joey Boggs
Virtualization Bugs
: ZStream
Depends On:
Blocks: 858200 875929
  Show dependency treegraph
 
Reported: 2012-10-08 04:59 EDT by haiyang,dong
Modified: 2013-01-08 23:17 EST (History)
11 users (show)

See Also:
Fixed In Version: ovirt-node-2.5.0-9.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-15 09:05:06 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
attached ovirt.log (8.38 KB, text/x-log)
2012-10-08 22:01 EDT, haiyang,dong
no flags Details

  None (edit)
Description haiyang,dong 2012-10-08 04:59:37 EDT
Description of problem:
The grub.conf missed the content of the backup version after upgraded from rhev-hypervisor6-6.3-20121005.0.rhev31.el6_3 to rhev-hypervisor6-6.3-20121005.0.rhev31.el6_3 via RHEVM.
 
Version-Release number of selected component (if applicable):
rhev-hypervisor6-6.3-20121005.0.rhev31.el6_3

How reproducible:
100%

Steps to Reproduce:
1. Install rhev-hypervisor6-6.3-20121005.0.rhev31.el6_3 and register to RHEV-M.
2. Upgrade RHEV-H to the latest version(rhev-hypervisor6-6.3-20121005.0.rhev31.el6_3) via rhevm.
3. After upgrade successful, wait for a while,RHEV-H can automatic reboot.

Actual results:
After step 3, there only the latest version can be selected to boot,missed the backup version.
After boot the latest version successfully
1.RHEVM shows that upgrade rhev-h successfully.
2.Press F2 drop to shell on the rhev-h side:
[root@localhost admin]# cat /dev/.initramfs/live/grub/grub.conf 

default saved
timeout 5
hiddenmenu
splashimage=(hd0,1)/grub/splash.xpm.gz
title RHEV Hypervisor 6.3-20121005.0.rhev31.el6_3
    root (hd0,1)
    kernel /vmlinuz0 root=live:LABEL=Root ro rootfstype=auto rootflags=ro ksdevice=bootif crashkernel=512M-2G:64M,2G-:128M lang= rd_NO_LUKS rd_NO_LVM kssendmac rd_NO_MD quiet elevator=deadline rhgb rd_NO_DM
    initrd /initrd0.img

[root@localhost admin]# ls -la /dev/disk/by-label/
total 0
drwxr-xr-x. 2 root root 200 2012-10-08 00:54 .
drwxr-xr-x. 6 root root 120 2012-10-08 00:53 ..
lrwxrwxrwx. 1 root root  10 2012-10-08 00:54 CONFIG -> ../../dm-7
lrwxrwxrwx. 1 root root  10 2012-10-08 00:54 DATA -> ../../dm-9
lrwxrwxrwx. 1 root root  10 2012-10-08 00:54 LOGGING -> ../../dm-8
lrwxrwxrwx. 1 root root   9 2012-10-08 00:53 rhevh-6.3-20120813.0 -> ../../sr0
lrwxrwxrwx. 1 root root  11 2012-10-08 00:53 _rhevh-6.3-20121 -> ../../loop1
lrwxrwxrwx. 1 root root  10 2012-10-08 00:54 Root -> ../../dm-2
lrwxrwxrwx. 1 root root  10 2012-10-08 00:54 RootBackup -> ../../dm-3
lrwxrwxrwx. 1 root root  10 2012-10-08 00:54 SWAP -> ../../dm-6

[root@localhost admin]# mount
...
/dev/mapper/1ATA_SAMSUNG_HD322HJ_S1GXJ90S204929p2 on /dev/.initramfs/live type unknown (ro)
...

[root@localhost admin]# mount /dev/mapper/1ATA_SAMSUNG_HD322HJ_S1GXJ90S204929p3  /mnt

[root@localhost admin]# ls /mnt/
efi/         grub/        initrd0.img  LiveOS/      lost+found/  version      vmlinuz0    

So that the backup version wasn't deleted after upgraded rhev-h via RHEVM, but couldn't boot the backup version.

Expected results:
After step 3, it should have two build version(the latest version and the backup version) that can be selected to boot

Additional info:
-----
Comment 4 haiyang,dong 2012-10-08 22:01:07 EDT
Created attachment 623840 [details]
attached ovirt.log
Comment 15 haiyang,dong 2012-10-18 08:57:55 EDT
hi jboggs,

After upgraded from rhev-hypervisor6-6.3-20121015.0.rhev31.el6_3 to rhev-hypervisor6-6.3-20121017.0.rhev31.el6_3 via RHEVM.
In addition to the grub.conf missed the content of the backup version, i notice another issue :
the latest version content saved the old version "title" in grub.conf .
Comment 25 Mike Burns 2012-11-15 09:05:06 EST

*** This bug has been marked as a duplicate of bug 858200 ***

Note You need to log in before you can comment on or make changes to this bug.