Bug 858320 - rhevm-manage-domains is broken (can't remove/add domain) due to NPE (@ ManageDomains.constructUPN(ManageDomains.java:94) )
rhevm-manage-domains is broken (can't remove/add domain) due to NPE (@ Manage...
Status: CLOSED DUPLICATE of bug 858769
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-config (Show other bugs)
3.1.0
Unspecified Unspecified
unspecified Severity urgent
: ---
: ---
Assigned To: Yair Zaslavsky
Pavel Stehlik
infra
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-18 11:58 EDT by Pavel Stehlik
Modified: 2016-02-10 14:15 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-25 05:02:25 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Infra
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pavel Stehlik 2012-09-18 11:58:09 EDT
Description of problem:
 I bring my setup to state when have IPA there & I can't remove/add same/another domain. Looks like there's no AdUser in the DB (the field is empty). DomainName is filled ipa-domain.rhev.lab.eng.brq.redhat.com


[root@ps-ad2-set ~]# rhevm-manage-domains -action=validate
Exception in thread "main" java.lang.NullPointerException
        at org.ovirt.engine.core.utils.kerberos.ManageDomains.constructUPN(ManageDomains.java:94)
        at org.ovirt.engine.core.utils.kerberos.ManageDomains.checkKerberosConfiguration(ManageDomains.java:617)
        at org.ovirt.engine.core.utils.kerberos.ManageDomains.testConfiguration(ManageDomains.java:772)
        at org.ovirt.engine.core.utils.kerberos.ManageDomains.validate(ManageDomains.java:352)
        at org.ovirt.engine.core.utils.kerberos.ManageDomains.runCommand(ManageDomains.java:251)
        at org.ovirt.engine.core.utils.kerberos.ManageDomains.main(ManageDomains.java:166)


[root@ps-ad2-set ~]# rhevm-manage-domains -action=delete -user=vdcadmin -interactive -domain=ipa-domain.rhev.lab.eng.brq.redhat.com -addPermissions -provider=IPA
WARNING: Domain ipa-domain.rhev.lab.eng.brq.redhat.com is the last domain in the configuration. After deleting it you will have to either add another domain, or to use the internal admin user in order to login.
Error with output, no default message to show. sorry..


manage-log-domains:
==============================
2012-09-18 14:13:10,089 INFO  [org.ovirt.engine.core.utils.kerberos.ManageDomainsDAOImpl] Setting value for AdUserName to
2012-09-18 14:13:10,881 INFO  [org.ovirt.engine.core.utils.kerberos.ManageDomainsDAOImpl] Setting value for AdUserPassword to
2012-09-18 14:13:11,974 ERROR [org.ovirt.engine.core.utils.kerberos.ManageDomains] Error with output, no default message to show. sorry..


Version-Release number of selected component (if applicable):
si18

How reproducible:
rarely 

Steps to Reproduce:
1. see above
2.
3.
  
Actual results:
Can't remove IPA domain

Expected results:


Additional info:
Comment 7 Yair Zaslavsky 2012-09-25 05:02:25 EDT

*** This bug has been marked as a duplicate of bug 858769 ***

Note You need to log in before you can comment on or make changes to this bug.