Bug 858769 - manage-domains: once the domain is added admin@internal can't search in that domain
manage-domains: once the domain is added admin@internal can't search in that ...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-config (Show other bugs)
3.1.0
Unspecified Unspecified
urgent Severity urgent
: ---
: ---
Assigned To: Yair Zaslavsky
Pavel Stehlik
infra
: Regression
: 858320 859361 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-19 12:08 EDT by Pavel Stehlik
Modified: 2016-02-10 14:05 EST (History)
9 users (show)

See Also:
Fixed In Version: si19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-04 14:57:44 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Infra
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
engine.log (56.06 KB, application/octet-stream)
2012-09-19 12:08 EDT, Pavel Stehlik
no flags Details

  None (edit)
Description Pavel Stehlik 2012-09-19 12:08:17 EDT
Created attachment 614457 [details]
engine.log

Description of problem:
 Once domain is added, engine restarted, user used admin@internal, then search doesn't return anything from new domain. 
engine.log:
(see att)
2012-09-19 17:22:55,829 ERROR [org.ovirt.engine.core.bll.adbroker.GSSAPIDirContextAuthenticationStrategy] (ajp-/127.0.0.1:8009-2) Error from Kerberos: java.lang.NullPointerException
        at org.ovirt.engine.core.bll.adbroker.GSSAPICallbackHandler.handle(GSSAPICallbackHandler.java:47)
        at javax.security.auth.login.LoginContext$SecureCallbackHandler$1.run(LoginContext.java:969)
        at javax.security.auth.login.LoginContext$SecureCallbackHandler$1.run(LoginContext.java:966)
        at java.security.AccessController.doPrivileged(Native Method)


Version-Release number of selected component (if applicable):
si18.1

How reproducible:
100% (observed on RHDS & AD)

Steps to Reproduce:
1. use rhevm-manage-domains without -addPermissions, (restart engine)
2. log to webadmin by admin@internal
3. try perform search
  
Actual results:
Once the user from new domain is added ( -addPermissions) & log into webadmin instead admin@internal, the search result is correct.

Expected results:


Additional info:
whole engine-manage-domains.log:
===================================
2012-09-19 17:22:01,768 INFO  [org.ovirt.engine.core.utils.kerberos.ManageDomains] Creating kerberos configuration for domain(s): ad2.rhev.lab.eng.brq.redhat.com
2012-09-19 17:22:01,917 INFO  [org.ovirt.engine.core.utils.kerberos.ManageDomains] Successfully created kerberos configuration for domain(s): ad2.rhev.lab.eng.brq.redhat.com
2012-09-19 17:22:01,917 INFO  [org.ovirt.engine.core.utils.kerberos.ManageDomains] Testing kerberos configuration for domain: ad2.rhev.lab.eng.brq.redhat.com
2012-09-19 17:22:02,437 INFO  [org.ovirt.engine.core.utils.kerberos.ManageDomains] Successfully tested kerberos configuration for domain: ad2.rhev.lab.eng.brq.redhat.com
2012-09-19 17:22:02,440 INFO  [org.ovirt.engine.core.utils.kerberos.ManageDomains] Applying kerberos configuration
2012-09-19 17:22:02,441 INFO  [org.ovirt.engine.core.utils.kerberos.ManageDomainsDAOImpl] Setting value for AdUserName to ad2.rhev.lab.eng.brq.redhat.com:vdcadmin2@AD2.RHEV.LAB.ENG.BRQ.REDHAT.COM
2012-09-19 17:22:03,325 INFO  [org.ovirt.engine.core.utils.kerberos.ManageDomainsDAOImpl] Setting value for AdUserPassword to ad2.rhev.lab.eng.brq.redhat.com:********
2012-09-19 17:22:03,956 INFO  [org.ovirt.engine.core.utils.kerberos.ManageDomainsDAOImpl] Setting value for LdapServers to
2012-09-19 17:22:04,769 INFO  [org.ovirt.engine.core.utils.kerberos.ManageDomainsDAOImpl] Setting value for AdUserId to ad2.rhev.lab.eng.brq.redhat.com:681df905-967b-45f7-a106-a9ab82699ca2
2012-09-19 17:22:05,480 INFO  [org.ovirt.engine.core.utils.kerberos.ManageDomainsDAOImpl] Setting value for LDAPSecurityAuthentication to ad2.rhev.lab.eng.brq.redhat.com:GSSAPI
2012-09-19 17:22:06,481 INFO  [org.ovirt.engine.core.utils.kerberos.ManageDomainsDAOImpl] Setting value for DomainName to ad2.rhev.lab.eng.brq.redhat.com
2012-09-19 17:22:07,446 INFO  [org.ovirt.engine.core.utils.kerberos.ManageDomainsDAOImpl] Setting value for LDAPProviderTypes to ad2.rhev.lab.eng.brq.redhat.com:activeDirectory
Comment 1 Yair Zaslavsky 2012-09-23 05:48:48 EDT
*** Bug 859361 has been marked as a duplicate of this bug. ***
Comment 2 Yair Zaslavsky 2012-09-24 20:31:10 EDT
http://gerrit.ovirt.org/#/c/8157/
Comment 4 Yair Zaslavsky 2012-09-25 05:02:25 EDT
*** Bug 858320 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.