Bug 858587 - The working directory for Konsole is $HOME/Documents/ and not $HOME on Fedora 18 Alpha TC5 (up to date)
The working directory for Konsole is $HOME/Documents/ and not $HOME on Fedora...
Status: CLOSED DUPLICATE of bug 841471
Product: Fedora
Classification: Fedora
Component: konsole (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-19 03:49 EDT by xset1980
Modified: 2012-09-19 11:18 EDT (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-19 11:18:26 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
path error (924.56 KB, image/png)
2012-09-19 07:20 EDT, xset1980
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
KDE Software Compilation 108510 None None None 2012-09-19 08:38:55 EDT
KDE Software Compilation 183534 None None None 2012-09-19 08:21:20 EDT
KDE Software Compilation 302903 None None None 2012-09-19 08:39:22 EDT

  None (edit)
Description xset1980 2012-09-19 03:49:52 EDT
Description of problem:

When konsole, xterm, etc is open, the default "pwd" is /home/user/Documents/ and not the tradicional /home/user/ path

Version-Release number of selected component (if applicable):

Fedora 18 Alpha KDE TC5 up to date

How reproducible:
always

Steps to Reproduce:
1.Open a terminal emulator
2.type pwd
3./home/user/Documents
  
Actual results:


Expected results:


Additional info:

Deleting all users (less root) and creating a new user, the problem persist
Comment 1 Roman Rakus 2012-09-19 04:07:21 EDT
Isn't that terminal just changing your working directory to ~/Documents? Or isn't there something in any of bashrc files?
Please, provide me an output of:
echo $HOME
Comment 2 xset1980 2012-09-19 07:19:42 EDT
 (In reply to comment #1)
> Isn't that terminal just changing your working directory to ~/Documents? Or
> isn't there something in any of bashrc files?
> Please, provide me an output of:
> echo $HOME

@Roman Rakus

No idea, if is a bug of bash or xterm, konsole, etc. I just report the error that i can see.
On a fresh install (now) using LiveCD KDE F18 Alpha, the same error again.

1.- alt+f2, xterm, intro = /home/user/Documents prompt
2.- echo $HOME = /home/nix
3.- pwd = /home/nix/Documents

Attach screenshot with identical steps
Comment 3 xset1980 2012-09-19 07:20:28 EDT
Created attachment 614306 [details]
path error
Comment 4 xset1980 2012-09-19 07:33:51 EDT
Modifing the "initial directory" on konsole, is solved, but, only on konsole, xterm no, so, is a system-wide variable that affect to all terminal emulators
Comment 5 Roman Rakus 2012-09-19 07:48:36 EDT
Reassigning to Konsole
Comment 6 Radek Novacek 2012-09-19 07:53:48 EDT
This is not a bug, it's expected behavior. You can change default directory for konsole, xterm and others by setting "Document Path" in System Settings -> Account Details -> Paths.
Comment 7 xset1980 2012-09-19 08:07:35 EDT
@Radek Novacek

Aha, changing the path of Documents, xterm and others are like the clasic terminal. But, the KDE settings are not relationed with this, of yes?. I have a box with F17 and the paths are configured by default, /home/user/documents, but when i open a terminal, the default directory is /home/user, no /home/user/documents
Comment 8 Radek Novacek 2012-09-19 08:28:47 EDT
Sorry, I misunderstand the bug report, the problem is that working directory is set to ~/Documents instead of ~ when running program (konsole, xterm, ...) from krunner, right?
Comment 9 Rex Dieter 2012-09-19 09:07:26 EDT
correct
Comment 10 Kevin Kofler 2012-09-19 11:18:26 EDT
So, as I said on IRC:
* The fact that the default working directory on application startup is ~/Documents is a feature, not a bug, see (non-)bug #571837.
* You also cannot expect the KDE Plasma Workspaces to automatically figure out that xterm is a terminal emulator. We are not going to hardcode a list of terminal emulators.
* What should, however be done, is for Konsole and xterm to specify ~ as the startup working directory, either in their .desktop file or elsewhere. For some reason, Konsole appears to start up in ~ on F16 and F17, but I cannot find where this is set, so I don't know what changed in F18 Alpha.

There's already a bug filed for the Konsole behavior change, I reopened it.

*** This bug has been marked as a duplicate of bug 841471 ***

Note You need to log in before you can comment on or make changes to this bug.