Bug 841471 - Konsole (or Terminal) start in /Documents folder
Summary: Konsole (or Terminal) start in /Documents folder
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: konsole
Version: rawhide
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Rex Dieter
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords: Patch, Reopened
: 858587 (view as bug list)
Depends On:
Blocks: 861504
TreeView+ depends on / blocked
 
Reported: 2012-07-19 05:56 UTC by dominique
Modified: 2012-11-30 11:44 UTC (History)
12 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2012-11-30 11:44:18 UTC


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
KDE Software Compilation 302903 None None None 2012-09-19 15:22:17 UTC

Description dominique 2012-07-19 05:56:53 UTC
Description of problem:

I test F18 rawhide, and when I launch Konsole (or Terminal) they start in my Documents folder (with F17, they start in my home/my user folder).

How reproducible:
Steps to Reproduce:
1.Launch Konsole or Terminal
  
Actual results:
Start in my /Documents folder


Expected results:
Start in my /home/my user folder

Comment 1 Rex Dieter 2012-07-19 13:57:10 UTC
It's currently a kde feature that all apps start in XDG_DOCUMENTS_DIR (defaults to $HOME/Documents)

Comment 2 dominique 2012-07-19 19:06:13 UTC
OK...
I launch  terminal (or konsole) with gnome, and they start in my /home/my_user/ folder...

Comment 3 Rex Dieter 2012-07-19 19:11:37 UTC
sorry, to be clear, it's any app started from a kde desktop

Comment 4 Kevin Kofler 2012-07-19 22:26:06 UTC

*** This bug has been marked as a duplicate of bug 571837 ***

Comment 5 dominique 2012-07-21 17:34:25 UTC
(In reply to comment #1)
> It's currently a kde feature that all apps start in XDG_DOCUMENTS_DIR
> (defaults to $HOME/Documents)

You say it's a kde feature, but I have not that with F17 and Kde 4.8.4-1.

Is it a feature for F18 rawhide and Kde 4.8.9 ?

Comment 6 Kevin Kofler 2012-09-19 15:16:26 UTC
It looks like at least for Konsole, the behavior changed in F18, it started up in ~ rather than ~/Documents up to F17.

Comment 7 Kevin Kofler 2012-09-19 15:18:26 UTC
*** Bug 858587 has been marked as a duplicate of this bug. ***

Comment 8 xset1980 2012-09-21 03:25:48 UTC
I can confirm it. F18 KDE Alpha LiveCD, konsole start on ~/Documents

Comment 9 Lukáš Tinkl 2012-09-24 07:51:52 UTC
For reference, here's a fix: http://commits.kde.org/konsole/a910778820408f293085073712b98a090dd3b28a

Comment 10 Massimiliano 2012-09-24 16:51:27 UTC
Now I have the same behaviour (konsole starts in ~/Documents folder) in my F17:

$ rpm -q konsole
konsole-4.9.1-1.fc17.x86_64

Comment 11 Jeremy Petersen 2012-09-24 17:39:21 UTC
As of the latest updates I am now seeing this behavior in F17 as well. Konsole defaults to $HOME/Documents/ directory rather than just $HOME/. This is not preferred behavior.

Comment 12 Fedora Update System 2012-09-24 18:30:10 UTC
konsole-4.9.1-2.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/konsole-4.9.1-2.fc17

Comment 13 Fedora Update System 2012-09-25 04:24:48 UTC
Package konsole-4.9.1-2.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing konsole-4.9.1-2.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-14700/konsole-4.9.1-2.fc17
then log in and leave karma (feedback).

Comment 14 xset1980 2012-09-25 13:31:16 UTC
Tested the F18 package and fixed:


rpm -qa |grep -i konsole
konsole-4.9.1-2.fc18.i686
konsole-part-4.9.1-2.fc18.i686


start on ~/ and not ~/Documents

Comment 15 dominique 2012-09-25 15:35:37 UTC
Test with kde 4.9 on F17, and  konsole-4.9.1-2.fc17 solve the problem.

I also test with F18, and konsole-4.9.1-2.fc18 solve the problem.

Thank

Comment 16 Fedora Update System 2012-09-26 09:02:48 UTC
konsole-4.9.1-2.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 17 Fedora Update System 2012-09-26 11:45:39 UTC
konsole-4.9.1-2.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/konsole-4.9.1-2.fc18

Comment 18 Rex Dieter 2012-09-28 19:36:56 UTC
Oh boo, someone on irc using konsole not in kde reported today that it no longer works for them:

Failed to launch Konsole ... Failed to change $HOME and there is no such directory

I'll test myself here in a bit, but it would appear that
Path[$e]=$HOME
doesn't work outside of kde, I think the [$e] extension is kde-only that allows for expansion of env vars

Comment 19 Rex Dieter 2012-10-02 00:00:19 UTC
Considering the regression (comment #18), reopenning.  I'll contact konsole upstream for their take on that.

In the meantime, I think I'm ready to propose we consider reverting the upstream commits that start applications in xdg documents dir by default (and go back to using $HOME instead)

Comment 20 Kevin Kofler 2012-10-02 00:13:38 UTC
And I'm starting to agree with you and Than on that, considering that starting apps in ~/Documents is supposed to be a compatibility feature for non-KDE apps, but no other desktop does that.

Comment 21 Fedora Update System 2012-10-04 18:14:09 UTC
kdelibs-4.9.2-5.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/kdelibs-4.9.2-5.fc17

Comment 22 Fedora Update System 2012-10-05 00:53:52 UTC
Package kdelibs-4.9.2-5.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing kdelibs-4.9.2-5.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-15396/kdelibs-4.9.2-5.fc17
then log in and leave karma (feedback).

Comment 23 Fedora Update System 2012-10-06 11:48:37 UTC
kdelibs-4.9.2-5.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/kdelibs-4.9.2-5.fc18

Comment 24 xset1980 2012-11-30 04:39:31 UTC
Fixed Fedora 18 beta rc1. close please.


Note You need to log in before you can comment on or make changes to this bug.