Bug 858717 - SELinux is preventing /usr/sbin/usbmuxd from 'open' accesses on the file usbmuxd.pid.
SELinux is preventing /usr/sbin/usbmuxd from 'open' accesses on the file usbm...
Status: CLOSED DUPLICATE of bug 858720
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
18
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:2c5e41d84183d1c7085e0fbcaf7...
:
: 858715 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-19 09:47 EDT by Stef Walter
Modified: 2012-09-20 06:22 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-19 20:55:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: type (9 bytes, text/plain)
2012-09-19 09:47 EDT, Stef Walter
no flags Details
File: hashmarkername (14 bytes, text/plain)
2012-09-19 09:47 EDT, Stef Walter
no flags Details

  None (edit)
Description Stef Walter 2012-09-19 09:47:34 EDT
Additional info:
libreport version: 2.0.13
kernel:         3.3.4-5.fc17.x86_64

description:
:SELinux is preventing /usr/sbin/usbmuxd from 'open' accesses on the file usbmuxd.pid.
:
:*****  Plugin catchall (100. confidence) suggests  ***************************
:
:If you believe that usbmuxd should be allowed open access on the usbmuxd.pid file by default.
:Then you should report this as a bug.
:You can generate a local policy module to allow this access.
:Do
:allow this access for now by executing:
:# grep usbmuxd /var/log/audit/audit.log | audit2allow -M mypol
:# semodule -i mypol.pp
:
:Additional Information:
:Source Context                system_u:system_r:usbmuxd_t:s0-s0:c0.c1023
:Target Context                system_u:object_r:init_var_run_t:s0
:Target Objects                usbmuxd.pid [ file ]
:Source                        usbmuxd
:Source Path                   /usr/sbin/usbmuxd
:Port                          <Unknown>
:Host                          (removed)
:Source RPM Packages           usbmuxd-1.0.8-4.fc18.x86_64
:Target RPM Packages           
:Policy RPM                    selinux-policy-3.11.1-21.fc18.noarch
:Selinux Enabled               True
:Policy Type                   targeted
:Enforcing Mode                Permissive
:Host Name                     (removed)
:Platform                      Linux (removed) 3.3.4-5.fc17.x86_64 #1 SMP Mon May
:                              7 17:29:34 UTC 2012 x86_64 x86_64
:Alert Count                   1
:First Seen                    2012-09-18 21:46:24 CEST
:Last Seen                     2012-09-18 21:46:24 CEST
:Local ID                      063024dd-f40b-43bb-98eb-e11d51ce36a2
:
:Raw Audit Messages
:type=AVC msg=audit(1347997584.150:1531): avc:  denied  { open } for  pid=24660 comm="usbmuxd" name="usbmuxd.pid" dev="tmpfs" ino=8825187 scontext=system_u:system_r:usbmuxd_t:s0-s0:c0.c1023 tcontext=system_u:object_r:init_var_run_t:s0 tclass=file
:
:
:type=SYSCALL msg=audit(1347997584.150:1531): arch=x86_64 syscall=open success=yes exit=ESRCH a0=4086aa a1=41 a2=1a4 a3=7fff022e7f70 items=0 ppid=24655 pid=24660 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm=usbmuxd exe=/usr/sbin/usbmuxd subj=system_u:system_r:usbmuxd_t:s0-s0:c0.c1023 key=(null)
:
:Hash: usbmuxd,usbmuxd_t,init_var_run_t,file,open
:
:audit2allowunable to open /sys/fs/selinux/policy:  Permission denied
:
:
:audit2allow -Runable to open /sys/fs/selinux/policy:  Permission denied
:
:
Comment 1 Stef Walter 2012-09-19 09:47:36 EDT
Created attachment 614391 [details]
File: type
Comment 2 Stef Walter 2012-09-19 09:47:38 EDT
Created attachment 614392 [details]
File: hashmarkername
Comment 3 Daniel Walsh 2012-09-19 20:55:21 EDT
This looks like some kind of upgrade issue, you are running with an F17 kernel and an F18 selinux-policy?

This looks like the init system created the pid file with the wrong label.

usbmuxd.pid should be labeled 

matchpathcon  /run/usbmuxd.pid
/run/usbmuxd.pid	system_u:object_r:usbmuxd_var_run_t:s0


Do you know how this pid file got created?
Comment 4 Daniel Walsh 2012-09-19 20:55:44 EDT

*** This bug has been marked as a duplicate of bug 858720 ***
Comment 5 Stef Walter 2012-09-20 05:12:31 EDT
(In reply to comment #3)
> This looks like some kind of upgrade issue, you are running with an F17
> kernel and an F18 selinux-policy?

You're right. Looks like an old rawhide kernel. grub2-mkconfig wasn't working correctly. Sorry for the noise.
Comment 6 Miroslav Grepl 2012-09-20 06:22:56 EDT
*** Bug 858715 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.