Bug 858720 - SELinux is preventing /usr/bin/totem-video-thumbnailer from 'rename' accesses on the file registry.x86_64.bin.tmp7GW2KW.
SELinux is preventing /usr/bin/totem-video-thumbnailer from 'rename' accesses...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
18
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:ae7848e1143708de5bca9b7e347...
:
: 858716 858717 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-19 09:49 EDT by Stef Walter
Modified: 2012-12-20 10:32 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-20 10:32:55 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: type (9 bytes, text/plain)
2012-09-19 09:49 EDT, Stef Walter
no flags Details
File: hashmarkername (14 bytes, text/plain)
2012-09-19 09:49 EDT, Stef Walter
no flags Details

  None (edit)
Description Stef Walter 2012-09-19 09:49:20 EDT
Additional info:
libreport version: 2.0.13
kernel:         3.3.4-5.fc17.x86_64

description:
:SELinux is preventing /usr/bin/totem-video-thumbnailer from 'rename' accesses on the file registry.x86_64.bin.tmp7GW2KW.
:
:*****  Plugin catchall (100. confidence) suggests  ***************************
:
:If you believe that totem-video-thumbnailer should be allowed rename access on the registry.x86_64.bin.tmp7GW2KW file by default.
:Then you should report this as a bug.
:You can generate a local policy module to allow this access.
:Do
:allow this access for now by executing:
:# grep totem-video-thu /var/log/audit/audit.log | audit2allow -M mypol
:# semodule -i mypol.pp
:
:Additional Information:
:Source Context                unconfined_u:unconfined_r:thumb_t:s0-s0:c0.c1023
:Target Context                unconfined_u:object_r:cache_home_t:s0
:Target Objects                registry.x86_64.bin.tmp7GW2KW [ file ]
:Source                        totem-video-thu
:Source Path                   /usr/bin/totem-video-thumbnailer
:Port                          <Unknown>
:Host                          (removed)
:Source RPM Packages           totem-3.5.90-2.fc18.x86_64
:Target RPM Packages           
:Policy RPM                    selinux-policy-3.11.1-18.fc18.noarch
:Selinux Enabled               True
:Policy Type                   targeted
:Enforcing Mode                Permissive
:Host Name                     (removed)
:Platform                      Linux (removed) 3.3.4-5.fc17.x86_64 #1 SMP Mon May
:                              7 17:29:34 UTC 2012 x86_64 x86_64
:Alert Count                   1
:First Seen                    2012-09-17 15:04:31 CEST
:Last Seen                     2012-09-17 15:04:31 CEST
:Local ID                      a1066223-28cb-4dac-b53a-cf9b0a021940
:
:Raw Audit Messages
:type=AVC msg=audit(1347887071.785:567): avc:  denied  { rename } for  pid=27354 comm="totem-video-thu" name="registry.x86_64.bin.tmp7GW2KW" dev="sdd1" ino=1982467 scontext=unconfined_u:unconfined_r:thumb_t:s0-s0:c0.c1023 tcontext=unconfined_u:object_r:cache_home_t:s0 tclass=file
:
:
:type=AVC msg=audit(1347887071.785:567): avc:  denied  { unlink } for  pid=27354 comm="totem-video-thu" name="registry.x86_64.bin" dev="sdd1" ino=1982654 scontext=unconfined_u:unconfined_r:thumb_t:s0-s0:c0.c1023 tcontext=unconfined_u:object_r:cache_home_t:s0 tclass=file
:
:
:type=SYSCALL msg=audit(1347887071.785:567): arch=x86_64 syscall=rename success=yes exit=0 a0=132eb40 a1=1205870 a2=12ca640 a3=33 items=0 ppid=2785 pid=27354 auid=1000 uid=1000 gid=1000 euid=1000 suid=1000 fsuid=1000 egid=1000 sgid=1000 fsgid=1000 tty=(none) ses=2 comm=totem-video-thu exe=/usr/bin/totem-video-thumbnailer subj=unconfined_u:unconfined_r:thumb_t:s0-s0:c0.c1023 key=(null)
:
:Hash: totem-video-thu,thumb_t,cache_home_t,file,rename
:
:audit2allowunable to open /sys/fs/selinux/policy:  Permission denied
:
:
:audit2allow -Runable to open /sys/fs/selinux/policy:  Permission denied
:
:
Comment 1 Stef Walter 2012-09-19 09:49:24 EDT
Created attachment 614394 [details]
File: type
Comment 2 Stef Walter 2012-09-19 09:49:27 EDT
Created attachment 614395 [details]
File: hashmarkername
Comment 3 Daniel Walsh 2012-09-19 20:52:44 EDT
There is a labeling problem in ~/.cache/thumbnails

For now just execute

chcon -Rt thumb_home_t ~/.cache/thumbnails

Fixed in selinux-policy-3.11.1-23.fc18.noarch
Comment 4 Daniel Walsh 2012-09-19 20:55:44 EDT
*** Bug 858717 has been marked as a duplicate of this bug. ***
Comment 5 Daniel Walsh 2012-09-19 20:56:14 EDT
*** Bug 858716 has been marked as a duplicate of this bug. ***
Comment 6 Fedora Update System 2012-09-26 00:51:31 EDT
selinux-policy-3.11.1-25.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/selinux-policy-3.11.1-25.fc18
Comment 7 Fedora Update System 2012-09-26 17:18:51 EDT
Package selinux-policy-3.11.1-25.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing selinux-policy-3.11.1-25.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-14807/selinux-policy-3.11.1-25.fc18
then log in and leave karma (feedback).
Comment 8 Elad Alfassa 2012-10-08 09:44:56 EDT
I just saw this issue with selinux-policy-3.11.1-32.fc18.noarch

Does this mean I need to relabel my home directory, or that there's a bug?



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 9 Miroslav Grepl 2012-10-09 04:15:48 EDT
Are you getting exactly the same AVC msg?
Comment 10 Elad Alfassa 2012-10-09 06:54:10 EDT
Yes.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 11 Daniel Walsh 2012-10-09 13:31:32 EDT
ls -lZd ~/cache/thumbnails
Comment 12 Daniel Walsh 2012-10-09 13:34:38 EDT
One problem we have is that we are not running restorecon -R -v /home, on an update since it could take too long.
Comment 13 Elad Alfassa 2012-10-09 15:30:46 EDT
[elad@alfmobile ~]$ ls -lZd ~/.cache/thumbnails
drwx------. elad elad unconfined_u:object_r:cache_home_t:s0 /home/elad/.cache/thumbnails




-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 14 Miroslav Grepl 2012-10-10 04:46:00 EDT
So if you now execute

# restorecon -R -v ~/.cache/thumbnails

does it work then?
Comment 15 Fedora Update System 2012-12-20 10:32:57 EST
selinux-policy-3.11.1-25.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.