Bug 858877 - [RFE] Allow selection of all listem items when applying packages to a system group
[RFE] Allow selection of all listem items when applying packages to a system ...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 6
Classification: Red Hat
Component: WebUI (Show other bugs)
6.0.1
Unspecified Unspecified
unspecified Severity medium (vote)
: Unspecified
: --
Assigned To: Jakub Hadvig
sthirugn@redhat.com
: FutureFeature, Reopened, Triaged
Depends On: 1151618
Blocks: 1130651
  Show dependency treegraph
 
Reported: 2012-09-19 17:39 EDT by Og Maciel
Modified: 2017-02-23 16:20 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-08-12 09:57:42 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot (59.43 KB, image/png)
2012-09-19 17:39 EDT, Og Maciel
no flags Details

  None (edit)
Description Og Maciel 2012-09-19 17:39:59 EDT
Created attachment 614597 [details]
Screenshot

Description of problem:

The attached screenshot shows that you cannot select all the available errata items (I believe the same applies for packages) to be applied to a system group. We should have the equivalent of a "(de)select all" option.

Version-Release number of selected component (if applicable):
* candlepin-0.7.8-1.el6cf.noarch
* candlepin-selinux-0.7.8-1.el6cf.noarch
* candlepin-tomcat6-0.7.8-1.el6cf.noarch
* katello-1.1.12-7.el6cf.noarch
* katello-all-1.1.12-7.el6cf.noarch
* katello-candlepin-cert-key-pair-1.0-1.noarch
* katello-certs-tools-1.1.8-1.el6cf.noarch
* katello-cli-1.1.8-4.el6cf.noarch
* katello-cli-common-1.1.8-4.el6cf.noarch
* katello-common-1.1.12-7.el6cf.noarch
* katello-configure-1.1.9-3.el6cf.noarch
* katello-glue-candlepin-1.1.12-7.el6cf.noarch
* katello-glue-pulp-1.1.12-7.el6cf.noarch
* katello-qpid-broker-key-pair-1.0-1.noarch
* katello-qpid-client-key-pair-1.0-1.noarch
* katello-selinux-1.1.1-1.el6cf.noarch
* pulp-1.1.12-1.el6cf.noarch
* pulp-common-1.1.12-1.el6cf.noarch
* pulp-selinux-server-1.1.12-1.el6cf.noarch


How reproducible:


Steps to Reproduce:
1. Select a system group that is properly subscribed and has access to errata items.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 3 Mike McCune 2013-08-16 13:54:38 EDT
getting rid of 6.0.0 version since that doesn't exist
Comment 4 Mike McCune 2013-09-19 14:14:36 EDT
These bugs have been resolved in upstream projects for a period of months so I'm mass-closing them as CLOSED:UPSTREAM.  If this is a mistake feel free to re-open.
Comment 5 Mike McCune 2013-09-19 22:29:52 EDT
This bug was mistakenly closed during a triage process.  Moving back to MODIFIED or ON_QA depending
Comment 6 Walden Raines 2014-09-24 15:15:36 EDT
This is no longer valid as we now have a "select all" checkbox for errata.
Comment 9 sthirugn@redhat.com 2015-03-03 16:28:02 EST
Verified. "select all" checkbox is now available.

Version Tested:
Satellite-6.1.0-RHEL-6-20150224.0
Comment 10 Bryan Kearney 2015-08-11 09:22:22 EDT
This bug is slated to be released with Satellite 6.1.
Comment 11 Bryan Kearney 2015-08-12 09:57:42 EDT
This bug was fixed in version 6.1.1 of Satellite which was released on 12 August, 2015.

Note You need to log in before you can comment on or make changes to this bug.