Bug 859034 - aeolus-configure -p vsphere have no validation check for values provided in config file and shows success when it is complete
aeolus-configure -p vsphere have no validation check for values provided in c...
Status: CLOSED DUPLICATE of bug 801508
Product: CloudForms Cloud Engine
Classification: Red Hat
Component: aeolus-configure (Show other bugs)
1.1.0
x86_64 Linux
unspecified Severity medium
: rc
: ---
Assigned To: Mike Orazi
Rehana
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-20 08:28 EDT by pushpesh sharma
Modified: 2014-08-04 18:30 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-20 11:06:09 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description pushpesh sharma 2012-09-20 08:28:32 EDT
It seems to be a side-effect or a related bug to :-

https://bugzilla.redhat.com/show_bug.cgi?id=799488

Coping from above bug.  

It seems all the validation from vsphere is removed for the fix.I intentionally left all the paramater values(default dummy values) unchanged in both vsphere and rhevm configure files.

[root@dhcp201-113 ~]# tail -8 /etc/aeolus-configure/nodes/vsphere_configure 
      default:
        # Uncomment and provide values to match your vSphere environment.
        # Values below are examples.
          deltacloud_provider: vsphere.server.com
          username: username
          password: password
          datastore: datastore
          network_name: network_name
[root@dhcp201-113 ~]# tail -8 /etc/aeolus-configure/nodes/rhevm_configure
          nfs_server: nfs.server.com
          nfs_export: /export/export_domain
          nfs_mount_point: /mnt/rhevm-nfs
          deltacloud_username: username@fqdn
          deltacloud_password: password
          deltacloud_api: https://rhevm.server.com:8443/api
          deltacloud_data_center: data center id
          push_timeout: 1800

And here is the output:-

[root@dhcp201-113 ~]# aeolus-configure -p vsphere
Launching aeolus configuration recipe...
notice: /File[/etc/ldap_fluff.yml]/content: content changed '{md5}b27213de9f26cf3a5e689c1ab7d2c2b6' to '{md5}109fb977032121710c47df851d8f0e72'
notice: /File[/etc/ldap_fluff.yml]/group: group changed 'root' to 'aeolus'
notice: /File[/etc/ldap_fluff.yml]/mode: mode changed '644' to '640'
notice: /File[/usr/share/aeolus-conductor/config/initializers/secret_token.rb]/ensure: defined content as '{md5}dd58e9d517a374c07b27f76f69880bce'
notice: /File[/usr/share/aeolus-conductor/config/settings.yml]/content: content changed '{md5}e554310b717ab9218f4d136cdc7994f4' to '{md5}e9e9f46bfcd6c8646c9da4652a6c4625'
notice: /Stage[main]/Aeolus::Image-factory/Augeas[imagefactory.conf]/returns: executed successfully
notice: /Stage[main]/Postgres::Server/Service[postgresql]/ensure: ensure changed 'stopped' to 'running'
notice: /Stage[main]/Aeolus  

.............
notice: /Stage[main]/Aeolus::Profiles::Common/Aeolus::Conductor::Destroy_temp_admins[after]/Exec[destroy_temp_admin-after]/returns: executed successfully
notice: Finished catalog run in 61.27 seconds


[root@dhcp201-113 ~]# aeolus-configure -p rhevm
Launching aeolus configuration recipe...
Couldn't resolve host name at /usr/share/aeolus-configure/modules/aeolus/manifests/rhevm/validate.pp:2 on node dhcp201-113.englab.pnq.redhat.com



So rhevm-configure behaved correctly with invalid parameter values where fo vsphere-configure it is unable to provide any information regarding invalid parametrs instead it succeed with configuring.
Comment 2 Dave Johnson 2012-09-20 11:06:09 EDT

*** This bug has been marked as a duplicate of bug 801508 ***

Note You need to log in before you can comment on or make changes to this bug.