Bug 859036 - [RFE]Console option "Pass ctrl-alt-del to VM" seems to do nothing with RHEL client.
[RFE]Console option "Pass ctrl-alt-del to VM" seems to do nothing with RHEL c...
Status: CLOSED DUPLICATE of bug 1029441
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: RFEs (Show other bugs)
3.4.0
Unspecified Unspecified
unspecified Severity unspecified
: ---
: 3.4.0
Assigned To: Frantisek Kobzik
Shai Revivo
virt
: FutureFeature
: 879321 (view as bug list)
Depends On: 996564 996570 1029441 1042782
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-20 08:31 EDT by Paul Vine
Modified: 2015-09-22 09 EDT (History)
16 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-06 09:02:19 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
sherold: Triaged+


Attachments (Terms of Use)

  None (edit)
Description Paul Vine 2012-09-20 08:31:52 EDT
Description of problem: The same behaviour is observed whether this option is checked or not.

Version-Release number of selected component (if applicable):
RHEVM 3.1.0-14-el6ev
Virt-viewer 0.5.2-9.el6

How reproducible:

Steps to Reproduce:
1.Uncheck pass CAD to VM
2.Connect to VM and try CAD with and without guest in focus.
  
Actual results:
Regardless of how the option is set if VM is in focus CAD is passed to it and out of focus it is sent to the client.

Expected results:
According to the doc I would expect if the option is checked any CAD would be sent to the guest and if not checked none would be sent to the guest.

Additional info:
Doc - Pass Ctrl-Alt-Del to virtual machine: Tick this checkbox for this keystroke to be intercepted on the virtual guest. In Red Hat Enterprise Linux, this key combination sends a signal to reboot the computer. In Windows, this key combination displays the task manager or Windows Security dialog.
Comment 1 Paul Vine 2012-09-20 08:33:09 EDT
Guest was W7x64.
Comment 2 Christophe Fergeau 2012-09-20 09:05:28 EDT
The component has been set to spice-client-win, but the report mentions Virt-viewer 0.5.2-9.el6. Moreover, I don't expect the ctrl+alt+del option to work with a windows client, so I assume the component is wrong?
Probably a duplicate of https://bugzilla.redhat.com/show_bug.cgi?id=807771
Comment 3 Itamar Heim 2012-09-20 10:22:35 EDT
(In reply to comment #2)
> The component has been set to spice-client-win, but the report mentions
> Virt-viewer 0.5.2-9.el6. Moreover, I don't expect the ctrl+alt+del option to
> work with a windows client, so I assume the component is wrong?

actually, this feature was developed specificaly for windows clients (windows xp in workgroup mode mostly)

> Probably a duplicate of https://bugzilla.redhat.com/show_bug.cgi?id=807771

well, if it is not implemented, of course it isn't working?
Comment 4 Christophe Fergeau 2012-09-20 10:38:58 EDT
(In reply to comment #3)
> (In reply to comment #2)
> > The component has been set to spice-client-win, but the report mentions
> > Virt-viewer 0.5.2-9.el6. Moreover, I don't expect the ctrl+alt+del option to
> > work with a windows client, so I assume the component is wrong?
> 
> actually, this feature was developed specificaly for windows clients
> (windows xp in workgroup mode mostly)

As far as I know, Windows does not allow applications to intercept the ctrl+alt+del key combination, so this is not possible to implement, for example see http://en.wikipedia.org/wiki/Control-Alt-Delete#Windows_NT_.28and_later_versions.29 :
"[...] a user process is not able to intercept the Control-Alt-Delete sequence."

Fwiw, I'd be interested in a description of what problem and use cases we are trying to solve with this key combination, and about the expected behaviour when "pass ctrl+alt+del" is set/unset (not "the ctrl+alt+del combination is passed through" but "the user wants to do XXX, he can do that by checking the box, and he can achieve YYY by unchecking it")
Comment 5 Itamar Heim 2012-09-20 10:43:06 EDT
this worked, it isn't theortical.
on windows xp, in workgroup mode (not part of AD), hitting ctrl-alt-del opened task manager in client.
when this was enabled, the spice client would:
- kill the task manager process so it wouldn't open (used to be another flag, consolidated to the CAD flag)
- detect the CAD and send it to the guest (so yes, windows got it first, but client could still detect it was pressed)

this may not be relevant with windows 7
Comment 6 Christophe Fergeau 2012-09-20 10:59:29 EDT
Ah very interesting, thanks a lot! I couldn't find anyone to explain what we were trying to achieve with this ctrl+alt+del feature last time I worked on it, which made it harder to work on...
This "detect ctrl+alt+del/close window" hack is not implemented either in the client.
Comment 7 Uri Lublin 2012-09-20 12:20:43 EDT
(In reply to comment #5)
What is the use case for not sending CAD to the guest, when users press CAD while the client window is in-focus ?
Comment 8 David Blechter 2012-09-20 13:58:04 EDT
1. This bug was submitted to the user-portal. It is the only justification it is in the RHEVM product. The bug was found on RHEL client machine!!! for clarification: the win-spice-client is for the old spice client (spicec), and we should use mingw-virt-viewer instead;

2. The correct location should be in the rhel spice-gtk - it is rhel client

3. In the virt-viewer implementation we have an option to send CAD to the guest regardless of the OS on client/guest. 

4. On the rhel client the behavior is exactly as it is expected on rhel machine (from in Description "...if VM is in focus CAD is passed to it and out of focus it is sent to the client")

5. On the Win machine CAD brings the Task Manager of the client as it is expected. And for sending the CAD to the VM use option (see 2).

6. And based on the above we can illuminate the option in the user-portal starting from 3.1. 

Are there any missing use-cases?
Comment 11 Marc-Andre Lureau 2012-11-22 10:46:49 EST
*** Bug 879321 has been marked as a duplicate of this bug. ***
Comment 12 Marc-Andre Lureau 2013-04-29 10:58:33 EDT
Since this requires considerable development time and is not a regression apparently, should one treat it as RFE?

My understanding is that this is a Windows-only feature. According to http://stackoverflow.com/a/11658230/1277510, it will require admin right to install a privilege filter or application/agent to tweak the registry dynamically.

(this looks like a limited windows kiosk-mode feature request to me)
Comment 13 Paul Vine 2013-04-29 11:44:00 EDT
Moving to RHEL and removing futurefeature as document clearly states intended behavior or the doc is incorrect.
Comment 24 RHEL Product and Program Management 2013-10-14 00:46:36 EDT
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 26 David Blechter 2013-11-08 09:50:15 EST
moved it to RFE. This bug contains dependencies, and I suggest using it as the tracker to address the c-a-d issues.
Comment 27 Michal Skrivanek 2013-11-13 08:06:38 EST
our current proposal is to remove CAD and replace it with optional mapping to Ctrl-Alt-End, regardless the client platform you'd be using CAE as a "send CAD to the guest"
Comment 28 Frantisek Kobzik 2013-11-14 10:10:01 EST
adding rfe for implementing control-alt-end support in the engine.
Comment 29 Frantisek Kobzik 2014-01-06 09:02:19 EST
fixing 1029441 fixes this bug too.

*** This bug has been marked as a duplicate of bug 1029441 ***

Note You need to log in before you can comment on or make changes to this bug.