Bug 85914 - After login, alt-tab freezes screen unless mouse is moved first
After login, alt-tab freezes screen unless mouse is moved first
Status: CLOSED UPSTREAM
Product: Red Hat Linux
Classification: Retired
Component: metacity (Show other bugs)
9
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Havoc Pennington
: MoveUpstream, Triaged
: 85915 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-03-10 14:05 EST by Mark Knutsen
Modified: 2007-04-18 12:51 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-05-25 14:54:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Mark Knutsen 2003-03-10 14:05:25 EST
Description of problem:
With a phoebe3 Everything install:

I have my gnome session set to display two terminals at login. I can
immediately begin typing on one of them, but if I try to alt-tab to
the other, the screen appears to freeze. Clicking the mouse once
(anywhere) clears the problem, but this shouldn't be necessary.

Version-Release number of selected component (if applicable):
2.2.0.1-3

How reproducible:
Every time

Steps to Reproduce:
1. Log in, start two gnome-terminals
2. Log out, check "save current setup"
3. Log in again. Note that one terminal has focus (you can type),
   although its titlebar isn't highlighted. Do not touch the mouse.
4. Hit alt-tab and release
    
Actual results:
Screen appears frozen with outline of background window drawn over
foreground window. Tiny "alt-tab window" with two terminal icons is
also displayed. Subsequent keystrokes don't appear to work. Mouse
does work, but may disappear if moved outside tiny "alt-tab window".

Clicking mouse clears the problem. Subsequent alt-tab actions
function as expected.

Expected results:
Alt-tab should function properly before the mouse is ever clicked
or moved.

Additional info:
The problem doesn't happen if the mouse is so much as moved away from
the center of the screen before alt-tab is first used. It only seems
to happen when the mouse is not touched. The little window that pops
up when you alt-tab seems to "capture" the mouse and interrupt the
process.
Comment 1 Mark Knutsen 2003-03-10 14:48:24 EST
*** Bug 85915 has been marked as a duplicate of this bug. ***
Comment 2 Mark Knutsen 2003-04-12 19:33:48 EDT
Problem still exists in Red Hat 9. Also, can be reproduced with only one gnome-
terminal rather than two.
Comment 3 Havoc Pennington 2003-08-05 18:33:21 EDT
metacity must get confused if you begin an alt+tab and metacity doesn't 
know about the focused window, or something like that.
Comment 4 Havoc Pennington 2004-05-25 14:54:58 EDT
Upstream as http://bugzilla.gnome.org/show_bug.cgi?id=143147
Comment 5 Elijah Newren 2005-01-06 23:38:46 EST
From the description, I'm pretty sure this was bug
http://bugzilla.gnome.org/show_bug.cgi?id=147475, which has been
fixed.  I cannot duplicate.  Can someone else please verify?
Comment 6 Mark Knutsen 2005-02-25 10:10:17 EST
This is not the same as
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=85914, which had
to do with the workspace switcher, not the task switcher, but it's
fixed anyway as of RHEL4. Thanks!
Comment 7 Mark Knutsen 2005-02-25 10:11:23 EST
Oops, meant http://bugzilla.gnome.org/show_bug.cgi?id=147475
Comment 8 Elijah Newren 2005-02-25 11:54:03 EST
Mark: Gnome #147475 was reported as a problem involving the workspace
switcher, but the bug was found to be a much more general problem with
not having a focus window.  That's why I believe this is the same bug
as that one, despite the very different descriptions of how to reproduce.

Anyway, glad to hear that it's working for you.  :)

Note You need to log in before you can comment on or make changes to this bug.