Bug 85915 - After login, alt-tab freezes screen unless mouse is moved first
After login, alt-tab freezes screen unless mouse is moved first
Status: CLOSED DUPLICATE of bug 85914
Product: Red Hat Linux
Classification: Retired
Component: gnome-desktop (Show other bugs)
9
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Mark McLoughlin
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-03-10 14:46 EST by Mark Knutsen
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:52:09 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mark Knutsen 2003-03-10 14:46:33 EST
Description of problem:
With a phoebe3 Everything install:

I have my gnome session set to display two terminals at login. I can
immediately begin typing on one of them, but if I try to alt-tab to
the other, the screen appears to freeze. Clicking the mouse once
(anywhere) clears the problem, but this shouldn't be necessary.

Version-Release number of selected component (if applicable):
2.2.0.1-3

How reproducible:
Every time

Steps to Reproduce:
1. Log in, start two gnome-terminals
2. Log out, check "save current setup"
3. Log in again. Note that one terminal has focus (you can type),
   although its titlebar isn't highlighted. Do not touch the mouse.
4. Hit alt-tab and release
    
Actual results:
Screen appears frozen with outline of background window drawn over
foreground window. Tiny "alt-tab window" with two terminal icons is
also displayed. Subsequent keystrokes don't appear to work. Mouse
does work, but may disappear if moved outside tiny "alt-tab window".

Clicking mouse clears the problem. Subsequent alt-tab actions
function as expected.

Expected results:
Alt-tab should function properly before the mouse is ever clicked
or moved.

Additional info:
The problem doesn't happen if the mouse is so much as moved away from
the center of the screen before alt-tab is first used. It only seems
to happen when the mouse is not touched. The little window that pops
up when you alt-tab seems to "capture" the mouse and interrupt the
process.
Comment 1 Mark Knutsen 2003-03-10 14:48:22 EST

*** This bug has been marked as a duplicate of 85914 ***
Comment 2 Red Hat Bugzilla 2006-02-21 13:52:09 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.