This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 859148 - [abrt] libreoffice-core-3.5.6.2-2.fc17: memcpy: Process /usr/lib64/libreoffice/program/soffice.bin was killed by signal 11 (SIGSEGV)
[abrt] libreoffice-core-3.5.6.2-2.fc17: memcpy: Process /usr/lib64/libreoffic...
Status: CLOSED DUPLICATE of bug 831628
Product: Fedora
Classification: Fedora
Component: libreoffice (Show other bugs)
17
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Caolan McNamara
Fedora Extras Quality Assurance
abrt_hash:717263220bd59520589b26dc423...
:
: 991554 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-20 12:28 EDT by Ignace BIENVILLE
Modified: 2013-08-03 07:17 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-21 03:02:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
File: core_backtrace (657 bytes, text/plain)
2012-09-20 12:28 EDT, Ignace BIENVILLE
no flags Details
File: environ (1.92 KB, text/plain)
2012-09-20 12:28 EDT, Ignace BIENVILLE
no flags Details
File: limits (1.29 KB, text/plain)
2012-09-20 12:28 EDT, Ignace BIENVILLE
no flags Details
File: backtrace (62.43 KB, text/plain)
2012-09-20 12:28 EDT, Ignace BIENVILLE
no flags Details
File: cgroup (129 bytes, text/plain)
2012-09-20 12:28 EDT, Ignace BIENVILLE
no flags Details
File: maps (107.84 KB, text/plain)
2012-09-20 12:28 EDT, Ignace BIENVILLE
no flags Details
File: dso_list (24.45 KB, text/plain)
2012-09-20 12:28 EDT, Ignace BIENVILLE
no flags Details
File: var_log_messages (353 bytes, text/plain)
2012-09-20 12:28 EDT, Ignace BIENVILLE
no flags Details
File: open_fds (270 bytes, text/plain)
2012-09-20 12:28 EDT, Ignace BIENVILLE
no flags Details

  None (edit)
Description Ignace BIENVILLE 2012-09-20 12:28:19 EDT
Description of problem:
apres un end session, il devais etre ouvert avec un fichier

Version-Release number of selected component:
libreoffice-core-3.5.6.2-2.fc17

Additional info:
libreport version: 2.0.13
abrt_version:   2.0.12
backtrace_rating: 4
cmdline:        /usr/lib64/libreoffice/program/soffice.bin --writer file:///home/ignace/Dropbox/Projet%20Formation/Projet%203%20-%20C%23%20-%20Mailing%20SMS/Cahier%20des%20charges/Cahier%20des%20Charges.docx --splash-pipe=6
crash_function: memcpy
kernel:         3.5.3-1.fc17.x86_64

truncated backtrace:
:Thread no. 1 (3 frames)
: #0 memcpy at ../sysdeps/x86_64/memcpy.S
: #1 ICEConnectionWorker at /usr/src/debug/libreoffice-3.5.6.2/vcl/unx/generic/app/sm.cxx
: #2 osl_thread_start_Impl at thread.c
Comment 1 Ignace BIENVILLE 2012-09-20 12:28:24 EDT
Created attachment 614973 [details]
File: core_backtrace
Comment 2 Ignace BIENVILLE 2012-09-20 12:28:27 EDT
Created attachment 614974 [details]
File: environ
Comment 3 Ignace BIENVILLE 2012-09-20 12:28:31 EDT
Created attachment 614975 [details]
File: limits
Comment 4 Ignace BIENVILLE 2012-09-20 12:28:34 EDT
Created attachment 614976 [details]
File: backtrace
Comment 5 Ignace BIENVILLE 2012-09-20 12:28:36 EDT
Created attachment 614977 [details]
File: cgroup
Comment 6 Ignace BIENVILLE 2012-09-20 12:28:41 EDT
Created attachment 614978 [details]
File: maps
Comment 7 Ignace BIENVILLE 2012-09-20 12:28:43 EDT
Created attachment 614979 [details]
File: dso_list
Comment 8 Ignace BIENVILLE 2012-09-20 12:28:46 EDT
Created attachment 614980 [details]
File: var_log_messages
Comment 9 Ignace BIENVILLE 2012-09-20 12:28:48 EDT
Created attachment 614981 [details]
File: open_fds
Comment 10 Michael Stahl 2012-09-20 13:49:26 EDT
> Thread 1 (Thread 0x7f5bcc99f700 (LWP 3661)):
> #0  __memcpy_sse2 () at ../sysdeps/x86_64/memcpy.S:125
> No locals.
> #1  0x00007f5bcf7a76b3 in ICEConnectionWorker () at /usr/src/debug/libreoffice-3.5.6.2/vcl/unx/generic/app/sm.cxx:662
>        nConnectionsBefore = 1
>        bWakeup = <optimized out>
>        nBytes = 16
>        pLocalFD = 0x0
>        nRet = <optimized out>

ICEConnectionWorker:
>>            pLocalFD = (struct pollfd*)rtl_allocateMemory( nBytes );
>>            memcpy( pLocalFD, pThis->m_pFilehandles, nBytes );


so rtl_allocateMemory returned 0 because rtl allocator is being shut down concurrently in thread 2:

> Thread 2 (Thread 0x7f5bbbc8a700 (LWP 3662)):
> #7  0x0000003825a3b0bd in rtl_memory_fini () at /usr/src/debug/libreoffice-3.5.6.2/sal/rtl/source/alloc_global.cxx:254
No locals.
> #8  0x0000003820e38f5a in __cxa_finalize (d=0x3825c5a2a0) at cxa_finalize.c:56


hmm... why does thread 2 run global destructors of sal library when other threads are still running?
Comment 11 Stephan Bergmann 2012-09-21 03:02:56 EDT

*** This bug has been marked as a duplicate of bug 831628 ***
Comment 12 Caolan McNamara 2013-08-03 07:17:26 EDT
*** Bug 991554 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.