This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 859224 - Please take systemd-logind's handle-power-key/handle-suspend-key/handle-hibernate-key/handle-lid-switch inhibitor locks if GNOME wants to handle the respective keys on its own
Please take systemd-logind's handle-power-key/handle-suspend-key/handle-hiber...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: gnome-settings-daemon (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Bastien Nocera
Fedora Extras Quality Assurance
RejectedBlocker
:
: 865362 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-20 16:22 EDT by Lennart Poettering
Modified: 2013-01-18 10:50 EST (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-20 10:56:24 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Lennart Poettering 2012-09-20 16:22:28 EDT
With systemd-190 we have changed the lid switch logic, as discussed here:

https://bugzilla.gnome.org/show_bug.cgi?id=680689
http://www.freedesktop.org/wiki/Software/systemd/inhibit
http://lists.freedesktop.org/archives/systemd-devel/2012-September/006604.html

If GNOME wants to handle the power key/reset key/lid switch on its own it should take the "handle-power-key", "handle-reset-key", "handle-lid-switch" inhibitor locks while running. It can do this either natively in C by accessing logind's D-Bus API (see above), or simply by wrapping the invocation of gnome-session in an invocation of systemd-inhibit.

Example:

systemd-inhibit --what=handle-power-key:handle-reset-key:handle-lid-switch gnome-session

Thanks!
Comment 1 Lennart Poettering 2012-09-20 16:26:49 EDT
I am a bit confused apparently. Replace "reset key" with "sleep key" everywhere in what I wrote above. Sorry for the confusion.
Comment 2 Lennart Poettering 2012-09-25 19:00:52 EDT
Let's make this even more confusing. The "sleep key" logic got split up into "suspend key" and "hibernate key"
Comment 3 Matthias Clasen 2012-09-26 19:02:24 EDT
We'll put a patch for this into gnome-settings-daemon,
Comment 4 Matthias Clasen 2012-09-26 20:42:57 EDT
Not doing this leads to pretty bad double-suspend behaviour, so putting this on the F18Beta
Comment 5 Fedora Update System 2012-10-02 13:33:01 EDT
gnome-settings-daemon-3.6.0-3.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/gnome-settings-daemon-3.6.0-3.fc18
Comment 6 Fedora Update System 2012-10-02 15:49:01 EDT
Package gnome-settings-daemon-3.6.0-3.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing gnome-settings-daemon-3.6.0-3.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-15224/gnome-settings-daemon-3.6.0-3.fc18
then log in and leave karma (feedback).
Comment 7 Adam Williamson 2012-10-03 13:40:53 EDT
Discussed at 2012-10-03 blocker review meeting: http://meetbot.fedoraproject.org/fedora-qa/2012-10-03/f18-beta-blocker-review-2.2012-10-03-16.00.log.txt . Rejected as a blocker, the only known practical impact of this is on suspend (closing lid of a laptop would suspend on close and then again on open, so you'd have to push power button), and suspend is generally not a blocker for Beta (there are no criteria for suspend, intentionally). We agreed to leave NTH status open, since there's still nearly a week before freeze anyway and this will in all likelihood get pushed before then.
Comment 8 Fedora Update System 2012-10-03 22:06:41 EDT
Package gnome-settings-daemon-3.6.0-4.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing gnome-settings-daemon-3.6.0-4.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-15224/gnome-settings-daemon-3.6.0-4.fc18
then log in and leave karma (feedback).
Comment 9 Fedora Update System 2012-10-09 05:39:49 EDT
gnome-settings-daemon-3.6.1-2.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/gnome-settings-daemon-3.6.1-2.fc18
Comment 10 Lukas Zachar 2012-10-11 10:22:34 EDT
*** Bug 865362 has been marked as a duplicate of this bug. ***
Comment 11 Fedora Update System 2012-12-20 10:56:26 EST
gnome-settings-daemon-3.6.0-4.fc18 has been pushed to the Fedora 18 obsolete repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.