This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 865362 - Suspend after the lid close resumes in two phases.
Suspend after the lid close resumes in two phases.
Status: CLOSED DUPLICATE of bug 859224
Product: Fedora
Classification: Fedora
Component: upower (Show other bugs)
18
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Richard Hughes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-11 05:47 EDT by Lukas Zachar
Modified: 2012-10-11 10:22 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-11 10:22:34 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
pm-utils-bugreport-info output (3.15 KB, application/octet-stream)
2012-10-11 05:47 EDT, Lukas Zachar
no flags Details
power --monitor-detail output (20.07 KB, text/plain)
2012-10-11 05:48 EDT, Lukas Zachar
no flags Details
upowerd -v output (46.95 KB, text/plain)
2012-10-11 05:48 EDT, Lukas Zachar
no flags Details
dmesg output (184.29 KB, text/plain)
2012-10-11 05:49 EDT, Lukas Zachar
no flags Details

  None (edit)
Description Lukas Zachar 2012-10-11 05:47:11 EDT
Created attachment 625456 [details]
pm-utils-bugreport-info output

Description of problem:

When I close the lid the laptop suspends correctly. The power led starts blinking. I open the lid and for a few seconds I see the desktop. Then it suspends automatically again. After the consequent close/open of the lid or power button press the laptop resumes and stays resumed.

Experienced on the pm-test day lived and with updated upower too. After the update I killed gdm, upowerd, upower so it should reload it correctly.

I tried to run /usr/libexec/upowerd -v and upower --monitor-detail from the terminal and it resumed correctly. 
But when I tried to run systemctl start upower.service the consequent close/open lid issue reappears, and even following tries (after the stopping the systemd service) of upowerd from the terminal we not successful any more.

Version-Release number of selected component (if applicable):
upower-0.9.17-2, upower-0.9.18-1.fc18.x86_64

How reproducible:
always

Steps to Reproduce:
1. close lid
2. open lid
3.
  
Actual results:
Laptop is resumed, desktop is shown for 1-2 sec. Then it suspends on its own again. Consequent resume works and laptop stays resumed.

Expected results:
Laptop is resumed and stays awake.

Additional info:
Smolt profile: http://www.smolts.org/client/show/pub_339e87bc-c2c3-433b-89f1-82defdf4d6f7
Comment 1 Lukas Zachar 2012-10-11 05:48:05 EDT
Created attachment 625457 [details]
power --monitor-detail output
Comment 2 Lukas Zachar 2012-10-11 05:48:38 EDT
Created attachment 625458 [details]
upowerd -v output
Comment 3 Lukas Zachar 2012-10-11 05:49:08 EDT
Created attachment 625467 [details]
dmesg output
Comment 4 Juhamatti Niemelä 2012-10-11 06:05:11 EDT
I have this same issue with pm-test-day livecd on Lenovo Thinkpad Edge. Smolt profile: http://www.smolts.org/client/show/pub_5c5f65fb-d013-4ccb-9e7b-dfbbacd0b87c
Comment 5 Lukas Zachar 2012-10-11 09:30:18 EDT
It works flawlessly with gnome-settings-daemon-3.6.1-2.fc18.
Comment 6 Lukas Zachar 2012-10-11 10:22:34 EDT

*** This bug has been marked as a duplicate of bug 859224 ***

Note You need to log in before you can comment on or make changes to this bug.