Bug 859264 - ibus-typing-booster setup is not enabled in ibus-setup
ibus-typing-booster setup is not enabled in ibus-setup
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: ibus-typing-booster (Show other bugs)
17
All Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: anish
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-20 20:05 EDT by Mike FABIAN
Modified: 2015-04-12 19:12 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-09-24 06:37:39 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
preferences-disabled-for-ibus-typing-booster.png (60.33 KB, image/png)
2012-09-20 20:05 EDT, Mike FABIAN
no flags Details
preferences-in-ibus-setup-for-ibus-typing-booster-work-on-f18.png (548.25 KB, image/png)
2012-09-24 06:36 EDT, Mike FABIAN
no flags Details

  None (edit)
Description Mike FABIAN 2012-09-20 20:05:59 EDT
Created attachment 615190 [details]
preferences-disabled-for-ibus-typing-booster.png

See attached screenshot.

The preferences button is disabled when 
ibus-typing-booster is selected in the “ibus-setup” program.
Comment 1 Mike FABIAN 2012-09-20 20:16:04 EDT
I added some debug “print” statements to /usr/share/ibus/setup/main.py
like this:

mfabian@ari:/usr/share/ibus/setup
$ diff -U 5  main.py.~1~ main.py
--- main.py.~1~	2012-08-22 14:11:48.000000000 +0200
+++ main.py	2012-09-20 17:54:50.188641435 +0200
@@ -281,18 +281,25 @@
     def __get_engine_setup_exec_args(self, engine):
         args = []
         if engine == None:
            return args
         setup = str(engine.get_setup())
+        print "mike setup=%(setup)s" %{'setup': setup}
         if len(setup) != 0:
             args = setup.split()
             args.insert(1, path.basename(args[0]))
+            print "mike args=%s" %args
             return args
         name = str(engine.get_name())
+        print "mike name=%(name)s" %{'name': name}
+        #if name == 'en_US':
+        #    print "mike changing name ..."
+        #    name = 'typing-booster:en_US'
         libexecdir = os.environ['IBUS_LIBEXECDIR']
         setup_path = (libexecdir + '/' + 'ibus-setup-' if libexecdir != None \
             else 'ibus-setup-') + name.split(':')[0]
+        print "mike name=%(name)s setup_path=%(setup_path)s" %{'name': name, 'setup_path': setup_path}
         if path.exists(setup_path):
             args.append(setup_path)
             args.append(path.basename(setup_path))
         return args
 
mfabian@ari:/usr/share/ibus/setup

And when I now start “ibus-setup” from the command line, I see:

    mfabian@ari:/usr/share/ibus/setup
    $ ibus-setup
    mike setup=
    mike name=en_US
    mike name=en_US setup_path=/usr/libexec/ibus-setup-en_US

I.e. engine.get_setup() returns nothing and then it falls back to
what engine.get_name(), which is just “en_US” and then tries
/usr/libexec/ibus-setup-en_US as the path of the setup binary, which
doesn’t exist.

What exists is:

    mfabian@ari:~
    $ ls /usr/libexec/ibus-setup-typing-booster 
    /usr/libexec/ibus-setup-typing-booster*
    mfabian@ari:~
    $ 

I.e. either engine.get_setup() should return the correct binary,
or alternatively, engine.get_name() could return
something like

    “typing-booster:en_US”

then it works.
Comment 2 Mike FABIAN 2012-09-24 06:32:57 EDT
Apparently this problem appeared for me on f17 because
I had the following obsolete packages installed:

ibus-european-table
english-typing-booster
ibus-typing-booster
hindi-typing-booster-inscript
marathi-typing-booster-inscript
bengali-typing-booster-phonetic
gujarati-typing-booster-inscript
marathi-typing-booster-phonetic
bengali-typing-booster-probhat
hindi-typing-booster-phonetic
bengali-typing-booster-inscript
gujarati-typing-booster-phonetic
tamil-typing-booster-inscript

After I deleted all these packages and installed
*only* the latest version of ibus-typing-booster

ibus-typing-booster-0.0.9

the setup button works for me.
Comment 3 Mike FABIAN 2012-09-24 06:36:22 EDT
Created attachment 616462 [details]
preferences-in-ibus-setup-for-ibus-typing-booster-work-on-f18.png

Also works on f18.
Comment 4 Mike FABIAN 2012-09-24 06:37:39 EDT
So this bug seems to be invalid because I saw it only
in old packages which are deprecated anyway.
Comment 5 Mike FABIAN 2012-09-24 06:38:18 EDT
bug#858980 remains on f18 though.

Note You need to log in before you can comment on or make changes to this bug.